Re: [ovs-dev] [post-8024 1/5] Prepend "nw_" to "frag" and "tos" elements.

2011-11-10 Thread Ben Pfaff
On Thu, Nov 10, 2011 at 05:46:26PM -0800, Justin Pettit wrote: > > and maybe we should even change the > > member name in struct ofp_match to nw_dscp (or whatever you like). > > > As you know, the interplay of TOS and DSCP in OpenFlow are a passion > of mine. I've kept that field name "nw_tos",

[ovs-dev] [PATCH 2/2] net-netlink: Add lockdep_genl_is_held().

2011-11-10 Thread Pravin B Shelar
OVS uses genl_mutex locking to protect datapath data-structures like flow-table, flow-actions. Following patch adds lockdep_genl_is_held() which is used for rcu annotation to prove locking. Signed-off-by: Pravin B Shelar --- include/linux/genetlink.h |3 +++ net/netlink/genetlink.c |8

[ovs-dev] [PATCH 1/2] net-netlink: add genl_notify()

2011-11-10 Thread Pravin B Shelar
Open vSwitch uses Generic Netlink interface for communication between userspace and kernel module. genl_notify() is used for sending notification of back to userspace. genl_notify() is analogous to rtnl_notify() but uses genl_sock instead of rtnl. Signed-off-by: Pravin B Shelar --- include/net/

Re: [ovs-dev] [PATCH] datapath: Don't use Nicira's OUI for generating mac-address.

2011-11-10 Thread Jesse Gross
On Thu, Nov 10, 2011 at 2:11 PM, Pravin B Shelar wrote: > Signed-off-by: Pravin B Shelar > --- >  datapath/tunnel.c             |    2 +- >  datapath/vport-generic.c      |   13 - >  datapath/vport-generic.h      |    1 - >  datapath/vport-internal_dev.c |    2 +- >  datapath/vport-pa

Re: [ovs-dev] [mirror 03/13] ofproto-dpif: Make compose_mirror_dsts() harder to screw up.

2011-11-10 Thread Justin Pettit
Looks good. --Justin On Oct 26, 2011, at 10:09 AM, Ben Pfaff wrote: > I came close to add a "continue;" inside the main "while" loop in > compose_mirror_dsts(), which would have turned it into an infinite loop. > This commit changes it to a "for" loop that is harder to screw up. > --- > ofproto

Re: [ovs-dev] [mirror 02/13] ofproto-dpif: Remove duplicate VLAN logic.

2011-11-10 Thread Justin Pettit
On Oct 26, 2011, at 10:09 AM, Ben Pfaff wrote: > @@ -4810,6 +4821,7 @@ is_admissible(struct ofproto_dpif *ofproto, const > struct flow *flow, > { The comment for is_admissable() seems out of date. It refers to "in_portp", but I'm guessing it should be referring to "in_bundlep". Also, I think

Re: [ovs-dev] [PATCH] datapath: Remove actions.h

2011-11-10 Thread Jesse Gross
On Thu, Nov 10, 2011 at 2:14 PM, Pravin B Shelar wrote: > There are only two symbols in actions.h. Compatibility function > is moved to compat.h and execute_actions() declaration is moved > to datapath.h > > Signed-off-by: Pravin B Shelar Acked-by: Jesse Gross __

Re: [ovs-dev] [PATCH] datapath: Use skb_copy_and_csum_dev() to csum upcall packet.

2011-11-10 Thread Jesse Gross
On Thu, Nov 10, 2011 at 2:07 PM, Pravin B Shelar wrote: > Signed-off-by: Pravin B Shelar > --- >  datapath/datapath.c |   21 ++--- >  1 files changed, 2 insertions(+), 19 deletions(-) Acked-by: Jesse Gross ___ dev mailing list dev@open

Re: [ovs-dev] [mirror 01/13] ofproto-dpif: Do not output RSPAN packets to SPAN ports.

2011-11-10 Thread Justin Pettit
Looks good. --Justin On Oct 26, 2011, at 10:09 AM, Ben Pfaff wrote: > It's always been my intention that ports used as port mirroring > destinations (SPAN) be reserved solely for that purpose. When SPAN and > RSPAN are both configured, however, RSPAN mirror packets could get directed > to SPAN

Re: [ovs-dev] [post-8024 5/5] flow: htons() zero initializers to make their size more clear.

2011-11-10 Thread Justin Pettit
On Nov 10, 2011, at 9:04 AM, Ben Pfaff wrote: > Looks good to me, thanks. Thanks for the reviews. I pushed the series. --Justin ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [post-8024 4/5] flow: Use FWW_ flags to wildcard IP DSCP and ECN.

2011-11-10 Thread Justin Pettit
On Nov 10, 2011, at 9:03 AM, Ben Pfaff wrote: > I'm not sure that we care about using exactly the same naming as the > OpenFlow 1.0 document. Our header file diverged years ago and now I > imagine that the diff is practically the whole file. That's true. As I mentioned earlier, I'd still prefer

Re: [ovs-dev] [post-8024 1/5] Prepend "nw_" to "frag" and "tos" elements.

2011-11-10 Thread Justin Pettit
On Nov 10, 2011, at 8:51 AM, Ben Pfaff wrote: > On Wed, Nov 09, 2011 at 11:59:08PM -0800, Justin Pettit wrote: >> Most of the members in structures referring to network elements indicate >> the layer (e.g., "tl_", "nw_", "tp_"). The "frag" and "tos" members >> didn't, so this commit add them. >

Re: [ovs-dev] [PATCH] ovs-test: A new tool that allows to diagnose connectivity and performance issues

2011-11-10 Thread Ansis Atteka
On Tue, Nov 1, 2011 at 11:18 AM, Ben Pfaff wrote: > On Mon, Oct 31, 2011 at 04:38:51PM -0700, Ansis Atteka wrote: > > This tool will be a replacement for the current ovs-vlan-test > > utility. Besides from connectivity issues it will also be able > > to detect performance related issues in Open v

Re: [ovs-dev] [PATCH 2/2] datapath: Removal of kernel compatibility code for upstreaming

2011-11-10 Thread Pravin Shelar
On Thu, Nov 10, 2011 at 11:30 AM, Jesse Gross wrote: > On Wed, Nov 9, 2011 at 6:40 PM, Pravin B Shelar wrote: >> Following patch deletes OVS compatibility code related to older kernel, >> bridge, vlan etc and rearranges it for upstreaming. >> >> This patch is against OVS upstream kernel tree. >>

Re: [ovs-dev] [PATCH] datapath: Remove unnecessary definition of is_internal_vport()

2011-11-10 Thread Jesse Gross
On Thu, Nov 10, 2011 at 2:00 PM, Pravin B Shelar wrote: > Signed-off-by: Pravin B Shelar > --- >  datapath/vport-internal_dev.c |    5 - >  datapath/vport-internal_dev.h |    2 -- >  2 files changed, 0 insertions(+), 7 deletions(-) Acked-by: Jesse Gross _

[ovs-dev] [PATCH] datapath: Remove actions.h

2011-11-10 Thread Pravin B Shelar
There are only two symbols in actions.h. Compatibility function is moved to compat.h and execute_actions() declaration is moved to datapath.h Signed-off-by: Pravin B Shelar --- datapath/Modules.mk |1 - datapath/actions.c |1 - datapath/actions.h | 28 da

[ovs-dev] [PATCH] datapath: Don't use Nicira's OUI for generating mac-address.

2011-11-10 Thread Pravin B Shelar
Signed-off-by: Pravin B Shelar --- datapath/tunnel.c |2 +- datapath/vport-generic.c | 13 - datapath/vport-generic.h |1 - datapath/vport-internal_dev.c |2 +- datapath/vport-patch.c|2 +- 5 files changed, 3 insertions(+), 17 deletions(

[ovs-dev] [PATCH] datapath: Use skb_copy_and_csum_dev() to csum upcall packet.

2011-11-10 Thread Pravin B Shelar
Signed-off-by: Pravin B Shelar --- datapath/datapath.c | 21 ++--- 1 files changed, 2 insertions(+), 19 deletions(-) diff --git a/datapath/datapath.c b/datapath/datapath.c index 5660f2d..6ebe7a0 100644 --- a/datapath/datapath.c +++ b/datapath/datapath.c @@ -335,21 +335,6 @@ out

[ovs-dev] [PATCH] datapath: Remove unnecessary definition of is_internal_vport()

2011-11-10 Thread Pravin B Shelar
Signed-off-by: Pravin B Shelar --- datapath/vport-internal_dev.c |5 - datapath/vport-internal_dev.h |2 -- 2 files changed, 0 insertions(+), 7 deletions(-) diff --git a/datapath/vport-internal_dev.c b/datapath/vport-internal_dev.c index 26b432b..bc7b70e 100644 --- a/datapath/vport-i

Re: [ovs-dev] [PATCH 2/2] datapath: Removal of kernel compatibility code for upstreaming

2011-11-10 Thread Jesse Gross
On Wed, Nov 9, 2011 at 6:40 PM, Pravin B Shelar wrote: > Following patch deletes OVS compatibility code related to older kernel, > bridge, vlan etc and rearranges it for upstreaming. > > This patch is against OVS upstream kernel tree. > > Signed-off-by: Pravin B Shelar > Bug #7561 This one is le

Re: [ovs-dev] [PATCH] classifier: Use HMAP_FOR_EACH, HMAP_FOR_EACH_CONTINUE.

2011-11-10 Thread Ethan Jackson
Looks good. Ethan On Wed, Nov 9, 2011 at 16:24, Ben Pfaff wrote: > I like how this removes over 20 lines of code and ends up more readable. > --- >  lib/classifier.c |   30 +++--- >  1 files changed, 3 insertions(+), 27 deletions(-) > > diff --git a/lib/classifier.c b/lib

Re: [ovs-dev] [PATCH 2/2] datapath: Removal of kernel compatibility code for upstreaming

2011-11-10 Thread Jesse Gross
On Thu, Nov 10, 2011 at 11:02 AM, Pravin Shelar wrote: > On Wed, Nov 9, 2011 at 8:17 PM, Jesse Gross wrote: >> On Wed, Nov 9, 2011 at 6:40 PM, Pravin B Shelar wrote: >>> Following patch deletes OVS compatibility code related to older kernel, >>> bridge, vlan etc and rearranges it for upstreaming

Re: [ovs-dev] [PATCH 2/2] datapath: Removal of kernel compatibility code for upstreaming

2011-11-10 Thread Pravin Shelar
On Wed, Nov 9, 2011 at 8:17 PM, Jesse Gross wrote: > On Wed, Nov 9, 2011 at 6:40 PM, Pravin B Shelar wrote: >> Following patch deletes OVS compatibility code related to older kernel, >> bridge, vlan etc and rearranges it for upstreaming. >> >> This patch is against OVS upstream kernel tree. >> >>

Re: [ovs-dev] [PATCH] ovs-ofctl: Document behavior when table=255 is specified.

2011-11-10 Thread Justin Pettit
Looks good. --Justin On Nov 10, 2011, at 9:09 AM, Ben Pfaff wrote: > Reported-by: Michael Mao > --- > utilities/ovs-ofctl.8.in |6 +++--- > 1 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/utilities/ovs-ofctl.8.in b/utilities/ovs-ofctl.8.in > index cd8d4f2..531fd9c 100644

Re: [ovs-dev] Statistics Collection Performance Impact

2011-11-10 Thread Ben Pfaff
On Thu, Nov 10, 2011 at 06:04:07PM +0900, Simon Horman wrote: > On Wed, Nov 09, 2011 at 08:14:36PM -0800, Ben Pfaff wrote: > > On Thu, Nov 10, 2011 at 10:20:24AM +0900, Simon Horman wrote: > > > On Wed, Nov 09, 2011 at 01:19:42PM -0800, Ben Pfaff wrote: > > > > On Mon, Nov 07, 2011 at 04:20:19PM +0

Re: [ovs-dev] [PATCH] debian: Strip epoch from version number used in directory names.

2011-11-10 Thread Ben Pfaff
Thanks, I pushed it. On Wed, Nov 09, 2011 at 10:23:55AM -0800, Justin Pettit wrote: > Looks reasonable to me. > > --Justin > > > On Nov 9, 2011, at 8:35 AM, Ben Pfaff wrote: > > > This doesn't fix a visible bug, since there's no epoch in the Open vSwitch > > version used in Debian, but some Ni

Re: [ovs-dev] [PATCH 1/2] datapath: add genl_notify()

2011-11-10 Thread Jesse Gross
On Wed, Nov 9, 2011 at 6:40 PM, Pravin B Shelar wrote: >        This function is used for sending notification over > genl_sock. > > Signed-off-by: Pravin B Shelar > Bug #7561 Since this patch will be going upstream by itself can you please clean up the commit message: * The subject should be s

[ovs-dev] [PATCH] ovs-ofctl: Document behavior when table=255 is specified.

2011-11-10 Thread Ben Pfaff
Reported-by: Michael Mao --- utilities/ovs-ofctl.8.in |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/utilities/ovs-ofctl.8.in b/utilities/ovs-ofctl.8.in index cd8d4f2..531fd9c 100644 --- a/utilities/ovs-ofctl.8.in +++ b/utilities/ovs-ofctl.8.in @@ -447,10 +447,10 @@

Re: [ovs-dev] [post-8024 5/5] flow: htons() zero initializers to make their size more clear.

2011-11-10 Thread Ben Pfaff
Looks good to me, thanks. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [post-8024 4/5] flow: Use FWW_ flags to wildcard IP DSCP and ECN.

2011-11-10 Thread Ben Pfaff
On Wed, Nov 09, 2011 at 11:59:11PM -0800, Justin Pettit wrote: > It's no longer necessary to maintain a "nw_tos_mask" wildcard member, > since we only care about completely wildcarding the DSCP and ECN > portions of the IP TOS field. This commit makes that change. It also > goes a bit further in

Re: [ovs-dev] [post-8024 3/5] ofp-util: Rename MAY_IPV6_ADDR to MAY_IPV6.

2011-11-10 Thread Ben Pfaff
On Wed, Nov 09, 2011 at 11:59:10PM -0800, Justin Pettit wrote: > The MAY_IPV6_ADDR function now includes the IPv6 flow label, so it is > clearer to just call it MAY_IPV6. Looks good to me. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/m

Re: [ovs-dev] [post-8024 2/5] classifier: Don't check masks when adding IPv4/IPv6 addresses.

2011-11-10 Thread Ben Pfaff
On Wed, Nov 09, 2011 at 11:59:09PM -0800, Justin Pettit wrote: > The meta-flow code enforces IPv4/IPv6 masks, so there's no reason to do > it again in the classifier. This allows a number of functions to be > removed, since the only callers were in this classifier code. Looks good to me.

Re: [ovs-dev] [post-8024 1/5] Prepend "nw_" to "frag" and "tos" elements.

2011-11-10 Thread Ben Pfaff
On Wed, Nov 09, 2011 at 11:59:08PM -0800, Justin Pettit wrote: > Most of the members in structures referring to network elements indicate > the layer (e.g., "tl_", "nw_", "tp_"). The "frag" and "tos" members > didn't, so this commit add them. The nw_tos members of struct flow and struct ofp_match

Re: [ovs-dev] Statistics Collection Performance Impact

2011-11-10 Thread Simon Horman
On Wed, Nov 09, 2011 at 08:14:36PM -0800, Ben Pfaff wrote: > On Thu, Nov 10, 2011 at 10:20:24AM +0900, Simon Horman wrote: > > On Wed, Nov 09, 2011 at 01:19:42PM -0800, Ben Pfaff wrote: > > > On Mon, Nov 07, 2011 at 04:20:19PM +0900, Simon Horman wrote: > > > > Although a very simple and possibly n