Re: [ovs-dev] [PATCH] dpif: Improve logging of upcalls.

2011-06-08 Thread Ethan Jackson
Looks Good. Ethan On Wed, Jun 8, 2011 at 14:04, Ben Pfaff wrote: > The kernel now provides the entire flow key for a packet sent up to > userspace, but dpif_recv() would only log the in_port.  This change makes > userspace log the entire flow key. > > This would have made a bug that I recently l

Re: [ovs-dev] [PATCH 3/3] ofp-parse: Ignore extra fields produced by dump-flows.

2011-06-08 Thread Ethan Jackson
Looks Good. Ethan On Wed, Jun 8, 2011 at 13:41, Ben Pfaff wrote: > It's reasonable to want to dump a flow table with "dump-flows" and then > later use that output as input to other commands that read flows, but until > now that hasn't been directly possible because "dump-flows" adds extra > fiel

Re: [ovs-dev] [PATCH 2/3] ofp-print: Change "table_id" to "table" in flow_mod and flow_stats.

2011-06-08 Thread Ethan Jackson
Looks Good to me. I wonder if it make sense to change table_id to table in the internal data structures as well so things are consistent? Ethan On Wed, Jun 8, 2011 at 13:41, Ben Pfaff wrote: > Flow dumps printed the OpenFlow table ID under the name "table_id", but > the flow parser only accepte

[ovs-dev] [PATCH] tests: Unit test autopath action parsing.

2011-06-08 Thread Ethan Jackson
--- tests/ovs-ofctl.at |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/tests/ovs-ofctl.at b/tests/ovs-ofctl.at index a7d3b84..8b15f9c 100644 --- a/tests/ovs-ofctl.at +++ b/tests/ovs-ofctl.at @@ -121,6 +121,7 @@ actions=note:41.42.43,note:00.01.02.03.04.05.06.07,note tun_

Re: [ovs-dev] [PATCH 1/3] ofp-parse: Add support for vlan_tci field.

2011-06-08 Thread Ethan Jackson
Looks Good. Ethan On Wed, Jun 8, 2011 at 13:41, Ben Pfaff wrote: > Until now, the flow parser has supported dl_vlan and dl_vlan_pcp but not > the fully maskable vlan_tci that NXM allows.  This adds that support. > --- >  lib/ofp-parse.c          |   36 >  tes

[ovs-dev] [PATCH] vlog: Output configuration list in alphabetical order.

2011-06-08 Thread Justin Pettit
--- lib/vlog.c | 13 - 1 files changed, 12 insertions(+), 1 deletions(-) diff --git a/lib/vlog.c b/lib/vlog.c index 4f6523f..265e9c6 100644 --- a/lib/vlog.c +++ b/lib/vlog.c @@ -29,6 +29,7 @@ #include "dirs.h" #include "dynamic-string.h" #include "sat-math.h" +#include "svec.h"

[ovs-dev] (PMC)生产计划与物料控制

2011-06-08 Thread 生产计划与物料控制高级研修班
PMC生产计划与物料控制高级研修班 时间地点:2011年6月25-26日深圳 2011年7月14-15日苏州 2011年7月23-24日深圳 2011年7月28-29日北京 主办单位:智源培训(www.zhiyuanpx.com) 学员对象:生产总监、生产经理、生产计划相关人员、车间主任、物料主管、采 购主管及相关人员. 费  用:2800/人(含授课费、资料费、会务费、午餐费) 联系电话: 上海:021 -- 5109 3280 周小姐钱先生 深圳

Re: [ovs-dev] [brcompatd 8/8] ovs-brcompatd: Run ovs-vsctl instead of accessing database directly.

2011-06-08 Thread Ben Pfaff
On Wed, Jun 08, 2011 at 02:04:11PM -0700, Jesse Gross wrote: > On Wed, Jun 8, 2011 at 1:47 PM, Ben Pfaff wrote: > > On Wed, Jun 08, 2011 at 01:05:45PM -0700, Jesse Gross wrote: > >> On Mon, Jun 6, 2011 at 12:41 PM, Ben Pfaff wrote: > >> > ovs-vsctl is carefully written to avoid races in database

Re: [ovs-dev] [PATCH 1/2] datapath: IP fragments should include L4 header in flow length.

2011-06-08 Thread Jesse Gross
On Wed, Jun 8, 2011 at 1:51 PM, Ben Pfaff wrote: > On Wed, Jun 08, 2011 at 01:21:41PM -0700, Jesse Gross wrote: >> If we can't parse a header because it is invalid or not present due to >> fragmentation, we still need to include the length of that header when >> comparing the flow key.  The value

Re: [ovs-dev] [brcompatd 8/8] ovs-brcompatd: Run ovs-vsctl instead of accessing database directly.

2011-06-08 Thread Jesse Gross
On Wed, Jun 8, 2011 at 1:47 PM, Ben Pfaff wrote: > On Wed, Jun 08, 2011 at 01:05:45PM -0700, Jesse Gross wrote: >> On Mon, Jun 6, 2011 at 12:41 PM, Ben Pfaff wrote: >> > ovs-vsctl is carefully written to avoid races in database access. ??It is >> > much simpler to just call it than to reimplement

[ovs-dev] [PATCH] dpif: Improve logging of upcalls.

2011-06-08 Thread Ben Pfaff
The kernel now provides the entire flow key for a packet sent up to userspace, but dpif_recv() would only log the in_port. This change makes userspace log the entire flow key. This would have made a bug that I recently looked at a bit easier to investigate. --- lib/dpif.c | 42

Re: [ovs-dev] [bisected] every IP fragment now goes to userspace

2011-06-08 Thread Ben Pfaff
On Wed, Jun 08, 2011 at 11:19:36AM -0700, Jesse Gross wrote: > On Wed, Jun 8, 2011 at 10:51 AM, Ben Pfaff wrote: > > I accidentally discovered that on "master" every IP fragment ends up > > being sent to userspace. ??My test case is "netperf -H 192.168.0.2 -t > > UDP_STREAM" (which generates 64 kB

Re: [ovs-dev] [PATCH 2/2] datapath: Remove redundant nw_ prefix from fields in flow key.

2011-06-08 Thread Ben Pfaff
On Wed, Jun 08, 2011 at 01:21:42PM -0700, Jesse Gross wrote: > The fields of the kernel flow key are now grouped by protocol rather > than using generic names. The containing structures describe the > category, so it is no longer necessary to use prefixes. Most of > these prefixes have been remov

Re: [ovs-dev] [PATCH 1/2] datapath: IP fragments should include L4 header in flow length.

2011-06-08 Thread Ben Pfaff
On Wed, Jun 08, 2011 at 01:21:41PM -0700, Jesse Gross wrote: > If we can't parse a header because it is invalid or not present due to > fragmentation, we still need to include the length of that header when > comparing the flow key. The value of the field will be zero to > indicate that header was

Re: [ovs-dev] [brcompatd 8/8] ovs-brcompatd: Run ovs-vsctl instead of accessing database directly.

2011-06-08 Thread Ben Pfaff
On Wed, Jun 08, 2011 at 01:05:45PM -0700, Jesse Gross wrote: > On Mon, Jun 6, 2011 at 12:41 PM, Ben Pfaff wrote: > > ovs-vsctl is carefully written to avoid races in database access. ??It is > > much simpler to just call it than to reimplement its capabilities. > > > > This eliminates the requirem

[ovs-dev] [PATCH 2/3] ofp-print: Change "table_id" to "table" in flow_mod and flow_stats.

2011-06-08 Thread Ben Pfaff
Flow dumps printed the OpenFlow table ID under the name "table_id", but the flow parser only accepted "table". This makes them consistent by changing the output. (Another alternative would be to change the accepted input name.) [CCing people and groups who I know parse ovs-ofctl output.] CC: Pau

[ovs-dev] [PATCH 1/3] ofp-parse: Add support for vlan_tci field.

2011-06-08 Thread Ben Pfaff
Until now, the flow parser has supported dl_vlan and dl_vlan_pcp but not the fully maskable vlan_tci that NXM allows. This adds that support. --- lib/ofp-parse.c | 36 tests/ovs-ofctl.at |2 ++ utilities/ovs-ofctl.8.in | 37 +

[ovs-dev] [PATCH 3/3] ofp-parse: Ignore extra fields produced by dump-flows.

2011-06-08 Thread Ben Pfaff
It's reasonable to want to dump a flow table with "dump-flows" and then later use that output as input to other commands that read flows, but until now that hasn't been directly possible because "dump-flows" adds extra fields that other commands reject on input. This changes the flow parser to jus

[ovs-dev] [PATCH 2/2] datapath: Remove redundant nw_ prefix from fields in flow key.

2011-06-08 Thread Jesse Gross
The fields of the kernel flow key are now grouped by protocol rather than using generic names. The containing structures describe the category, so it is no longer necessary to use prefixes. Most of these prefixes have been removed but nw_proto and nw_tos have retained them. This renames the fiel

[ovs-dev] [PATCH 1/2] datapath: IP fragments should include L4 header in flow length.

2011-06-08 Thread Jesse Gross
If we can't parse a header because it is invalid or not present due to fragmentation, we still need to include the length of that header when comparing the flow key. The value of the field will be zero to indicate that header was not present, rather than effectively wildcarding the value. However

Re: [ovs-dev] [brcompatd 8/8] ovs-brcompatd: Run ovs-vsctl instead of accessing database directly.

2011-06-08 Thread Jesse Gross
On Mon, Jun 6, 2011 at 12:41 PM, Ben Pfaff wrote: > ovs-vsctl is carefully written to avoid races in database access.  It is > much simpler to just call it than to reimplement its capabilities. > > This eliminates the requirement that bridges managed by ovs-brcompatd have > no ports at ovs-brcompa

Re: [ovs-dev] [bisected] every IP fragment now goes to userspace

2011-06-08 Thread Jesse Gross
On Wed, Jun 8, 2011 at 10:51 AM, Ben Pfaff wrote: > I accidentally discovered that on "master" every IP fragment ends up > being sent to userspace.  My test case is "netperf -H 192.168.0.2 -t > UDP_STREAM" (which generates 64 kB UDP packets), then observing that > the datapath "miss" counter goes

[ovs-dev] [bisected] every IP fragment now goes to userspace

2011-06-08 Thread Ben Pfaff
I accidentally discovered that on "master" every IP fragment ends up being sent to userspace. My test case is "netperf -H 192.168.0.2 -t UDP_STREAM" (which generates 64 kB UDP packets), then observing that the datapath "miss" counter goes up quickly while the "hit" counter stays put, as well as no

Re: [ovs-dev] [PATCH 3/3] ofp-parse: Add support for dl_dst masks in flow match parsing.

2011-06-08 Thread Paul Ingram
Thanks Ben. :: psi On Jun 7, 2011, at 4:54 PM, Ben Pfaff wrote: > Thank you for the reviews. I pushed this series. > > On Tue, Jun 07, 2011 at 04:36:13PM -0700, Ethan Jackson wrote: >> Looks Good. >> >> Ethan >> >> On Mon, Jun 6, 2011 at 14:28, Ben Pfaff wrote: >>> This makes it possible to

Re: [ovs-dev] [PATCH] xenserver: Collect xenserver configured timezone in bugtool report

2011-06-08 Thread Ben Pfaff
On Tue, Jun 07, 2011 at 03:47:35PM -0700, Sajjad Lateef wrote: > xenserver logs can be in any timezone, as configured by user > during install time. Also, the timezone data is not currently > recorded in the bugtool report. Therefore, it is currently not > possible to easily correlate logs collecte

Re: [ovs-dev] [brcompatd 8/8] ovs-brcompatd: Run ovs-vsctl instead of accessing database directly.

2011-06-08 Thread Ben Pfaff
On Tue, Jun 07, 2011 at 06:22:03PM -0700, Ethan Jackson wrote: > The patch seems fine. I had one thought which may or may not be valuable. > > In reading send_ifindex_reply() and get_bridge_intefaces() I thought > that it might be valuable to implement a function which converts a " > \t\r\n" deli