Really cool Chris, I already did not follow yet, but I'll do soon.
I could suggest to make another page as a follow up with simple steps for
people creating a project from scratch with mavenized FlexJS , since create
a basic pom, and so on...
I think better if it was IDE oriented (and I'll suggest
I think it was user error. I checked out the repo and checked out master
instead of develop by mistake.
I just switched to develop and I’m trying again…
On Jul 21, 2016, at 11:27 PM, Alex Harui wrote:
> Try syncing up the flex-typedefs repo, or delete it and it should bring it
> down again. I
The how-to seems real easy :) I will give it a try later today!
And my original issue with the timeouts somehow fixed itself today, those
tests complete in under a minute now! I forgot the golden rule of Windows:
If something doesn't work right, try a reboot.
On Thu, Jul 21, 2016 at 9:34 PM, Chri
Hello. Cna anybody share with his socket experience.
For 2 days im trying to make sockets and no results
always 2031 ioerror and 2048 secureerror
added
Security.loadPolicyFile(url to crossdomain.xml);
Security.allowDomain("*");
Security.allowInsecureDomain(("*");
got secureerror from Security.all
OK, it appears to be working for me again.
-Alex
On 7/21/16, 6:50 AM, "Alex Harui" wrote:
>OK, will look into it.
>
>On 7/20/16, 10:59 PM, "yishayw" wrote:
>
>>It fails on Copy FalconJX SDK files
>>
>>Here's the install log:
>>
>>Installer version 3.2.0 (windows)
>>Using Locale: en_US
>>Fetche
Try syncing up the flex-typedefs repo, or delete it and it should bring it
down again. I don't think there is any on line #29 in js/build.xml that
could generate that error.
-Alex
On 7/21/16, 1:12 PM, "Harbs" wrote:
>Here’s the result of trying to run "ant all" on flex-asjs:
>
>check-typedefs-
I'll check out the defines for the example.
Regarding Cordova. That was more a comment to myself. There is a Maven plugin,
but that sucks ;-) I'll probably whip up something myself
Chris
Von meinem Samsung Galaxy Smartphone gesendet.
Ursprüngliche Nachricht
Von: Alex Harui
Here’s the result of trying to run "ant all" on flex-asjs:
check-typedefs-home:
[echo] FLEXJS_TYPEDEFS_HOME is
/Users/harbs/Documents/ApacheFlex/flex-typedefs
[available] DEPRECATED - used to override an existing property.
[available] Build file should not reuse the same property name for
On 7/20/16, 7:06 AM, "Christofer Dutz" wrote:
>Well I found improvements in 3 of the examples, still not all of them are
>bug-free but at least now two more modules have no JS issues that I could
>find.
I forgot to mention that for DataBindingExample_as, it appears that the JS
version is being
On 7/21/16, 11:56 AM, "Harbs" wrote:
>I’m with you.
>
>If the transform stuff has too much overhead, I’d do it as a Bead. We’ll
>see how it goes…
>
>Let’s discuss this some more once we’ve done some of this implementation
>so there’s something concrete to discuss.
Sounds good. IIRC, some of t
I’m with you.
If the transform stuff has too much overhead, I’d do it as a Bead. We’ll see
how it goes…
Let’s discuss this some more once we’ve done some of this implementation so
there’s something concrete to discuss.
On Jul 21, 2016, at 9:54 PM, Alex Harui wrote:
>
>
> On 7/21/16, 11:38
On 7/21/16, 11:38 AM, "Harbs" wrote:
>The standard in SVG is declarative. The standard in Canvas is functional
>(very similar to the Flash APIs). Here’s a good write-up comparing Flash
>to Canvas.[1]
Thanks for the link.
IMO, at the lowest level, I would pretty much implement the Canvas API
a
The standard in SVG is declarative. The standard in Canvas is functional (very
similar to the Flash APIs). Here’s a good write-up comparing Flash to Canvas.[1]
I would like to present a unified API so SVG and Canvas could be swapped out
for each other. So for SVG, my idea is to construct the mar
On 7/21/16, 8:20 AM, "Peter Ent" wrote:
>
>Anyway - left with a dilemma: make the CreateJS package easy for people
>familiar with CreateJS to use and somehow shoehorn in SWF compatibility or
>decide on a common API for both CreateJS and SWF and use that. It would
>mean anyone interested in using
On 7/21/16, 10:19 AM, "Harbs" wrote:
>Unless folks have a problem with it, I’m going to try and refactor some
>naming. If what I do is too drastic, we can revert my changes…
>
>I’ll try and keep my changes in clearly separate commits. I can do it on
>a feature branch if folks prefer.
Well, I'm
Unless folks have a problem with it, I’m going to try and refactor some naming.
If what I do is too drastic, we can revert my changes…
I’ll try and keep my changes in clearly separate commits. I can do it on a
feature branch if folks prefer.
On Jul 21, 2016, at 7:21 PM, Alex Harui wrote:
>
>
Although, I’d probably rename the function to drawPathString() to make it clear
that it’s different than the Flash implementation.
On Jul 21, 2016, at 7:25 PM, Harbs wrote:
> Yes. drawPath is an exception. But curveTo, quadraticCurveTo, etc.should
> behave as it did in Flash.
>
> On Jul 21, 2
draw is called inside GraphicShape.addToParent().
Overriding draw is what you did in Ellipse, and I think that makes more sense.
On Jul 21, 2016, at 6:34 PM, Peter Ent wrote:
> The addedToParent() function is called when a Circle is put onto the
> display list; draw wouldn't be called then.
>
Yes. drawPath is an exception. But curveTo, quadraticCurveTo, etc.should behave
as it did in Flash.
On Jul 21, 2016, at 7:21 PM, Alex Harui wrote:
>
>
> On 7/21/16, 7:06 AM, "Harbs" wrote:
>
>> For svg and canvas, the drawing commands map pretty cleanly to their HTML
>> counterparts, so it
On 7/21/16, 7:06 AM, "Harbs" wrote:
>For svg and canvas, the drawing commands map pretty cleanly to their HTML
>counterparts, so it would be pretty clean.
I haven't spent any serious time thinking about it. Just quickly, I saw
flash.display.Graphics.drawPath which seems quite different from S
On 7/21/16, 7:09 AM, "Peter Ent" wrote:
>I agree with Alex in most respects, but have a couple of other
>suggestions, below.
>
>I think the basic package should wrap (thinly, as possible) HTML/JS and
>the SWF implementation mimic that but it doesn't necessarily need to have
>the same names as H
The addedToParent() function is called when a Circle is put onto the
display list; draw wouldn't be called then.
‹peter
On 7/21/16, 5:40 AM, "Harbs" wrote:
>Is there a reason addedToParent() is overridden instead of draw()?
>
>Harbs
Thanks, Chris.
So we have a little dilemma here. When I built the CreateJS project and
the example to go with it, I mimicked a CreateJS tutorial. Two tutorials
in fact: one that puts up a blue circle and one that moves and fades said
circle.
The example follows closely to how you would think of u
I agree with Alex in most respects, but have a couple of other
suggestions, below.
I think the basic package should wrap (thinly, as possible) HTML/JS and
the SWF implementation mimic that but it doesn't necessarily need to have
the same names as HTML/JS uses and can be more platform agnostic.
I
For svg and canvas, the drawing commands map pretty cleanly to their HTML
counterparts, so it would be pretty clean.
In fact, this is pretty much what GraphicsContainer currently does, but I’m
talking about completing the support and naming it to be more indicative of
what it is.
Basically, If
On 7/21/16, 3:00 AM, "Harbs" wrote:
>3. I’d like an interface which mimics the Flash APIs as closely as
>possible. It might not make sense to have every element have a “graphics”
>object because it could inflate things unnecessarily, but I’m thinking
>that it might make sense to rename Graphic
OK, will look into it.
On 7/20/16, 10:59 PM, "yishayw" wrote:
>It fails on Copy FalconJX SDK files
>
>Here's the install log:
>
>Installer version 3.2.0 (windows)
>Using Locale: en_US
>Fetched the SDK download mirror URL from the CGI.
>SDK version Apache FlexJS Nightly
>AIR version 21.0
>Flash P
Harbs-4 wrote
> I have a few issues with the graphics package which I wanted to discuss:
>
> 1. The package name. It’s currently using a generic name, and ultimately,
> I think we’re going to want separate packages for SVG and Canvas. Since
> it’s currently using SVG, I would propose to change the
I have a few issues with the graphics package which I wanted to discuss:
1. The package name. It’s currently using a generic name, and ultimately, I
think we’re going to want separate packages for SVG and Canvas. Since it’s
currently using SVG, I would propose to change the name to
org.apache.f
Is there a reason addedToParent() is overridden instead of draw()?
Harbs
Ok ... just finished the how-to:
https://cwiki.apache.org/confluence/display/FLEX/Building+FlexJS+with+Maven
I'd appreciate feedback ;-)
Chris
Von: Greg Dove
Gesendet: Donnerstag, 21. Juli 2016 08:56:53
An: dev@flex.apache.org
Betreff: Re: [Falcon] Quick sanit
Well that info was for locally creating a Flex SDK using the Mavenizer, I think
you wanted to know how to build a FlexJS SDK using Maven, am I correct?
I just finished writing down a step-by-step guide to build FlexJS with Maven
here:
https://cwiki.apache.org/confluence/display/FLEX/Building+F
32 matches
Mail list logo