Hi David,
Please see inline.
Thanks,
Anoob
> -Original Message-
> From: Coyle, David
> Sent: Monday, September 11, 2023 9:32 PM
> To: Anoob Joseph ; dev@dpdk.org
> Cc: Ji, Kai ; O'Sullivan, Kevin ;
> Jerin Jacob Kollanukkaran
> Subject: RE: [EXT] [PATCH v2 0/2] crypto/scheduler: add su
On Tue, 12 Sep 2023 19:52:39 +0800
Min Zhou wrote:
> diff --git a/app/test/test_hash_readwrite.c
> b/app/test/test_hash_readwrite.c index 74ca13912f..4997a01249 100644
> --- a/app/test/test_hash_readwrite.c
> +++ b/app/test/test_hash_readwrite.c
> @@ -162,7 +162,7 @@ init_params(int use_ext, int
> -Original Message-
> From: Wu, Wenjun1
> Sent: Wednesday, September 13, 2023 1:57 PM
> To: Su, Simei ; Wu, Jingjing ;
> Xing, Beilei ; Zhang, Qi Z
> Cc: dev@dpdk.org
> Subject: RE: [PATCH v3] common/idpf: refactor single queue Tx function
>
>
>
> > -Original Message-
> > F
This patch fixes the issue where device id first 0 does not print.
Fixes: e4f27af0f448 ("bus/pci: reduce boot-up logs to absolute minimum")
Cc: sta...@dpdk.org
Signed-off-by: Qiming Yang
---
drivers/bus/pci/pci_common.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers
This patch fixed the issue which the link status still up
when the link status changed from up to downi after device
restart.
Fixes: fdcf92ed6637 ("net/ice: fix link status recovery")
Cc: sta...@dpdk.org
Signed-off-by: Qiming Yang
---
drivers/net/ice/ice_ethdev.c | 2 ++
1 file changed, 2 inser
On Wed, Sep 13, 2023 at 3:30PM, Stephen Hemminger wrote:
On Tue, 12 Sep 2023 19:52:39 +0800
Min Zhou wrote:
diff --git a/app/test/test_hash_readwrite.c
b/app/test/test_hash_readwrite.c index 74ca13912f..4997a01249 100644
--- a/app/test/test_hash_readwrite.c
+++ b/app/test/test_hash_readwrite
Acked-by: Hemant Agrawal
> -Original Message-
> From: Vargas, Hernan
> Sent: Wednesday, September 13, 2023 2:03 AM
> To: Hemant Agrawal ; Chautru, Nicolas
> ; dev@dpdk.org; maxime.coque...@redhat.com
> Cc: Rix, Tom ; david.march...@redhat.com
> Subject: RE: [PATCH v2 5/5] devtools: ignor
The main effect of this patch series is to
remove calls to pthread functions except for pthread_cancel and locks.
The function rte_thread_create_control() does not take thread attributes
settings anymore as it looks a useless complication of the API.
Then the rte_thread API is made stable,
so we c
All pthread functions below have an equivalent in rte_thread API:
- pthread_create
- pthread_join
- pthread_detach
- pthread_setname_np
- pthread_set_name_np
- pthread_setaffinity_np
- pthread_attr_setinheritsched
- pthread_attr_setsch
RTE_MAX_THREAD_NAME_LEN is including the NUL character,
so it should be named "size" instead of "length".
A new constant RTE_THREAD_NAME_SIZE is introduced for naming accuracy.
For API compatibility, the old name is kept.
At the same time, the original definition is moved
from rte_eal.h to rte_thr
The experimental function rte_thread_create_control()
is supposed to wrap actions needed to create a control thread in DPDK.
This function should be easy to port on any OS.
As such, the thread attributes should not be customizable in this API.
The thread priority should be normal, and the affinity
The rte_thread API must be used to ease OS porting.
One step of this process is to mark the necessary API as stable.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
doc/guides/rel_notes/release_23_11.rst | 1 +
lib/eal/include/rte_thread.h | 64 --
In order to make sure all threads created in DPDK drivers and libraries
have the same prefix in their name, some wrapper functions are added
for internal use when creating a control thread or setting a thread name:
- rte_thread_create_internal_control
- rte_thread_set_prefixed_name
Calls to rte_ctrl_thread_create() are replaced with
rte_thread_create_internal_control().
Other pthread-related functions are replaced with the rte_thread API.
Only pthread_cancel() has no replacement.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
lib/eal/
Calls to rte_ctrl_thread_create() are replaced with
rte_thread_create_internal_control().
Other pthread-related functions are replaced with the rte_thread API.
Only pthread_cancel() has no replacement.
The mlx5 vDPA control threads were real-time threads
with an affinity on the core specified by t
Calls to rte_ctrl_thread_create() are replaced with
rte_thread_create_control().
In vhost_blk, the control thread is not forced
to be scheduled on core 0 anymore.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
examples/vhost/main.c | 9 +
Calls to pthread for thread creation are replaced with the rte_thread API.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
app/test/process.h | 10 +-
app/test/test_lcores.c | 9 -
app/test/test_pdump.c | 6 +++---
app/test/test_pdump.
The deprecated functions rte_thread_setname() and rte_ctrl_thread_create()
are replaced with the new rte_thread API:
rte_thread_setname()
can be replaced with
rte_thread_set_name()
or rte_thread_set_prefixed_name()
rte_ctrl_thread_create()
can be replaced with
The header files should have the minimum embedded includes.
The file pthread.h can logically be removed from
rte_per_lcore.h and rte_ethdev_core.h files.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
Acked-by: Ajit Khaparde
Acked-by: Rosen Xu
---
app/test/te
John Romein writes:
> getenv needs stdlib.h to be included.
>
> Bugzilla ID: 1133
>
> Fixes: 24c77594e08f ("gpu/cuda: map GPU memory with GDRCopy")
> Signed-off-by: John Romein
> ---
Hi John,
Thanks so much for the contribution. It looks like the patch got
corrupted by something. Please chec
> -Original Message-
> From: Jie Hai
> Subject: [PATCH v4 6/7] app/proc-info: support querying RSS hash algorithm
>
> Display RSS hash algorithm with command show-port as below.
> - RSS info
> -- hash algorithm : toeplitz
>
> Signed-off-by: Jie Hai
> Signed-off-by: Dongdong
> -Original Message-
> From: Jie Hai
> Sent: Friday, September 8, 2023 9:00 AM
> To: dev@dpdk.org; Pattan, Reshma
> Cc: haij...@huawei.com; lihuis...@huawei.com
> Subject: [PATCH v4 6/7] app/proc-info: support querying RSS hash algorithm
>
> Display RSS hash algorithm with command sho
The main effect of this patch series is to
remove calls to pthread functions except for pthread_cancel and locks.
The function rte_thread_create_control() does not take thread attributes
settings anymore as it looks a useless complication of the API.
Then the rte_thread API is made stable,
so we c
All pthread functions below have an equivalent in rte_thread API:
- pthread_create
- pthread_join
- pthread_detach
- pthread_setname_np
- pthread_set_name_np
- pthread_setaffinity_np
- pthread_attr_setinheritsched
- pthread_attr_setsch
RTE_MAX_THREAD_NAME_LEN is including the NUL character,
so it should be named "size" instead of "length".
A new constant RTE_THREAD_NAME_SIZE is introduced for naming accuracy.
For API compatibility, the old name is kept.
At the same time, the original definition is moved
from rte_eal.h to rte_thr
The experimental function rte_thread_create_control()
is supposed to wrap actions needed to create a control thread in DPDK.
This function should be easy to port on any OS.
As such, the thread attributes should not be customizable in this API.
The thread priority should be normal, and the affinity
The rte_thread API must be used to ease OS porting.
One step of this process is to mark the necessary API as stable.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
doc/guides/rel_notes/release_23_11.rst | 1 +
lib/eal/include/rte_thread.h | 64 --
In order to make sure all threads created in DPDK drivers and libraries
have the same prefix in their name, some wrapper functions are added
for internal use when creating a control thread or setting a thread name:
- rte_thread_create_internal_control
- rte_thread_set_prefixed_name
Calls to rte_ctrl_thread_create() are replaced with
rte_thread_create_internal_control().
Other pthread-related functions are replaced with the rte_thread API.
Only pthread_cancel() has no replacement.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
lib/eal/
Calls to rte_ctrl_thread_create() are replaced with
rte_thread_create_internal_control().
Other pthread-related functions are replaced with the rte_thread API.
Only pthread_cancel() has no replacement.
The mlx5 vDPA control threads were real-time threads
with an affinity on the core specified by t
Calls to rte_ctrl_thread_create() are replaced with
rte_thread_create_control().
In vhost_blk, the control thread is not forced
to be scheduled on core 0 anymore.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
examples/vhost/main.c | 9 +
Calls to pthread for thread creation are replaced with the rte_thread API.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
---
app/test/process.h | 10 +-
app/test/test_lcores.c | 9 -
app/test/test_pdump.c | 6 +++---
app/test/test_pdump.
The deprecated functions rte_thread_setname() and rte_ctrl_thread_create()
are replaced with the new rte_thread API:
rte_thread_setname()
can be replaced with
rte_thread_set_name()
or rte_thread_set_prefixed_name()
rte_ctrl_thread_create()
can be replaced with
The header files should have the minimum embedded includes.
The file pthread.h can logically be removed from
rte_per_lcore.h and rte_ethdev_core.h files.
Signed-off-by: Thomas Monjalon
Acked-by: Morten Brørup
Acked-by: Tyler Retzlaff
Acked-by: Ajit Khaparde
Acked-by: Rosen Xu
---
app/test/te
> -Original Message-
> From: Jie Hai
> Sent: Friday, September 8, 2023 9:00 AM
> To: dev@dpdk.org; Pattan, Reshma ; Vipin
> Varghese ; Mcnamara, John
>
> Cc: haij...@huawei.com; lihuis...@huawei.com
> Subject: [PATCH v4 4/7] app/proc-info: fix never show RSS info
>
> Command show-port
> -Original Message-
> From: Jie Hai
> Subject: [PATCH v4 5/7] app/proc-info: adjust the display format of RSS info
>
> Signed-off-by: Jie Hai
Acked-by: Reshma Pattan
Enable 32 bit build on x86 Linux. Fixed build warnings and errors
when building in 32 bit.
Cc: sta...@dpdk.org
Signed-off-by: Wei Hu
---
v2: change port casting from size_t to uintptr_t.
---
drivers/net/mana/mana.c | 2 +-
drivers/net/mana/meson.build | 4 ++--
drivers/net/mana/mr.c
+Chris Brezovec
Hi Maxime,
Chris from our team is attending the DPDK Summit in Dublin this week. If you
have some time available, we'd appreciate it if he could meet with you to
discuss the 32bit virtio issue we are seeing.
Regards,
Roger Melton
On 9/6/23 2:57 PM, Dave Johnson (davejo) wrote
From: Jiayu Hu
Update the email address for gro and gso libraries.
Signed-off-by: Jiayu Hu
---
MAINTAINERS | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 698608cdb2..8b00ae4711 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -1481,12 +1481
The LA12XX driver was not linked to the dpdk-test-bbdev tool because of
what looks like a rebase issue.
Fixes: 2b504721bfda ("app/bbdev: enable la12xx")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
app/test-bbdev/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff -
RTE_LIBRTE_SECURITY has been replaced with RTE_LIB_SECURITY for a
while now.
Fixes: b1bbf222bef1 ("crypto/dpaa_sec: add debug prints")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
drivers/crypto/dpaa_sec/dpaa_sec.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git
RTE_LIBRTE_SECURITY has been replaced with RTE_LIB_SECURITY for a
while now.
Fixes: 84bb24bd058c ("crypto/dpaa2_sec: add debug prints")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
drivers/crypto/dpaa2_sec/dpaa2_sec_dpseci.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
di
config_flag_fmt was used in the past and was dropped with commit
762bfccc8abf ("config: remove compatibility build defines").
Fixes: fa8f86a14e2e ("common/cnxk: add build infrastructre and HW definition")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
drivers/common/cnxk/meson.build | 1
Commit 1e728b01120c ("net/iavf: rework Tx path") reintroduced a check on
RTE_LIBRTE_IAVF_DEBUG_TX that has been dropped in favor of
RTE_ETHDEV_DEBUG_TX.
Fixes: 1e728b01120c ("net/iavf: rework Tx path")
Cc: sta...@dpdk.org
Signed-off-by: David Marchand
---
drivers/net/iavf/iavf_rxtx.c | 2 +-
1
On 2023-09-11 16:28, Sevincer, Abdullah wrote:
Mattias,
Yes that’s correct.
There is no way to cleaner and more robust way to achieve the same
result? For example, by accessing /proc, or better, an DPDK abstraction
of the same.
-Original Message-
From: Mattias Rönnblom
Sent: Fri
Acked-by: Nicolas Chautru
> -Original Message-
> From: David Marchand
> Sent: Wednesday, September 13, 2023 6:59 AM
> To: dev@dpdk.org
> Cc: maxime.coque...@redhat.com; sta...@dpdk.org; Chautru, Nicolas
> ; Hemant Agrawal ;
> Akhil Goyal
> Subject: [PATCH] app/bbdev: fix link with NXP L
> -Original Message-
> From: Mattias Rönnblom
> Sent: Wednesday, September 13, 2023 10:48 AM
> To: Sevincer, Abdullah ; Stephen Hemminger
> ; tho...@monjalon.net
> Cc: dev@dpdk.org; Tyler Retzlaff
> Subject: Re: quick thread in DLB2
>
> On 2023-09-11 16:28, Sevincer, Abdullah wrote:
>
> Subject: [PATCH 1/1] net/mana: add 32 bit short doorbell
>
> Add 32 bit short doorbell support. Ring short doorbell when running in 32 bit
> applicactions.
>
> Cc: sta...@dpdk.org
>
> Signed-off-by: Wei Hu
Please send this patch to
Ferruh Yigit
Andrew Rybchenko
> ---
> drivers/net/mana
> -Original Message-
> From: Zhang, Qi Z
> Sent: Wednesday, September 13, 2023 3:46 PM
> To: Wu, Wenjun1 ; Su, Simei ;
> Wu, Jingjing ; Xing, Beilei
> Cc: dev@dpdk.org
> Subject: RE: [PATCH v3] common/idpf: refactor single queue Tx function
>
>
>
> > -Original Message-
> > F
1. Refine single queue Tx data path for idpf common module.
2. Refine Tx queue setup for idpf pmd.
3. Refine Tx queue setup for cpfl pmd.
v4:
* Split one patch into patchset.
* Refine commit title and commit log.
v3:
* Change context TSO descriptor from base mode to flex mode.
v2:
* Refine commi
This patch refines Tx single queue setup to align with Tx data path.
Signed-off-by: Simei Su
Acked-by: Wenjun Wu
---
drivers/net/idpf/idpf_rxtx.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/idpf/idpf_rxtx.c b/drivers/net/idpf/idpf_rxtx.c
index 3e3d81ca6d..64f
Currently, single queue Tx data path uses flex Tx data descriptor
which is changed in the latest idpf spec. This patch replaces flex
Tx data descriptor with base Tx data descriptor for single queue Tx
data path.
Signed-off-by: Simei Su
Acked-by: Wenjun Wu
---
drivers/common/idpf/idpf_common_rxt
This patch refines Tx single queue setup to align with Tx data path.
Signed-off-by: Simei Su
Acked-by: Wenjun Wu
---
drivers/net/cpfl/cpfl_rxtx.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/cpfl/cpfl_rxtx.c b/drivers/net/cpfl/cpfl_rxtx.c
index 2ef6871a85..ab8
> -Original Message-
> From: Su, Simei
> Sent: Thursday, September 14, 2023 9:50 AM
> To: Wu, Jingjing ; Xing, Beilei
> ; Zhang, Qi Z
> Cc: dev@dpdk.org; Wu, Wenjun1 ; Su, Simei
>
> Subject: [PATCH v4 0/3] refactor single queue Tx data path
>
> 1. Refine single queue Tx data path for
> -Original Message-
> From: Yang, Qiming
> Sent: Wednesday, September 13, 2023 5:02 PM
> To: dev@dpdk.org
> Cc: Zhang, Qi Z ; Yang, Qiming
> ; sta...@dpdk.org
> Subject: [PATCH] net/ice: fix initail link status issue
s/initail/initial
>
> This patch fixed the issue which the link sta
> -Original Message-
> From: David Marchand
> Sent: Wednesday, September 13, 2023 10:03 PM
> To: dev@dpdk.org
> Cc: sta...@dpdk.org; Wu, Jingjing ; Xing, Beilei
> ; Doherty, Declan ;
> Sinha, Abhijit ; Nicolau, Radu
>
> Subject: [PATCH] net/iavf: fix Tx debug
>
> Commit 1e728b01120c (
> -Original Message-
> From: Long Li
> Sent: Thursday, September 14, 2023 5:11 AM
> To: Wei Hu ; dev@dpdk.org; Ferruh Yigit
> ; Andrew Rybchenko
>
> Cc: sta...@dpdk.org
> Subject: RE: [PATCH 1/1] net/mana: add 32 bit short doorbell
>
> > +
> > +/*
> > + * Write to hardware doorbell to no
Currently, single queue Tx data path uses flex Tx data
descriptor(DTYPE3) which is removed in the latest idpf spec.
This patch replaces flex Tx data descriptor with base Tx data
descriptor for single queue Tx data path and refines Tx single
queue setup to align with Tx data path.
Signed-off-by: Si
58 matches
Mail list logo