Hi Chaoyong,
On 2023-09-18 10:45:48 +0800, Chaoyong He wrote:
> Each parameter of function should occupy one line, and indent two TAB
> character.
> All the statement which span multi line should indent two TAB character.
>
> Signed-off-by: Chaoyong He
> Reviewed-by: Niklas
I'm resigning as NFP maintainer as I'm leaving Corigine. Update the
MAINTAINERS file to reflect this.
Signed-off-by: Niklas Söderlund
---
MAINTAINERS | 1 -
1 file changed, 1 deletion(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 698608cdb26a..308bcc175786 100644
--- a/MAINTAI
On 2023-07-07 18:57:12 -0700, Stephen Hemminger wrote:
> Replace explicit packet offset computations with rte_pktmbuf_mtod_offset().
>
> Signed-off-by: Stephen Hemminger
Reviewed-by: Niklas Söderlund
> ---
> drivers/net/nfp/flower/nfp_flower_cmsg.h | 3 ++-
> driv
have 1 or 2 R-b tags when
we post to the list. We have an internal review and CI pipeline we run
patches thru to reduce the noise at the list and to not waste upstream
review resources.
We follow the DPDK workflow internally before we submit patches to the
public mailing list. I hope we can continue to do so and add R-b tags,
as they represent real effort by the developers.
>
> It looks like there were additional reviewers of code, which is good,
> but it requires maintainers' (you and Chas) ack to get accepted.
>
--
Kind Regards,
Niklas Söderlund
Hi Stephen,
Thanks for your work.
On 2023-06-01 08:01:03 -0700, Stephen Hemminger wrote:
> Suggested by devtools/cocci/strlcpy-with-header.cocci
>
> Signed-off-by: Stephen Hemminger
Reviewed-by: Niklas Söderlund
> ---
> drivers/net/nfp/flower/nfp_flower_representor.c | 4
te mode 100644 drivers/net/nfp/nfpcore/nfp-common/nfp_platform.h
> delete mode 100644 drivers/net/nfp/nfpcore/nfp-common/nfp_resid.h
> create mode 100644 drivers/net/nfp/nfpcore/nfp_target.c
>
> --
> 2.39.1
>
--
Kind Regards,
Niklas Söderlund
Hi Stephen,
Thanks for your work.
On 2023-05-06 09:03:56 -0700, Stephen Hemminger wrote:
> Automatically generated by cocci/mtod-offset.cocci.
>
> Signed-off-by: Stephen Hemminger
Reviewed-by: Niklas Söderlund
> ---
> drivers/net/nfp/flower/nfp_flower_cmsg.h | 3 ++-
>
> drivers/net/bonding/version.map | 8
> 8 files changed, 155 insertions(+)
>
> --
> 2.39.1
>
--
Kind Regards,
Niklas Söderlund
(ERR, "MTU (%u) larger than current mbufsize (%u)
> > not supported",
> > mtu, hw->flbufsz);
> > return -ERANGE;
> > }
>
> Patch looks good but this looks like unrelated whitespace change.
It's a tad unrelated, but not a whitespace change. It fixes a spelling
mistake related to setting the MTU,
s/then/than/g
--
Kind Regards,
Niklas Söderlund
Hi Kevin,
Thanks for your input.
On 2023-02-16 10:28:34 +, Kevin Traynor wrote:
> On 15/02/2023 18:28, Ferruh Yigit wrote:
> > On 2/15/2023 5:47 PM, Niklas Söderlund wrote:
> > > Hi Ferruh,
> > >
> > > Thanks for your continues effort in dealing with NFP
ntent changes among formatting changes.
>
> (You can include simple grammar updates (that doesn't change either
> content or Corigine related information) to formatting update patch)
We will break this patch in to three as you suggest, address the
comments below and post a v2.
nding device capability. Is this a fix?
I agree this is a bit of a grey zone. We reasoned this was a fix as we
should have done this from the start in the commit that added support
for NFDk. Are you OK moving forward with this as a fix or would you
prefer we resubmit without the request to backport?
-
> drivers/net/mlx5/hws/mlx5dr_definer.c| 8 +++
> drivers/net/mlx5/mlx5_flow.c | 22 -
> drivers/net/mlx5/mlx5_flow_dv.c | 30 +---
> drivers/net/mlx5/mlx5_flow_verbs.c | 10
> drivers/net/nfp/nfp_flow.
mum compiler versions to support this change. Provided this is
sorted out as part of the full series to move to flex arrays, for the
change itself.
Acked-by: Niklas Söderlund
> ---
> drivers/net/nfp/flower/nfp_flower_cmsg.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> d
: sta...@dpdk.org
> >
> > Signed-off-by: Peng Zhang
> > Reviewed-by: Chaoyong He
> > Reviewed-by: Niklas Söderlund
> > ---
> >
> > v2:
> > * add fixline.
> >
>
> Updated commit log a little while merging, please check.
Thanks for
: Jin Liu
Reviewed-by: Chaoyong He
Reviewed-by: Niklas Söderlund
Signed-off-by: Niklas Söderlund
---
drivers/net/nfp/nfp_common.c | 86 ++--
drivers/net/nfp/nfp_common.h | 6 +++
drivers/net/nfp/nfp_rxtx.c | 51 ++---
drivers/net/nfp/nfp_rxtx.h
function to make sure
TSO works fine.
Fixes: c73dced48c8c ("net/nfp: add NFDk Tx")
Cc: sta...@dpdk.org
Signed-off-by: Fei Qin
Reviewed-by: Niklas Söderlund
Reviewed-by: Chaoyong He
Signed-off-by: Niklas Söderlund
---
drivers/net/nfp/nfp_rxtx.c | 2 ++
1 file changed, 2 insertion
inal code in next-net head?
It looks good, thanks for sorting that out.
>
> [1]
> https://patches.dpdk.org/project/dpdk/patch/20220922130314.694790-2-niklas.soderl...@corigine.com/
> [1/2] net/nfp: fix return value of nfp card init function
>
>
--
Kind Regards,
Niklas Söderlund
Hi,
Genteel ping on this.
On 2022-09-22 10:06:42 +0200, Niklas Söderlund wrote:
> From: Peng Zhang
>
> The method to fetch, sort and read the last entry of a list to figure
> out the total number of NUMA nodes in the system fails with 10 or more
> nodes. The reason being the
problems, a rte_mbuf will not be freed and it will cause memory leak.
Free the rte_mbuf before break out.
Fixes: b812daadad0d ("nfp: add Rx and Tx")
Cc: louis.pe...@corigine.com
Cc: sta...@dpdk.org
Signed-off-by: Long Wu
Reviewed-by: Chaoyong He
Reviewed-by: Niklas Söderlund
Signed-off-
Reviewed-by: Chaoyong He
Reviewed-by: Niklas Söderlund
Signed-off-by: Niklas Söderlund
---
drivers/net/nfp/nfp_ethdev.c| 36 +++--
drivers/net/nfp/nfp_ethdev_vf.c | 36 +++--
drivers/net/nfp/nfp_rxtx.c | 33
Hi all,
This small series aims to reduce code duplication by using a single
shared struct eth_dev_ops for NFDk and NFD3.
Patch 1/2 is a small bug fix that suck in when adding support for
NFP3800 where the error code is not correctly propagated.
Patch 2/2 is do the real work by merging the two
Jin Liu
Reviewed-by: Chaoyong He
Reviewed-by: Niklas Söderlund
Signed-off-by: Niklas Söderlund
---
drivers/net/nfp/nfp_ethdev.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/nfp/nfp_ethdev.c b/drivers/net/nfp/nfp_ethdev.c
index 2e546cfc5ffc..bc69840777eb 100644
-
support initialized
Fixes: 8ef09fdc506b ("build: add optional NUMA and CPU counts detection")
Cc: sta...@dpdk.org
Signed-off-by: Peng Zhang
Signed-off-by: Chaoyong He
Reviewed-by: Niklas Söderlund
---
buildtools/get-numa-count.py | 3 ++-
1 file changed, 2 insertions(+), 1 deleti
that patch separately I fear it
would create conflicts with the other patches in our queue. So I thin
either we drop this patch now and we pick it up at the end of our queue,
or we take this as is now. My preference would be to take it now, but
I'm not feeling strongly about it.
--
Kind Regards,
Niklas Söderlund
tc, please double
> check them in the next-net git repo.
Looks good, thanks!
--
Kind Regards,
Niklas Söderlund
statement.
> >
> > Signed-off-by: James Hershaw
> > Reviewed-by: Chaoyong He
> > Reviewed-by: Niklas Söderlund
> > ---
> > drivers/net/nfp/nfpcore/nfp_hwinfo.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> >
: James Hershaw
Reviewed-by: Niklas Söderlund
---
drivers/net/nfp/nfp_common.h| 2 ++
drivers/net/nfp/nfp_ethdev.c| 12
drivers/net/nfp/nfp_ethdev_vf.c | 8
3 files changed, 22 insertions(+)
diff --git a/drivers/net/nfp/nfp_common.h b/drivers/net/nfp/nfp_common.h
dd support for nfp cpp log print
> net/nfp: use dpdk debug macro to control nfp Rx/Tx log print
>
> drivers/net/nfp/nfp_common.c | 1 +
> drivers/net/nfp/nfp_logs.h | 9 ++---
> 2 files changed, 7 insertions(+), 3 deletions(-)
>
> --
> 1.8.3.1
>
--
Kind Regards,
Niklas Söderlund
ong He
> Reviewed-by: Niklas Söderlund
> ---
> drivers/net/nfp/nfpcore/nfp_hwinfo.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/net/nfp/nfpcore/nfp_hwinfo.c
> b/drivers/net/nfp/nfpcore/nfp_hwinfo.c
> index c0516bf..9f848bd 100644
> --
r.h
> create mode 100644 drivers/net/nfp/flower/nfp_flower_cmsg.c
> create mode 100644 drivers/net/nfp/flower/nfp_flower_cmsg.h
> create mode 100644 drivers/net/nfp/flower/nfp_flower_ctrl.c
> create mode 100644 drivers/net/nfp/flower/nfp_flower_ctrl.h
> create mode 100644 drivers/net/nfp/flower/nfp_flower_ovs_compat.h
> create mode 100644 drivers/net/nfp/flower/nfp_flower_representor.c
> create mode 100644 drivers/net/nfp/flower/nfp_flower_representor.h
>
> --
> 1.8.3.1
>
--
Kind Regards,
Niklas Söderlund
Fixes: 646ea79ce481 ("net/nfp: move PF functions into its own file")
> Cc: sta...@dpdk.org
>
> Signed-off-by: Peng Zhang
> Reviewed-by: Chaoyong He
> Reviewed-by: Niklas Söderlund
> ---
> drivers/net/nfp/nfp_ethdev.c | 4 +++-
> 1 file changed, 3 insertions(+),
cards.
--
Kind Regards,
Niklas Söderlund
features")
> Cc: sta...@dpdk.org
>
> Signed-off-by: Peng Zhang
> Signed-off-by: Yong Xu
> Signed-off-by: Chaoyong He
Reviewed-by: Niklas Söderlund
> ---
> drivers/net/nfp/nfp_common.c | 21 ++---
> 1 file changed, 10 insertions(+), 11 deletions(-)
&g
Hi Ferruh,
On 2022-04-27 10:47:03 +0100, Ferruh Yigit wrote:
> On 4/27/2022 9:37 AM, Niklas Söderlund wrote:
> > Hello,
> >
> > I have a question about the Checks that ran on this patch in patchwork
> > [1]. It appears the job ci/iol-x86_64-compile-testing,
> >
or NFP_FRAME_SIZE_MAX is derived for the maximum
> supported buffer size of 10240, minus 136 bytes that is reserved by the
> hardware and another 56 bytes reserved for expansion in firmware. This
> results in a usable maximum packet length of 10048 bytes.
>
> Signed-off-by: Wa
36 matches
Mail list logo