Hi all,

This small series aims to reduce code duplication by using a single 
shared struct eth_dev_ops for NFDk and NFD3.

Patch 1/2 is a small bug fix that suck in when adding support for 
NFP3800 where the error code is not correctly propagated.

Patch 2/2 is do the real work by merging the two existing structs and 
adding the small glue in the setup step that differenced them.

Jin Liu (2):
  net/nfp: fix return value of nfp card init function
  net/nfp: optimize ethdev struct

 drivers/net/nfp/nfp_ethdev.c    | 38 ++++-----------------------------
 drivers/net/nfp/nfp_ethdev_vf.c | 36 +++----------------------------
 drivers/net/nfp/nfp_rxtx.c      | 33 ++++++++++++++++++++++++++--
 drivers/net/nfp/nfp_rxtx.h      |  5 +----
 4 files changed, 39 insertions(+), 73 deletions(-)

-- 
2.37.3

Reply via email to