On 12/15/2016 12:04 PM, Jerin Jacob wrote:
On Sun, Dec 04, 2016 at 11:47:11PM +0530, Hemant Agrawal wrote:
Signed-off-by: Hemant Agrawal
---
drivers/net/dpaa2/base/dpaa2_hw_dpio.c | 74 ++
1 file changed, 74 insertions(+)
diff --git a/drivers/net/dpaa2/base/dpa
On Thu, Dec 15, 2016 at 12:07:51PM +0530, Shreyansh Jain wrote:
> On Thursday 15 December 2016 11:39 AM, Jerin Jacob wrote:
> > On Sun, Dec 04, 2016 at 11:47:12PM +0530, Hemant Agrawal wrote:
> > > DPBP represent a buffer pool instance in DPAA2-QBMAN
> > > HW accelerator.
> > >
> > > All buffers n
Hi, Thomas, Konstantin:
> -Original Message-
> From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Yang, Zhiyong
> Sent: Sunday, December 11, 2016 8:33 PM
> To: Ananyev, Konstantin ; Thomas
> Monjalon
> Cc: dev@dpdk.org; yuanhan@linux.intel.com; Richardson, Bruce
> ; De Lara Guarch,
On Thursday 15 December 2016 05:29 AM, Stephen Hemminger wrote:
Generalize existing bus support to handle VMBUS in Hyper-V.
Most of the code is based of existing model for PCI, the difference
is how bus is represented in sysfs and how addressing works.
This is based on earlier code contributed b
On Sun, Dec 04, 2016 at 11:47:03PM +0530, Hemant Agrawal wrote:
> Signed-off-by: Hemant Agrawal
Acked-by: Jerin Jacob
> ---
> mk/machine/dpaa2/rte.vars.mk | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/mk/machine/dpaa2/rte.vars.mk b/mk/machine/dpaa2/rte.vars.mk
On Thursday 15 December 2016 11:39 AM, Jerin Jacob wrote:
On Sun, Dec 04, 2016 at 11:47:12PM +0530, Hemant Agrawal wrote:
DPBP represent a buffer pool instance in DPAA2-QBMAN
HW accelerator.
All buffers needs to be programmed in the HW accelerator.
Signed-off-by: Hemant Agrawal
---
config/de
On Sun, Dec 04, 2016 at 11:47:11PM +0530, Hemant Agrawal wrote:
> Signed-off-by: Hemant Agrawal
> ---
> drivers/net/dpaa2/base/dpaa2_hw_dpio.c | 74
> ++
> 1 file changed, 74 insertions(+)
>
> diff --git a/drivers/net/dpaa2/base/dpaa2_hw_dpio.c
> b/drivers/net/d
On Sun, Dec 04, 2016 at 11:47:12PM +0530, Hemant Agrawal wrote:
> DPBP represent a buffer pool instance in DPAA2-QBMAN
> HW accelerator.
>
> All buffers needs to be programmed in the HW accelerator.
>
> Signed-off-by: Hemant Agrawal
> ---
> config/defconfig_arm64-dpaa2-linuxapp-gcc | 5 +
> d
On Sun, Dec 04, 2016 at 11:46:57PM +0530, Hemant Agrawal wrote:
> This patch intoduces the DPAA2 MC(Management complex Driver)
>
> This driver is common to be used by various DPAA2 net, crypto
> and other drivers
>
> Signed-off-by: Cristian Sovaiala
> [Hemant:rebase and conversion to library for
On Wed, Dec 14, 2016 at 10:55:34AM +0800, Yuanhan Liu wrote:
> On Wed, Dec 14, 2016 at 07:25:57AM +0530, Jerin Jacob wrote:
> > From: Santosh Shukla
> >
> > Replace the raw I/O device memory read/write access with eal
> > abstraction for I/O device memory read/write access to fix
> > portability
On Wed, Dec 14, 2016 at 11:02:23AM +0800, Yuanhan Liu wrote:
> On Wed, Dec 14, 2016 at 07:25:56AM +0530, Jerin Jacob wrote:
> > * Following macros are derived from linux/pci_regs.h, however,
> > * we can't simply include that header here, as there is no such
> > @@ -320,37 +322,37 @@ static con
Generalize existing bus support to handle VMBUS in Hyper-V.
Most of the code is based of existing model for PCI, the difference
is how bus is represented in sysfs and how addressing works.
This is based on earlier code contributed by Brocade.
It supports only 4.9 or later versions of the Linux ker
Allow sufficicent space for UUID in string form (36+1).
Needed to use UUID with Hyper-V
Signed-off-by: Stephen Hemminger
---
doc/guides/rel_notes/deprecation.rst | 3 +++
lib/librte_ether/rte_ethdev.h| 6 +-
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/doc/guides/rel
This is the core changes required to support VMBUS.
It does cause some ABI change to ethdev etc.
Stephen Hemminger (2):
ethdev: increase length ethernet device internal name
hyperv: VMBUS support infrastucture
doc/guides/rel_notes/deprecation.rst| 3 +
lib/librte_eal/common/Makefil
/build/lib/librte_eal/linuxapp/kni/igb_main.c:2317:21: error: initialization
from incompatible pointer type [-Werror=incompatible-pointer-types]
.ndo_set_vf_vlan = igb_ndo_set_vf_vlan,
^~~
I am sure Ferruh Yigit will fix it.
Which raises a couple of questio
> -Original Message-
> From: Ferruh Yigit [mailto:ferruh.yi...@intel.com]
> Sent: Wednesday, December 14, 2016 8:00 AM
> To: Yong Wang ; dev@dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v4] net/kni: add KNI PMD
>
> On 12/12/2016 9:59 PM, Yong Wang wrote:
> >> -Original Message-
> >> F
From: Paweł Małachowski
This allows for testing code which needs offloads to be supported.
Signed-off-by: Michał Mirosław
---
drivers/net/null/rte_eth_null.c | 23 ++-
1 file changed, 22 insertions(+), 1 deletion(-)
diff --git a/drivers/net/null/rte_eth_null.c b/drivers/ne
On 12/13/2016 1:08 AM, Michał Mirosław wrote:
> From: Piotr Bartosiewicz
>
> Signed-off-by: Michał Mirosław
> ---
Acked-by: Ferruh Yigit
On 12/14/2016 5:37 PM, Michał Mirosław wrote:
> On Wed, Dec 14, 2016 at 05:33:11PM +, Ferruh Yigit wrote:
>> On 12/13/2016 1:08 AM, Michał Mirosław wrote:
>>> Signed-off-by: Michał Mirosław
>>> ---
>>
>> Acked-by: Ferruh Yigit
>>
>> I guess no harm doing extra check on user input.
>
> This a
On Wed, Dec 14, 2016 at 05:33:11PM +, Ferruh Yigit wrote:
> On 12/13/2016 1:08 AM, Michał Mirosław wrote:
> > Signed-off-by: Michał Mirosław
> > ---
>
> Acked-by: Ferruh Yigit
>
> I guess no harm doing extra check on user input.
This actually prevents an OOPS that happens when you try to c
On 12/14/2016 5:35 PM, Ferruh Yigit wrote:
> On 12/14/2016 5:19 PM, Michał Mirosław wrote:
>> On Wed, Dec 14, 2016 at 05:06:23PM +, Ferruh Yigit wrote:
>>> Hi Michal,
>>>
>>> On 12/13/2016 1:08 AM, Michał Mirosław wrote:
Signed-off-by: Michał Mirosław
---
Acked-by: Ferruh Yigit
On 12/14/2016 5:19 PM, Michał Mirosław wrote:
> On Wed, Dec 14, 2016 at 05:06:23PM +, Ferruh Yigit wrote:
>> Hi Michal,
>>
>> On 12/13/2016 1:08 AM, Michał Mirosław wrote:
>>> Signed-off-by: Michał Mirosław
>>> ---
>>> lib/librte_eal/linuxapp/kni/kni_misc.c | 4 ++--
>>> 1 file changed, 2 ins
On 12/13/2016 1:08 AM, Michał Mirosław wrote:
> Signed-off-by: Michał Mirosław
> ---
Acked-by: Ferruh Yigit
I guess no harm doing extra check on user input.
On Wed, Dec 14, 2016 at 05:06:23PM +, Ferruh Yigit wrote:
> Hi Michal,
>
> On 12/13/2016 1:08 AM, Michał Mirosław wrote:
> > Signed-off-by: Michał Mirosław
> > ---
> > lib/librte_eal/linuxapp/kni/kni_misc.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/l
rte_acl_add_rules() has no way of checking rule size.
This was hidden because the test effectively checked that
adding a rule with userdata == 0 failed.
Signed-off-by: Michał Mirosław
---
app/test/test_acl.c | 20
1 file changed, 20 deletions(-)
diff --git a/app/test/test_
Signed-off-by: Michał Mirosław
---
v2: fixes prog_guide and ACL tests
---
app/test/test_acl.c | 13 -
doc/guides/prog_guide/packet_classif_access_ctrl.rst | 3 ++-
lib/librte_acl/rte_acl.c | 3 +--
lib/librte_acl/rte_acl.
Hi Michal,
On 12/13/2016 1:08 AM, Michał Mirosław wrote:
> Signed-off-by: Michał Mirosław
> ---
> lib/librte_eal/linuxapp/kni/kni_misc.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/lib/librte_eal/linuxapp/kni/kni_misc.c
> b/lib/librte_eal/linuxapp/kni/kni_misc.
On Wed, Dec 14, 2016 at 04:13:53PM +0100, tom.barbe...@ulg.ac.be wrote:
> Hi list,
>
> Between 2.2.0 and 16.04 (up to at least 16.07.2 if not current), with the
> XL710 controller I do not get any packet when calling rte_eth_rx_burst if
> nb_pkts is too small. I would say smaller than 32. The in
On 12/14/2016 01:54 PM, Adrien Mazarguil wrote:
>>
>>> + * @param[out] error
>>> + * Perform verbose error reporting if not NULL.
>>> + *
>>> + * @return
>>> + * 0 on success, a negative errno value otherwise and rte_errno is
>>> set.
>>> + */
>>> +int
>>>
On 12/12/2016 9:59 PM, Yong Wang wrote:
>> -Original Message-
>> From: Ferruh Yigit [mailto:ferruh.yi...@intel.com]
>> Sent: Wednesday, November 30, 2016 10:12 AM
>> To: dev@dpdk.org
>> Cc: Ferruh Yigit ; Yong Wang
>>
>> Subject: [PATCH v4] net/kni: add KNI PMD
>>
>> Add KNI PMD which wrap
Currently select() is used to monitor file descriptors for vhostuser
ports. This limits the number of ports possible to create since the
fd number is used as index in the fd_set and we have seen fds > 1023.
This patch changes select() to poll(). This way we can keep an
packed (pollfd) array for the
On Tue, Dec 06, 2016 at 09:22:15AM +0530, Jerin Jacob wrote:
> In a polling model, lcores poll ethdev ports and associated
> rx queues directly to look for packet. In an event driven model,
> by contrast, lcores call the scheduler that selects packets for
> them based on programmer-specified criter
On Wed, Dec 14, 2016 at 06:43:58PM +0530, Jerin Jacob wrote:
> On Thu, Dec 08, 2016 at 11:02:16AM +, Van Haaren, Harry wrote:
> > > From: Jerin Jacob [mailto:jerin.ja...@caviumnetworks.com]
> > > Sent: Thursday, December 8, 2016 1:24 AM
> > > To: Van Haaren, Harry
> >
> >
> >
> > > > * Oper
Hi list,
Between 2.2.0 and 16.04 (up to at least 16.07.2 if not current), with the XL710
controller I do not get any packet when calling rte_eth_rx_burst if nb_pkts is
too small. I would say smaller than 32. The input rate is not big, if that
helps. But It should definitely get at least one pac
Despite the issue with naming convention (either it will be writel or
write32), I'm fine with this change and new API.
Acked-by: Jan Medala
Jan
2016-12-14 2:55 GMT+01:00 Jerin Jacob :
> From: Santosh Shukla
>
> Replace the raw I/O device memory read/write access with eal
> abstraction for I
Hi Kevin,
On Wed, Dec 14, 2016 at 11:48:04AM +, Kevin Traynor wrote:
> hi Adrien, sorry for the delay
>
> <...>
>
>
> Is it expected that the application or pmd will provide locking between
> these functions if required? I think it's going to have to be the app.
> >>>
> >>> Lo
On Wed, Dec 14, 2016 at 10:53:57AM +0800, Yuanhan Liu wrote:
> On Wed, Dec 14, 2016 at 07:25:30AM +0530, Jerin Jacob wrote:
> > patchset 14-28: Replace the raw readl/writel in the drivers with
> > new rte_read[b/w/l/q], rte_write[b/w/l/q] eal abstraction
>
> Instead of rte_read[b/w/l/q], there is
On Thu, Dec 08, 2016 at 11:02:16AM +, Van Haaren, Harry wrote:
> > From: Jerin Jacob [mailto:jerin.ja...@caviumnetworks.com]
> > Sent: Thursday, December 8, 2016 1:24 AM
> > To: Van Haaren, Harry
>
>
>
> > > * Operation and sched_type *increased* to 4 bits each (from previous
> > > value o
Hi Michal,
> -Original Message-
> From: Michal Miroslaw [mailto:mirq-li...@rere.qmqm.pl]
> Sent: Wednesday, December 14, 2016 2:11 AM
> To: Ananyev, Konstantin
> Cc: dev@dpdk.org
> Subject: Re: [dpdk-dev] [PATCH 04/13] acl: allow zero verdict
>
> On Tue, Dec 13, 2016 at 09:55:12PM +,
hi Adrien, sorry for the delay
<...>
Is it expected that the application or pmd will provide locking between
these functions if required? I think it's going to have to be the app.
>>>
>>> Locking is indeed expected to be performed by applications. This API only
>>> documents places
On Wed, Dec 14, 2016 at 10:53:57AM +0800, Yuanhan Liu wrote:
> On Wed, Dec 14, 2016 at 07:25:30AM +0530, Jerin Jacob wrote:
> > patchset 14-28: Replace the raw readl/writel in the drivers with
> > new rte_read[b/w/l/q], rte_write[b/w/l/q] eal abstraction
>
> Instead of rte_read[b/w/l/q], there is
On Tuesday 13 December 2016 07:07 PM, Shreyansh Jain wrote:
These callbacks now act as first layer of PCI interfaces from the Bus.
Bus probe would enter the PMDs through the rte_driver->probe/remove
callbacks, falling to rte_xxx_driver->probe/remove (Currently, all the
drivers are rte_pci_driver)
Hey guys,
I'm using dpdk 16.4 and fm10k card. According to the code, there's no support
for disabling vlan stripping and VLAN QinQ in pmd fm10k.
Does anybody know why? If there's any way to work-around it, or when is a
behavior change expected?
I need my VF to receive the packets with the V
43 matches
Mail list logo