On Wed, 1 Feb 2023 07:21:10 GMT, Viktor Klang wrote:
>> This PR proposed to reduce contention in synchronized methods mainly by
>> doing I/O operations outside synch blocks.
>
> src/java.base/share/classes/java/lang/Module.java line 281:
>
>> 279:
>> 280: private static boolean isNativeAcc
On Tue, 31 Jan 2023 09:00:18 GMT, Alan Bateman wrote:
>> Hi @jaikiran ,
>> On my system OS's zlib is being used. and here is stack-trace.
>>
>> --System.out:(2/78)--
>> level:-1, strategy: 0, dowrap: false
>> m=525312, n=498060, len=524288, eq=false
>> --System.err:(11/58
On Wed, 25 Jan 2023 12:26:26 GMT, Per Minborg wrote:
> This PR proposed to reduce contention in synchronized methods mainly by doing
> I/O operations outside synch blocks.
src/java.base/share/classes/java/lang/Module.java line 281:
> 279:
> 280: private static boolean isNativeAccessEnable
On Sun, 29 Jan 2023 15:37:28 GMT, Glavo wrote:
> When the default Locale is `tr`, the jmod and jimage commands have the
> following problems:
>
> * The jmod command does not correctly recognize the `list` mode typed in
> lowercase;
> * The jimage command cannot obtain the help information of t
> `ResourceBundle.CacheKey.equals()` and `Bundles.CacheKey.equals()` are quire
> outdated. This simple clean-up modernizes them.
Sergey Tsypanov has updated the pull request incrementally with one additional
commit since the last revision:
Fix logic
-
Changes:
- all: https://g
> Another day, another PR to port FDLBIM to Java, this time for the log1p
> method.
>
> Other than using the two-argument form of the __HI method in Java
> transliteration version rather than C macro, there are no appreciable
> differences between the original C source in
>
> src/java.base/sh
On Tue, 31 Jan 2023 16:02:07 GMT, Per Minborg wrote:
>> `ZoneOffset` instances are cached by the `ZoneOffset` class itself for
>> values in the range [-18h, 18h] for each second that is on an even quarter
>> of an hour (i.e. at most 2*18*4+1 = 145 values).
>>
>> Instead of using a `Concurrent
On Wed, 1 Feb 2023 06:17:37 GMT, David Holmes wrote:
> I can't quite see the effect of the change here.
@minborg Have you used the wrong JBS issue by any chance? There is no
information in the JBS issue, or here, that the proposed change fixes the
reported startup regression after the JEP 434
On Wed, 25 Jan 2023 12:26:26 GMT, Per Minborg wrote:
> This PR proposed to reduce contention in synchronized methods mainly by doing
> I/O operations outside synch blocks.
I can't quite see the effect of the change here. You went from a synchronized
instance method, to a non-synchronized stati
On Tue, 31 Jan 2023 09:00:18 GMT, Alan Bateman wrote:
>> Hi @jaikiran ,
>> On my system OS's zlib is being used. and here is stack-trace.
>>
>> --System.out:(2/78)--
>> level:-1, strategy: 0, dowrap: false
>> m=525312, n=498060, len=524288, eq=false
>> --System.err:(11/58
On Sun, 29 Jan 2023 15:37:28 GMT, Glavo wrote:
> When the default Locale is `tr`, the jmod and jimage commands have the
> following problems:
>
> * The jmod command does not correctly recognize the `list` mode typed in
> lowercase;
> * The jimage command cannot obtain the help information of t
When the default Locale is `tr`, the jmod and jimage commands have the
following problems:
* The jmod command does not correctly recognize the `list` mode typed in
lowercase;
* The jimage command cannot obtain the help information of the `list` mode.
-
Commit messages:
- list mode
On Tue, 31 Jan 2023 18:28:59 GMT, Alan Bateman wrote:
> A PR may be a bit premature as this probably needs discussion first on
> whether this is worth doing. Yes, there are common methods between the two
> but at the same time, the byte and character hierarchies have always been
> distinct. Ha
> Root.java is changed to a manual test because it requires test to be run with
> the root user privilege, and it requires to modify the user policy file in
> the home director.
Bill Huang has updated the pull request incrementally with one additional
commit since the last revision:
Check ro
I have not add a chance to look or think about this yet but wanted to know I
will
On Jan 19, 2023, at 2:03 PM, Eirik Bjørsnøs
mailto:eir...@gmail.com>> wrote:
Hi,
A common use case for java.util.zip in build tools involves copying
entries from a ZipFile or ZipInputStream to a ZipOutputStream w
On Tue, 31 Jan 2023 at 21:21, wrote:
>
> There is no conflict with JLS 7.2.2 as I can see.
Thanks for getting back to me.
Maybe there isn't a direct conflict. But I still think this is not very
intuitive.
If I have an application with two packages:
com.acme.foreveryone
com.acme.secret
> Root.java is changed to a manual test because it requires test to be run with
> the root user privilege, and it requires to modify the user policy file in
> the home director.
Bill Huang has updated the pull request incrementally with one additional
commit since the last revision:
Implemen
On Tue, 31 Jan 2023 22:35:21 GMT, Bill Huang wrote:
> Root.java is changed to a manual test because it requires test to be run with
> the root user privilege, and it requires to modify the user policy file in
> the home director.
test/jdk/java/security/Policy/Root/Root.java line 34:
> 32:
>
Root.java is changed to a manual test because it requires test to be run with
the root user privilege, and it requires to modify the user policy file in the
home director.
-
Commit messages:
- JDK-824 java/security/Policy/Root/Root.java fails when home directory is
read-only
On Thu, 4 Aug 2022 16:26:19 GMT, Julian Waters wrote:
> Please review a small patch for dumping the failure reason when the MSVCRT
> libraries or the Java Virtual Machine fails to load on Windows, which can
> provide invaluable insight when debugging related launcher issues.
>
> See https://bu
On Tue, 31 Jan 2023 18:30:14 GMT, Raffaello Giulietti
wrote:
>> Align `double` and `float` decimal conversions in `java.util.Formatter` with
>> the algorithm used in `Double.toString(double)`.
>
> Raffaello Giulietti has updated the pull request incrementally with one
> additional commit since
On Tue, 31 Jan 2023 19:08:08 GMT, Bill Huang wrote:
> Test failed for exception in thread "main" java.lang.IllegalAccessError:
> class IPv6NameserverPlatformParsingTest (in unnamed module @0x72a8ab1a)
> cannot access class com.sun.jndi.dns.DnsContextFactory (in module
> jdk.naming.dns) because
> From: "Glavo"
> To: "Stuart Marks"
> Cc: "John Hendrikx" , "core-libs-dev"
>
> Sent: Tuesday, January 31, 2023 10:12:24 PM
> Subject: Re: NPE throwing behavior of immutable collections
> I understand that null is prohibited by default, but can we also provide a set
> of factory methods that a
There is no conflict with JLS 7.2.2 as I can see.
Opens `some.package` to `some.other.module` means just one package.
It's true that the open packages can be extended at runtime. For
example, `some.other.module` can update this module to open the package
to another module at runtime via `Modu
I understand that null is prohibited by default, but can we also provide a
set of factory methods that accept null?
They can be named like List.ofNullable/copyOfNullable.
On Tue, Jan 31, 2023 at 10:13 AM Stuart Marks
wrote:
> In this reply I'll focus on the null handling issues in collections.
>
On Tue, 31 Jan 2023 19:38:22 GMT, Bill Huang wrote:
>> Test failed for exception in thread "main" java.lang.IllegalAccessError:
>> class IPv6NameserverPlatformParsingTest (in unnamed module @0x72a8ab1a)
>> cannot access class com.sun.jndi.dns.DnsContextFactory (in module
>> jdk.naming.dns) bec
> Test failed for exception in thread "main" java.lang.IllegalAccessError:
> class IPv6NameserverPlatformParsingTest (in unnamed module @0x72a8ab1a)
> cannot access class com.sun.jndi.dns.DnsContextFactory (in module
> jdk.naming.dns) because module jdk.naming.dns does not export
> com.sun.jndi
On Tue, 31 Jan 2023 19:25:55 GMT, Alan Bateman wrote:
>> Test failed for exception in thread "main" java.lang.IllegalAccessError:
>> class IPv6NameserverPlatformParsingTest (in unnamed module @0x72a8ab1a)
>> cannot access class com.sun.jndi.dns.DnsContextFactory (in module
>> jdk.naming.dns) b
On Tue, 31 Jan 2023 19:08:08 GMT, Bill Huang wrote:
> Test failed for exception in thread "main" java.lang.IllegalAccessError:
> class IPv6NameserverPlatformParsingTest (in unnamed module @0x72a8ab1a)
> cannot access class com.sun.jndi.dns.DnsContextFactory (in module
> jdk.naming.dns) because
Test failed for exception in thread "main" java.lang.IllegalAccessError: class
IPv6NameserverPlatformParsingTest (in unnamed module @0x72a8ab1a) cannot access
class com.sun.jndi.dns.DnsContextFactory (in module jdk.naming.dns) because
module jdk.naming.dns does not export com.sun.jndi.dns to unn
On Tue, 31 Jan 2023 06:49:28 GMT, Andrey Turbanov wrote:
>> Joe Darcy has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Implement review feedback.
>
> src/java.base/share/classes/java/lang/FdLibm.java line 911:
>
>> 909: k = 1
> Another day, another PR to port FDLBIM to Java, this time for the log1p
> method.
>
> Other than using the two-argument form of the __HI method in Java
> transliteration version rather than C macro, there are no appreciable
> differences between the original C source in
>
> src/java.base/sh
On Sun, 29 Jan 2023 07:11:26 GMT, Tingjun Yuan wrote:
>> Add `java.io.PrintOutput` to represent print operations, and modify
>> `java.io.PrintStream` and `java.io.PrintWriter` to implement it.
>
> Tingjun Yuan has updated the pull request incrementally with one additional
> commit since the las
On Tue, 31 Jan 2023 18:12:45 GMT, Brian Burkhalter wrote:
>> In this specific `*.java.template` case, I think that the bug id in the
>> comment somehow replaces the lack of the @bug line.
>> But I have no problems in removing it if there are stronger opinions.
>
> The `@bug` tag is in `BasicTest
> Align `double` and `float` decimal conversions in `java.util.Formatter` with
> the algorithm used in `Double.toString(double)`.
Raffaello Giulietti has updated the pull request incrementally with one
additional commit since the last revision:
8300869: Make use of the Double.toString(double)
On Wed, 25 Jan 2023 12:26:26 GMT, Per Minborg wrote:
> This PR proposed to reduce contention in synchronized methods mainly by doing
> I/O operations outside synch blocks.
BTW: Is this PR meant by openjdk/jdk20 or openjdk/jdk?
-
PR: https://git.openjdk.org/jdk/pull/12193
On Mon, 30 Jan 2023 20:10:17 GMT, Raffaello Giulietti
wrote:
>> I see; it might suffice in this case to rely on the bug information in the
>> SCM history, but I don't have a strong opinion.
>
> In this specific `*.java.template` case, I think that the bug id in the
> comment somehow replaces t
On Wed, 25 Jan 2023 12:26:26 GMT, Per Minborg wrote:
> This PR proposed to reduce contention in synchronized methods mainly by doing
> I/O operations outside synch blocks.
src/java.base/share/classes/java/lang/Module.java line 318:
> 316: }
> 317:
> 318: private static boolean casEnab
On Tue, 31 Jan 2023 06:45:27 GMT, Andrey Turbanov wrote:
>> Another day, another PR to port FDLBIM to Java, this time for the log1p
>> method.
>>
>> Other than using the two-argument form of the __HI method in Java
>> transliteration version rather than C macro, there are no appreciable
>> di
On Wed, 25 Jan 2023 12:26:26 GMT, Per Minborg wrote:
> This PR proposed to reduce contention in synchronized methods mainly by doing
> I/O operations outside synch blocks.
The potential performance improvement in determining if native access is
enabled is a small part of the overall benchmarks
This PR proposed to reduce contention in synchronized methods mainly by doing
I/O operations outside synch blocks.
-
Commit messages:
- Reduce contention
Changes: https://git.openjdk.org/jdk/pull/12193/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=12193&range=00
Issue:
On Tue, 31 Jan 2023 11:40:43 GMT, Sergey Tsypanov wrote:
> `ResourceBundle.CacheKey.equals()` and `Bundles.CacheKey.equals()` are quire
> outdated. This simple clean-up modernizes them.
return moduleRef.refersTo(otherEntry.getModule()) &&
callerRef.refersTo(otherEntry.getCallerModule())
Hello!
I agree that collection factories should not throw on contains(null).
This issue actually reduces their
adoption. Imagine that I always returned from some method
Collections.unmodifiableSet(new HashSet<>(Arrays.asList(non, null, values)));
It's a verbose construct that creates inefficient d
On Tue, 31 Jan 2023 07:17:59 GMT, Alan Bateman wrote:
> There was some discussion about these test failures in the JBS issue and I
> think @sunny868 has accepted that they need to be investigated to see if they
> are test reliability issues or something else. As always, running tests with
> -X
The proposed change adds a new exception handler method to the
`test/jdk/com/sun/jndi/ldap/lib/BaseLdapServer.java` LDAP test library class.
It will allow LDAP tests to customize the handling of server-side exceptions.
The current `BaseLdapTestServer` implementation prints an exception and its
On Tue, 31 Jan 2023 15:57:43 GMT, Per Minborg wrote:
> `ZoneOffset` instances are cached by the `ZoneOffset` class itself for values
> in the range [-18h, 18h] for each second that is on an even quarter of an
> hour (i.e. at most 2*18*4+1 = 145 values).
>
> Instead of using a `ConcurrentHashM
`ZoneOffset` instances are cached by the `ZoneOffset` class itself for values
in the range [-18h, 18h] for each second that is on an even quarter of an hour
(i.e. at most 2*18*4+1 = 145 values).
Instead of using a `ConcurrentHashMap` for caching instanced, we could instead
use an `AtomicRefere
On Tue, 6 Dec 2022 21:14:07 GMT, Andrew Haley wrote:
>> JEP 429 implementation.
>
> Andrew Haley has updated the pull request with a new target base due to a
> merge or a rebase. The pull request now contains 71 commits:
>
> - Merge from JDK mainline
> - Add comment
> - Merge https://github.
On Thu, 7 Jul 2022 15:20:32 GMT, Raffaello Giulietti
wrote:
> A reimplementation of `BigDecimal.[double|float]Value()` to enhance
> performance, avoiding an intermediate string and its subsequent parsing on
> the slow path.
This PR is waiting for a review
-
PR: https://git.openj
> Align `double` and `float` decimal conversions in `java.util.Formatter` with
> the algorithm used in `Double.toString(double)`.
Raffaello Giulietti has updated the pull request incrementally with one
additional commit since the last revision:
8300869: Make use of the Double.toString(double)
On Tue, 31 Jan 2023 11:40:43 GMT, Sergey Tsypanov wrote:
> `ResourceBundle.CacheKey.equals()` and `Bundles.CacheKey.equals()` are quire
> outdated. This simple clean-up modernizes them.
Btw, in `ResourceBundle.CacheKey.equals()` can we replace
Module module = getModule();
Module caller = getCa
`ResourceBundle.CacheKey.equals()` and `Bundles.CacheKey.equals()` are quire
outdated. This simple clean-up modernizes them.
-
Commit messages:
- Copyright year update
- Modernize Bubldes.equals()
Changes: https://git.openjdk.org/jdk/pull/12328/files
Webrev: https://webrevs.openj
The proposed fix by @DougLea ensures that the state transition into waiting is
retried in the cases where a previous waiter isn't making progress and a new
waiter goes into waiting.
-
Commit messages:
- JDK-8300098 :
java/util/concurrent/ConcurrentHashMap/ConcurrentAssociateTest.j
On Tue, 31 Jan 2023 02:52:45 GMT, Joe Darcy wrote:
> Another day, another PR to port FDLBIM to Java, this time for the log1p
> method.
>
> Other than using the two-argument form of the __HI method in Java
> transliteration version rather than C macro, there are no appreciable
> differences be
On Thu, 26 Jan 2023 19:30:50 GMT, Christoph wrote:
> We readded the splitting code and the test is passing. In the test we could
> make it work with up to 130 modules where each module _n_ requires all
> modules from _0...n_
The patch looks similar to the original. As a quick test, I changed t
On Mon, 30 Jan 2023 08:38:15 GMT, Amit Kumar wrote:
> m=525312, n=498060, len=524288, eq=false
The test doesn't print this so I assume this is tracing that you added in your
runs. If I read it correctly, the initial input is len=524288, it deflates to
m=525312, then re-inflates to n=498060. So
56 matches
Mail list logo