On 20/10/2022 01:05, Reinier Zwitserloot wrote:
:
JDK18 brought JEP400 which changes the default charset encoding to
UTF-8. This, probably out of necessity, goes quite far, in that
|Charset.defaultCharset()| is now more or less a constant - always
returns UTF_8. It’s now quite difficult to r
On Wed, 19 Oct 2022 16:45:12 GMT, Lance Andersen wrote:
> Hi all,
>
> Please review this PR which will update the Zlib Data Compression Library
> from 1.2.11 to 1.2.13.
>
> - I have run all of the Mach5 tiers which did not show any issues related to
> the upgrade.
> - The JCK zip/jar tests al
On Wed, 19 Oct 2022 16:45:12 GMT, Lance Andersen wrote:
> Hi all,
>
> Please review this PR which will update the Zlib Data Compression Library
> from 1.2.11 to 1.2.13.
>
> - I have run all of the Mach5 tiers which did not show any issues related to
> the upgrade.
> - The JCK zip/jar tests al
On Sun, 18 Sep 2022 11:52:28 GMT, Jaikiran Pai wrote:
> Can I please get a review of this test only change which proposes to fix the
> recent intermittent failures in `RmiBootstrapTest` reported in
> https://bugs.openjdk.org/browse/JDK-8030616?
>
> The test has been intermittently failing with
On Mon, 3 Oct 2022 08:23:36 GMT, Raffaello Giulietti
wrote:
> Disables a specific assertion that causes intermittent failures.
Approved whether or not any comment is added.
test/jdk/java/util/DoubleStreamSums/CompensatedSums.java line 94:
> 92:
> 93: Assert.assertTrue(jdkParallelStre
PREAMBLE: Due to not being sure where to post it, this was posted to
amber-dev before. I have updated it to take into account Ron Pressler’s
notes on System.console, and Brian Goetz’s notes on steering clear of
shoving deadlines in debate posts like this one.
—
JDK18 brought JEP400 which changes
On Wed, 19 Oct 2022 22:27:27 GMT, Naoto Sato wrote:
>> Issue: Resource bundle name does not follow proper naming conventions
>> according to [getBundle
>> method](https://docs.oracle.com/javase/8/docs/api/java/util/ResourceBundle.html#getBundle-java.lang.String-java.util.Locale-)
>> for base n
On Wed, 19 Oct 2022 22:44:34 GMT, Naoto Sato wrote:
> btw, the link to getBundle javadoc points to JDK8's, where the module has not
> yet been introduced. I was scratching my head why I couldn't find the
> overload that takes a Module 😀
I intended to focus on "baseName - the base name of the r
On Fri, 7 Oct 2022 18:24:02 GMT, Justin Lu wrote:
> Issue: Resource bundle name does not follow proper naming conventions
> according to [getBundle
> method](https://docs.oracle.com/javase/8/docs/api/java/util/ResourceBundle.html#getBundle-java.lang.String-java.util.Locale-)
> for base name pa
> Issue: Formatter unit tests are launched via basic.sh
>
> Fix: Replace basic.sh with a Java test launcher
>
> Note: Java.internal.math was included in the original configuration of Basic,
> but I removed it as it was not used within the Basic unit tests
>
>
> Original output on success
> s
On Fri, 7 Oct 2022 18:24:02 GMT, Justin Lu wrote:
> Issue: Resource bundle name does not follow proper naming conventions
> according to [getBundle
> method](https://docs.oracle.com/javase/8/docs/api/java/util/ResourceBundle.html#getBundle-java.lang.String-java.util.Locale-)
> for base name pa
On Tue, 18 Oct 2022 23:03:16 GMT, Justin Lu wrote:
>> Issue: Formatter unit tests are launched via basic.sh
>>
>> Fix: Replace basic.sh with a Java test launcher
>>
>> Note: Java.internal.math was included in the original configuration of
>> Basic, but I removed it as it was not used within th
On Wed, 19 Oct 2022 19:04:57 GMT, Naoto Sato wrote:
> This is a regression caused by upgrading CLDR to version 39 (JDK-8258794), in
> which CLDR changed the locale inheritance for Norwegian. Some locale data
> (including number elements) that were in `nn` locale was moved to `no`. There
> was
Issue: Resource bundle name does not follow proper naming conventions according
to [getBundle
method](https://docs.oracle.com/javase/8/docs/api/java/util/ResourceBundle.html#getBundle-java.lang.String-java.util.Locale-)
for base name parameter
Fix: Modified bundle name to be a fully qualified c
On Thu, 13 Oct 2022 21:53:47 GMT, Ioi Lam wrote:
> Please review this small optimization. As shown in the JBS issue, most of the
> generated LambdaForm classes have a single ClassData, so we can get a small
> footprint/speed improvement.
This pull request has now been integrated.
Changeset: 8
On Mon, 17 Oct 2022 19:28:09 GMT, Claes Redestad wrote:
>> Ioi Lam has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> @iwanowww comments
>
> Looks good, assuming there are tests calling in with no class data to check
> that `defineClass` i
On Wed, 19 Oct 2022 19:04:57 GMT, Naoto Sato wrote:
> This is a regression caused by upgrading CLDR to version 39 (JDK-8258794), in
> which CLDR changed the locale inheritance for Norwegian. Some locale data
> (including number elements) that were in `nn` locale was moved to `no`. There
> was
> This task converts 5 manual tests to automated tests.
>
> sun/security/provider/PolicyParser/ExtDirsDefaultPolicy.java
> sun/security/provider/PolicyParser/ExtDirsChange.java
> sun/security/provider/PolicyParser/ExtDirs.java
> java/security/Policy/Root/Root.javajava/security/Policy/Root/Root.
This is a regression caused by upgrading CLDR to version 39 (JDK-8258794), in
which CLDR changed the locale inheritance for Norwegian. Some locale data
(including number elements) that were in `nn` locale was moved to `no`. There
was a code in CLDRConverter that specially handles `no` locale not
On Wed, 19 Oct 2022 16:45:12 GMT, Lance Andersen wrote:
> Hi all,
>
> Please review this PR which will update the Zlib Data Compression Library
> from 1.2.11 to 1.2.13.
>
> - I have run all of the Mach5 tiers which did not show any issues related to
> the upgrade.
> - The JCK zip/jar tests al
On Wed, 19 Oct 2022 18:02:45 GMT, Alan Bateman wrote:
> Can you confirm that this is exactly the 1.2.13 code, no patches/changes,
> right?
That is correct, there are no patches on top of the 1.2.13
-
PR: https://git.openjdk.org/jdk/pull/10773
On Wed, 19 Oct 2022 16:45:12 GMT, Lance Andersen wrote:
> Hi all,
>
> Please review this PR which will update the Zlib Data Compression Library
> from 1.2.11 to 1.2.13.
>
> - I have run all of the Mach5 tiers which did not show any issues related to
> the upgrade.
> - The JCK zip/jar tests al
Hi all,
Please review this PR which will update the Zlib Data Compression Library from
1.2.11 to 1.2.13.
- I have run all of the Mach5 tiers which did not show any issues related to
the upgrade.
- The JCK zip/jar tests also continue to pass.
- Jai ran his macOS aarch64 test(for
[JDK-8282954](h
On Mon, 17 Oct 2022 16:57:06 GMT, Bill Huang wrote:
>> This task converts 5 manual tests to automated tests.
>>
>> sun/security/provider/PolicyParser/ExtDirsDefaultPolicy.java
>> sun/security/provider/PolicyParser/ExtDirsChange.java
>> sun/security/provider/PolicyParser/ExtDirs.java
>> java/s
On Tue, 18 Oct 2022 22:11:57 GMT, Bill Huang wrote:
>> test/jdk/javax/crypto/CryptoPermissions/default_local.policy line 4:
>>
>>> 2: permission javax.crypto.CryptoAllPermission;
>>> 3: permission javax.crypto.CryptoPermission "DES", 64;
>>> 4: }
>>
>> please remove extra line.
>
> I do
On Tue, 18 Oct 2022 17:44:45 GMT, Naoto Sato wrote:
> Plurals were determined only by looking at the integer part of the compact
> number. Changed to consider the fraction digits as well.
This pull request has now been integrated.
Changeset: e238920b
Author:Naoto Sato
URL:
https://
On Wed, 5 Oct 2022 15:23:43 GMT, Aleksei Efimov wrote:
> ### Summary of the change
> This change introduces new system and security properties for specifying
> factory filters for the JNDI/LDAP and the JNDI/RMI JDK provider
> implementations.
>
> These new properties allow more granular contr
On Tue, 18 Oct 2022 11:55:06 GMT, Magnus Ihse Bursie wrote:
> This is a continuation of the effort to update all our URLs to the new
> top-level domain.
>
> This patch updates (most) URLs in testing code. There still exists references
> to openjdk.java.net, but that are not strictly used as no
> ### Summary of the change
> This change introduces new system and security properties for specifying
> factory filters for the JNDI/LDAP and the JNDI/RMI JDK provider
> implementations.
>
> These new properties allow more granular control over the set of object
> factories allowed to reconst
On Mon, 19 Sep 2022 08:51:24 GMT, Xiaohong Gong wrote:
> "`VectorSupport.indexVector()`" is used to compute a vector that contains the
> index values based on a given vector and a scale value (`i.e. index = vec +
> iota * scale`). This function is widely used in other APIs like
> "`VectorMask.
On Wed, 19 Oct 2022 08:31:07 GMT, Alan Bateman wrote:
> > * Alternative B: Instead of double-buffering I drop the original buffer and
> > use a same-size replacement each time the buffer was drained inside of
> > `transferTo`. This is a rather cheap solution and rather perfectly prevents
> > O
On Mon, 3 Oct 2022 05:54:31 GMT, Markus KARG wrote:
>> This PR implements JDK-8294696.
>
> Markus KARG has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Checking explicitly -1 instead of < 0
> * Alternative B: Instead of double-buffering I d
On Mon, 3 Oct 2022 05:54:31 GMT, Markus KARG wrote:
>> This PR implements JDK-8294696.
>
> Markus KARG has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Checking explicitly -1 instead of < 0
I think before we give up, we should consider the
On Mon, 26 Sep 2022 18:15:17 GMT, Dmitry Samersoff
wrote:
> If the user has set LD_LIBRARY_PATH to use a particular libjvm.so, options
> from the JDK_JAVA_OPTIONS environment variable are picked up twice.
>
> If an option cannot be accepted twice (e.g., -agentlib), the application
> fails to
On Wed, 19 Oct 2022 07:43:33 GMT, Jatin Bhateja wrote:
>> Xiaohong Gong has updated the pull request with a new target base due to a
>> merge or a rebase. The incremental webrev excludes the unrelated changes
>> brought in by the merge/rebase. The pull request contains three additional
>> comm
On Tue, 18 Oct 2022 01:44:21 GMT, Xiaohong Gong wrote:
>> "`VectorSupport.indexVector()`" is used to compute a vector that contains
>> the index values based on a given vector and a scale value (`i.e. index =
>> vec + iota * scale`). This function is widely used in other APIs like
>> "`VectorM
On Mon, 3 Oct 2022 05:54:31 GMT, Markus KARG wrote:
>> This PR implements JDK-8294696.
>
> Markus KARG has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Checking explicitly -1 instead of < 0
> Thank you. So far I have not measured the actual
37 matches
Mail list logo