EricWF closed this revision.
EricWF added a comment.
Committed in r274316.
http://reviews.llvm.org/D15421
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
EricWF added a subscriber: EricWF.
EricWF added a comment.
Ping? Is there a reason this hasn't been committed?
http://reviews.llvm.org/D15421
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-
ldionne updated this revision to Diff 58619.
ldionne added a comment.
Rebase the patch on top of the current `master`. The patch passes all of
Clang's tests (`make check-clang`). I also removed the TODO comment about
diagnostics, since that was answered by Richard Smith.
http://reviews.llvm.or
ldionne added a comment.
No problem for the delay; we're all busy :-). Unfortunately, the patch does not
apply cleanly on `master` anymore, so I'll rebase it and someone can then
commit it for me.
http://reviews.llvm.org/D15421
___
cfe-commits mai
rsmith accepted this revision.
rsmith added a comment.
This revision is now accepted and ready to land.
Sorry for the delay, this all LGTM. Do you need someone to commit it for you?
Comment at: lib/Sema/SemaTemplate.cpp:2082-2085
@@ +2081,6 @@
+// If the Index is out of boun
ldionne added a comment.
ping
http://reviews.llvm.org/D15421
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
ldionne updated this revision to Diff 48012.
ldionne added a comment.
Address some remaining issues:
- Rename __nth_element to __type_pack_element, as suggested by Richard Smith
- Fix template parameter position issue in createTypePackElementParameterList
AFAICT, the only remaining issue is whet
ldionne updated this revision to Diff 44907.
ldionne marked 4 inline comments as done.
ldionne added a comment.
Address Richard Smith's review comments:
- Remove IndexType parameter, and make Index a std::size_t
- Remove assertion about APSInt::GetExtValue()
- Other style changes
Still left to d
On Wed, Jan 13, 2016 at 6:48 PM, Richard Smith
wrote:
> On Wed, Jan 13, 2016 at 3:41 PM, Arthur O'Dwyer via cfe-commits <
> cfe-commits@lists.llvm.org> wrote:
>
>> Following Louis' suggestion, how about __pack_nth?
>>
>
> Maybe just __pack_element, to mirror its intended use to implement things
>
On Wed, Jan 13, 2016 at 3:41 PM, Arthur O'Dwyer via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Following Louis' suggestion, how about __pack_nth?
>
Maybe just __pack_element, to mirror its intended use to implement things
like tuple_element? (I'm not completely happy about using this gene
Following Louis' suggestion, how about __pack_nth?
On Wed, Jan 13, 2016 at 3:16 PM, Nathan Wilson via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
>
>
> On Wed, Jan 13, 2016 at 4:52 PM, Richard Smith
> wrote:
>
>> On Wed, Jan 13, 2016 at 2:31 PM, Nathan Wilson
>> wrote:
>>
>>> nwilson added
On Wed, Jan 13, 2016 at 4:52 PM, Richard Smith
wrote:
> On Wed, Jan 13, 2016 at 2:31 PM, Nathan Wilson
> wrote:
>
>> nwilson added a comment.
>>
>> In http://reviews.llvm.org/D15421#326144, @rsmith wrote:
>>
>> > Bikeshedding on the name a bit... how about `__type_pack_element`?
>>
>> Hmm, I kin
On Wed, Jan 13, 2016 at 2:31 PM, Nathan Wilson wrote:
> nwilson added a comment.
>
> In http://reviews.llvm.org/D15421#326144, @rsmith wrote:
>
> > Bikeshedding on the name a bit... how about `__type_pack_element`?
>
> Hmm, I kind of felt like having `nth` in there implied we're indexing into
> s
ldionne added a comment.
In http://reviews.llvm.org/D15421#326209, @nwilson wrote:
> In http://reviews.llvm.org/D15421#326144, @rsmith wrote:
>
> > Bikeshedding on the name a bit... how about `__type_pack_element`?
>
>
> Hmm, I kind of felt like having `nth` in there implied we're indexing into
nwilson added a comment.
In http://reviews.llvm.org/D15421#326144, @rsmith wrote:
> Bikeshedding on the name a bit... how about `__type_pack_element`?
Hmm, I kind of felt like having `nth` in there implied we're indexing into
something... What about `__nth_pack_element`?
http://reviews.llvm.
rsmith added a comment.
Bikeshedding on the name a bit... how about `__type_pack_element`?
http://reviews.llvm.org/D15421
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
rsmith added inline comments.
Comment at: include/clang/Basic/Builtins.h:216-219
@@ -215,3 +215,6 @@
/// \brief This names the __make_integer_seq BuiltinTemplateDecl.
BTK__make_integer_seq
+
+ /// \brief This names the __nth_element BuiltinTemplateDecl.
+ , BTK__nth_elemen
ldionne added a reviewer: rsmith.
ldionne updated this revision to Diff 44779.
ldionne added a comment.
Rebase on top of the master branch, and add Richard Smith as a reviewer, since
he also reviewed David Majnemer's original patch (suggested by Nathan Wilson).
http://reviews.llvm.org/D15421
F
ldionne added a comment.
We should probably consider changing the name from `__nth_element` to something
else, perhaps something that contains the word "pack". This is especially true
if we are to implement other intrinsics for manipulating parameter packs, like
slicing (as proposed by Eric Fis
ldionne updated this revision to Diff 42443.
ldionne added a comment.
Added full lines of context. Sorry for not doing it the first time around.
http://reviews.llvm.org/D15421
Files:
include/clang/AST/ASTContext.h
include/clang/AST/DeclTemplate.h
include/clang/Basic/Builtins.h
include/c
Hi Louis,
It would probably be useful to get the lines of context as well by doing a
full diff as describer here: http://llvm.org/docs/Phabricator.html#id3
For example, git diff -U99
On Thu, Dec 10, 2015 at 11:32 AM, Louis Dionne via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> ldi
ldionne created this revision.
ldionne added a reviewer: majnemer.
ldionne added a subscriber: cfe-commits.
This patch adds a `__nth_element` builtin that allows fetching the n-th type of
a parameter pack with very little compile-time overhead. The patch was inspired
by r252036 and r252115 by Da
22 matches
Mail list logo