ldionne added a comment. In http://reviews.llvm.org/D15421#326209, @nwilson wrote:
> In http://reviews.llvm.org/D15421#326144, @rsmith wrote: > > > Bikeshedding on the name a bit... how about `__type_pack_element`? > > > Hmm, I kind of felt like having `nth` in there implied we're indexing into > something... What about `__nth_pack_element`? If anything, I would probably start the name with `__pack`. This way, we could add other builtins that follow the same pattern, like `__pack_slice`, `__pack_reverse` and probably others. Or if we don't want to start with `__pack`, then no problem, but we might want to settle on a prefix that will work for other builtins on packs as well. http://reviews.llvm.org/D15421 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits