On 11/12/18 12:36 AM, Philippe Mathieu-Daudé wrote:
> +dclz            011100 ..... ..... ..... ..... 100100   @rs_rt_rd   
> ?ctx->insn_flags&ISA_MIPS64
> +dclo            011100 ..... ..... ..... ..... 100101   @rs_rt_rd   
> ?ctx->insn_flags&ISA_MIPS64

This syntax I do not like.  I preferred your other form,

  >isa(ISA_MIPS64)

which, with a change to return false as I suggested, would
have the same effect.

As an aside, you could do

#define check_isa(ctx, which)  ((ctx)->insn_flags & ISA_##which)

to reduce the decode markup to

  >isa(MIPS64)


r~

Reply via email to