"Denis V. Lunev" <d...@openvz.org> writes: > On 11/17/2015 01:10 PM, Markus Armbruster wrote: >> "Denis V. Lunev" <d...@openvz.org> writes: >> >>> Signed-off-by: Denis V. Lunev <d...@openvz.org> >>> CC: Juan Quintela <quint...@redhat.com> >>> CC: Amit Shah <amit.s...@redhat.com> >>> CC: Markus Armbruster <arm...@redhat.com> >>> CC: Eric Blake <ebl...@redhat.com> >>> --- >>> migration/savevm.c | 5 +++++ >>> qapi-schema.json | 13 +++++++++++++ >>> qmp-commands.hx | 25 +++++++++++++++++++++++++ >>> 3 files changed, 43 insertions(+) >>> >>> diff --git a/migration/savevm.c b/migration/savevm.c >>> index f83ffd0..565b10a 100644 >>> --- a/migration/savevm.c >>> +++ b/migration/savevm.c >>> @@ -2010,6 +2010,11 @@ void hmp_savevm(Monitor *mon, const QDict *qdict) >>> } >>> } >>> +void qmp_savevm(bool has_name, const char *name, Error **errp) >>> +{ >>> + do_savevm(has_name ? name : NULL, errp); >>> +} >>> + >> Please name do_savevm() qmp_savevm() and drop this wrapper. >> >> We're working on omitting has_FOO for pointer-valued FOO. > error code is used in the qemu-img. > I can drop error code check there and replace it with checking of > Error pointer. > Is this OK for you?
Let me rephrase my request: 1. Instead of wrapping do_savevm() in qmp_savevm(), use it directly. 2. Rename do_savevm() to qmp_savevm(), and change its arguments to make it work as QMP command handler. Does that make sense to you?