During reviewing Alexander's PPC patches, it proved that pci_data_{read, write}() should take PCIConfigAddress as an argument. this patch series is inspired by his patch and some of them are based on it.
This patch would make Alexander's PPC work easier. Isaku Yamahata (6): sh_pci: use PCIHostState instead of PCIBus. sh_pci: s/sh_pci_data_write/sh_pci_mem_write/g for consistency. versatile_pci: user PCIHostState instead of PCIBus pci_host: remove code duplication in pci_host_template.h pci: introduce PCIAddress, PCIConfigAddress and helper functions. pci host: make pci_data_{write, read}() get PCIConfigAddress. hw/apb_pci.c | 12 ++++-- hw/gt64xxx.c | 20 ++++++---- hw/pci.h | 7 ++++ hw/pci_host.c | 61 +++++++++++++++++++++++++------- hw/pci_host.h | 21 ++++++++++- hw/pci_host_template.h | 85 +++++++++---------------------------------- hw/pci_host_template_all.h | 23 ++++++++++++ hw/prep_pci.c | 28 +++++++++++--- hw/sh_pci.c | 42 +++++++++++++++------- hw/versatile_pci.c | 47 +++++++++++++++++++----- qemu-common.h | 2 + 11 files changed, 225 insertions(+), 123 deletions(-) create mode 100644 hw/pci_host_template_all.h