rename sh_pci_data_write to sh_pci_mem_write for consistency. Later sh_pci_data_write will be introduced again, so this patch is preliminary patch.
Cc: Takashi YOSHII <takas...@ops.dti.ne.jp> Signed-off-by: Isaku Yamahata <yamah...@valinux.co.jp> --- hw/sh_pci.c | 8 ++++---- 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/hw/sh_pci.c b/hw/sh_pci.c index d76d390..046db2e 100644 --- a/hw/sh_pci.c +++ b/hw/sh_pci.c @@ -72,7 +72,7 @@ static uint32_t sh_pci_reg_read (void *p, target_phys_addr_t addr) return 0; } -static void sh_pci_data_write (SHPCIC *pcic, target_phys_addr_t addr, +static void sh_pci_mem_write (SHPCIC *pcic, target_phys_addr_t addr, uint32_t val, int size) { pci_data_write(pcic->s.bus, addr + pcic->mbr, val, size); @@ -86,17 +86,17 @@ static uint32_t sh_pci_mem_read (SHPCIC *pcic, target_phys_addr_t addr, static void sh_pci_writeb (void *p, target_phys_addr_t addr, uint32_t val) { - sh_pci_data_write(p, addr, val, 1); + sh_pci_mem_write(p, addr, val, 1); } static void sh_pci_writew (void *p, target_phys_addr_t addr, uint32_t val) { - sh_pci_data_write(p, addr, val, 2); + sh_pci_mem_write(p, addr, val, 2); } static void sh_pci_writel (void *p, target_phys_addr_t addr, uint32_t val) { - sh_pci_data_write(p, addr, val, 4); + sh_pci_mem_write(p, addr, val, 4); } static uint32_t sh_pci_readb (void *p, target_phys_addr_t addr) -- 1.6.5.4