Le Monday 09 Dec 2013 à 12:03:26 (-0500), Luiz Capitulino a écrit : > On Mon, 9 Dec 2013 17:48:50 +0100 > Benoît Canet <benoit.ca...@irqsave.net> wrote: > > > Le Monday 09 Dec 2013 à 11:41:09 (-0500), Luiz Capitulino a écrit : > > > On Mon, 9 Dec 2013 17:23:09 +0100 > > > Kevin Wolf <kw...@redhat.com> wrote: > > > > > > > > > I'm leaning slightly towards the approach that Benoît took, if only > > > > > > for > > > > > > the naming aspect (that is, I also thought of the idea of a bool > > > > > > flag, > > > > > > but didn't suggest it because I didn't like the implications on the > > > > > > naming). But I can live with either approach, if anyone else has a > > > > > > strong opinion. > > > > > > > > > > Well, we can pick up any descriptive name 'treat-device-as-a-node', > > > > > 'device-is-a-graph-node'... > > > > > > > > All devices are represented by nodes, so that doesn't make sense. > > > > If anything, 'interpret-device-name-as-node-name', which at the same > > > > time makes it pretty clear that we're abusing a field for something it > > > > wasn't meant for. > > > > > > Having two optionals where they can't be specified at the same time > > > and can't be left off at the same time is a clear abuse as well. > > > > > > The truth is, both proposals are bad. This makes me think that maybe > > > we should introduce a block API 2.0 and deprecate the current one > > > (partly or completely). > > > > > > > It took me one year to go from the block filters and block backend > > requirement to the state where my customer allows me to work on block > > filters. > > > > Now if we add to this the new requirement of block API 2.0 I think I will > > soon > > have time to concentrate myself on non qemu projects :( > > I don't think it would be something major as far as code is concerned. > What can take a lot of time and energy is to define the API. The QMP > commands implementation would probably be a wrapper around a single (or > a set of) block functions. > > Again, I can live with what I suggested because I find it simpler > than your original proposal: no existing field is changed, only one > field is added, and clients can happily omit it if they don't know > what it's about. >
I already have rewritten the patches to support your version of the commands. I will let you people decide which version qemu will merge. Best regards Benoît