On Mon, 9 Dec 2013 17:23:09 +0100 Kevin Wolf <kw...@redhat.com> wrote:
> > > I'm leaning slightly towards the approach that Benoît took, if only for > > > the naming aspect (that is, I also thought of the idea of a bool flag, > > > but didn't suggest it because I didn't like the implications on the > > > naming). But I can live with either approach, if anyone else has a > > > strong opinion. > > > > Well, we can pick up any descriptive name 'treat-device-as-a-node', > > 'device-is-a-graph-node'... > > All devices are represented by nodes, so that doesn't make sense. > If anything, 'interpret-device-name-as-node-name', which at the same > time makes it pretty clear that we're abusing a field for something it > wasn't meant for. Having two optionals where they can't be specified at the same time and can't be left off at the same time is a clear abuse as well. The truth is, both proposals are bad. This makes me think that maybe we should introduce a block API 2.0 and deprecate the current one (partly or completely).