On Mon, Sep 02, 2013 at 02:55:36PM +0200, Andreas Färber wrote: [...] > > diff --git a/target-i386/cpu.h b/target-i386/cpu.h > > index 8a3d0fd..1ec32fa 100644 > > --- a/target-i386/cpu.h > > +++ b/target-i386/cpu.h > > @@ -865,6 +865,7 @@ typedef struct CPUX86State { > > bool tsc_valid; > > int tsc_khz; > > void *kvm_xsave_buf; > > + bool fwd_cpuid_cache_leaves; > > > > /* in order to simplify APIC support, we leave this pointer to the > > user */ > > Please place the field in X86CPU instead and document it.
While moving it, I believe the name can be made clearer. I would name it "fwd_host_cache_info" or something like that, to make it clear that it will expose the _host CPU_ cache information to the guest. -- Eduardo