Am 21.03.2013 15:28, schrieb Igor Mammedov: > ... and define type name and type cast macro for kvmvapic according > to accepted convention. > > Signed-off-by: Igor Mammedov <imamm...@redhat.com>
This looks great and a cherry-pick candidate if you agree? Just wondering, was there a name conflict for shorter VAPIC()? It's file-local, so doesn't really matter. Andreas > --- > hw/i386/kvmvapic.c | 7 +++++-- > 1 files changed, 5 insertions(+), 2 deletions(-) > > diff --git a/hw/i386/kvmvapic.c b/hw/i386/kvmvapic.c > index c151c95..21551a5 100644 > --- a/hw/i386/kvmvapic.c > +++ b/hw/i386/kvmvapic.c > @@ -62,6 +62,9 @@ typedef struct VAPICROMState { > bool rom_mapped_writable; > } VAPICROMState; > > +#define TYPE_VAPIC_DEVICE "kvmvapic" > +#define VAPIC_DEVICE(obj) OBJECT_CHECK(VAPICROMState, (obj), > TYPE_VAPIC_DEVICE) > + > #define TPR_INSTR_ABS_MODRM 0x1 > #define TPR_INSTR_MATCH_MODRM_REG 0x2 > > @@ -692,7 +695,7 @@ static const MemoryRegionOps vapic_ops = { > > static int vapic_init(SysBusDevice *dev) > { > - VAPICROMState *s = FROM_SYSBUS(VAPICROMState, dev); > + VAPICROMState *s = VAPIC_DEVICE(dev); > > memory_region_init_io(&s->io, &vapic_ops, s, "kvmvapic", 2); > sysbus_add_io(dev, VAPIC_IO_PORT, &s->io); > @@ -808,7 +811,7 @@ static void vapic_class_init(ObjectClass *klass, void > *data) > } > > static const TypeInfo vapic_type = { > - .name = "kvmvapic", > + .name = TYPE_VAPIC_DEVICE, > .parent = TYPE_SYS_BUS_DEVICE, > .instance_size = sizeof(VAPICROMState), > .class_init = vapic_class_init, > -- SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer; HRB 16746 AG Nürnberg