On 02/11/2013 03:49 PM, Michael R. Hines wrote: > From: "Michael R. Hines" <mrhi...@us.ibm.com> > > > Signed-off-by: Michael R. Hines <mrhi...@us.ibm.com> > ---
> +++ b/include/qapi/qmp/qerror.h > @@ -165,6 +165,12 @@ void assert_no_error(Error *err); > #define QERR_MIGRATION_ACTIVE \ > ERROR_CLASS_GENERIC_ERROR, "There's a migration process in progress" > > +#define QERR_MIGRATION_RDMA_NOT_CONFIGURED \ > + ERROR_CLASS_GENERIC_ERROR, "RMDA-based migration is missing > port/hostname information %s:%d" > + > +#define QERR_MIGRATION_RDMA_NOT_ENABLED \ > + ERROR_CLASS_GENERIC_ERROR, "RMDA-based migration has not been > compiled/enabled." > + You should not be creating new #defines for generic errors. Instead, use error_setg() at the place where you want to issue these errors. > +++ b/qapi-schema.json > > ## > +# @migrate_set_rdma_port New QMP commands should favor dash, not underscore. This should be named 'migrate-set-rdma-port'; or perhaps we should consider a more generic command 'migrate-set-parameter', which then takes a name/value pair of which parameter to set, instead of having to add a new command for every tweakable parameter. > +# > +# Set rdma communication port. > +# > +# @port: rdma communication port. > +# > +# Returns: nothing on success > +# > +# Notes: Nothing. > +# > +# Since: 1.3.0 1.5, at the earliest. > +## > +{ 'command': 'migrate_set_rdma_port', 'data': {'port': 'int'} } > + > +## > +# @migrate_set_rdma_host > +# > +# Set rdma communication host address. > +# > +# @host: rdma communication host address. > +# > +# Returns: nothing on success > +# > +# Notes: Nothing. > +# > +# Since: 1.3.0 > +## > +{ 'command': 'migrate_set_rdma_host', 'data': {'host': 'str'} } Likewise: 1.5 at the earliest, and migrate-set-rdma-host -- Eric Blake eblake redhat com +1-919-301-3266 Libvirt virtualization library http://libvirt.org
signature.asc
Description: OpenPGP digital signature