On 20/11/2012 15:18, Michael Herrmann wrote:
Thanks again for your further replies. So far, it's 4 votes for 'send_keys' and
1 vote for 'type'.
Regarding 'send_keys': To me personally it makes sense to send keys _to_
something. However, in our API, send_keys would not be called on an object or
with a parameter indicating the target. It would just be
send_keys(ENTER)
send_keys("Hello World!")
send_keys(CTRL + 'a')
In that case I'd just call it keys, that shouldn't cause too much
confusion :) Though keys_pressed comes to mind as an alternative.
Does that change your preference for 'send_keys'?
Thanks a lot!!!
--
Cheers.
Mark Lawrence.
--
http://mail.python.org/mailman/listinfo/python-list