On Sun, Jan 23, 2011 at 03:48:16PM -0800, Nigel Kersten wrote: > On Sun, Jan 23, 2011 at 3:38 PM, Dan Bode <d...@puppetlabs.com> wrote: > > On Sun, Jan 23, 2011 at 3:35 PM, Daniel Pittman <dan...@puppetlabs.com> > > wrote: > >> > >> My inclination is to say that "ontime" or "verbose" have stolen the name > >> for another concept; perhaps "interactive" covers the standard use-case > >> well > >> enough? > >> > >> Daniel > >> > >> On Jan 23, 2011 2:45 PM, "Patrick" <kc7...@gmail.com> wrote: > >> > > >> > On Jan 23, 2011, at 1:50 PM, Adam Nielsen wrote: > >> > > >> >>> https://projects.puppetlabs.com/issues/2476 > >> >>> > >> >>> This does seem to confuse a fair few new users. > >> >>> > >> >>> What would be a better name for "--test"? > > > > maybe we could keep --test and add --noop to the list of options in sets. > > That would take away the current functionality, which is immensely useful. > > You'd be required to spell out all the --onetime --no-daemonize stuff by hand. > > Maybe we should just make up a word. :) > > I know some people expect --noop to be implied by --test, and I have > some sympathy for that position, but before we can get there, we need > to have a name for the existing functionality that I don't want to do > away with. > Maybe --test should only set options if we havent specified otherwise (maybe it does so already). We could then say --test --no-noop to match current behaviour.
-Stefan
pgpiRn58IQQMe.pgp
Description: PGP signature