On Mon, 13 May 2024 at 15:38, Heikki Linnakangas <hlinn...@iki.fi> wrote: > Here's a patch to implement that.
+ if (conn->sslnegotiation[0] == 'd' && + conn->sslmode[0] != 'r' && conn->sslmode[0] != 'v') I think these checks should use strcmp instead of checking magic first characters. I see this same clever trick is used in the recently added init_allowed_encryption_methods, and I think that should be changed to use strcmp too for readability.