On Fri, Jul 01, 2022 at 10:22:16AM +0900, Michael Paquier wrote: > On Thu, Jun 30, 2022 at 08:57:04AM -0400, Isaac Morland wrote: > > I was going to point out that pg_database_owner is the same way, but it is > > fundamentally different in that it has no special allowed access and is > > meant to be the target of permission grants rather than being granted to > > other roles. > > > > +1 to rename it to pg_checkpoint or to some similar name. > > We are still in beta, so, FWIW, I am fine to adjust this name even if > it means an extra catversion bump. > > "checkpoint" is not a verb (right?), so would something like
Why not ? There's a *command* called "checkpoint". It is also a noun. -- Justin