Michael Schwingen wrote: > freddie_cho...@op.pl wrote: >> Maybe "unlock_mass_erase" would be a better name? >> > That sounds like it unlocks the mass_erase function - that command > name does not make clear that it *performs* a mass erase. How about > "unlock_and_mass_erase"?
Command name is getting longer and more unwieldy.. I don't use these commands, but how about adding a "force" or "unlock" optional argument to mass_erase instead, which does the erase-or-unlock logic Andreas suggested. That would cut down a little on command list growth and seems a good fit as an enhancement to the existing mass_erase. -- Jon Povey jon.po...@racelogic.co.uk Racelogic is a limited company registered in England. Registered number 2743719 . Registered Office Unit 10, Swan Business Centre, Osier Way, Buckingham, Bucks, MK18 1TB . The information contained in this electronic mail transmission is intended by Racelogic Ltd for the use of the named individual or entity to which it is directed and may contain information that is confidential or privileged. If you have received this electronic mail transmission in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply email so that the sender's address records can be corrected. The views expressed by the sender of this communication do not necessarily represent those of Racelogic Ltd. Please note that Racelogic reserves the right to monitor e-mail communications passing through its network _______________________________________________ Openocd-development mailing list Openocd-development@lists.berlios.de https://lists.berlios.de/mailman/listinfo/openocd-development