On Thu, 12 Dec 2024 18:49:13 GMT, Kevin Rushforth <k...@openjdk.org> wrote:

>> Andy Goryachev has updated the pull request with a new target base due to a 
>> merge or a rebase. The pull request now contains 83 commits:
>> 
>>  - Merge remote-tracking branch 'origin/master' into 8301121.RichTextArea
>>  - legal
>>  - unicode license
>>  - add handler
>>  - review comments
>>  - Merge remote-tracking branch 'origin/master' into 8301121.RichTextArea
>>  - clamp
>>  - Merge remote-tracking branch 'origin/master' into 8301121.RichTextArea
>>  - review comments
>>  - review comments
>>  - ... and 73 more: https://git.openjdk.org/jfx/compare/b76c05b9...e5814b21
>
> modules/jfx.incubator.richtext/src/main/java/jfx/incubator/scene/control/richtext/model/RichParagraph.java
>  line 216:
> 
>> 214:          * @return this {@code Builder} instance
>> 215:          */
>> 216:         public Builder addSquiggly(int start, int length, Color color) {
> 
> We need a better name.

this is an internal method.

> modules/jfx.incubator.richtext/src/main/java/jfx/incubator/scene/control/richtext/model/SimpleViewOnlyStyledModel.java
>  line 96:
> 
>> 94:     /**
>> 95:      * Appends a text segment to the last paragraph.
>> 96:      * The {@code text} cannot contain newline ({@code \n}) symbols.
> 
> What if it does contain newline chars? Does it throw an Exception? is the 
> newline ignored? Something else?

`The caller must ensure that the {@code text} does not contain newline symbols.`

I would rather not add checking to this method.

> modules/jfx.incubator.richtext/src/main/java/jfx/incubator/scene/control/richtext/model/SimpleViewOnlyStyledModel.java
>  line 194:
> 
>> 192:      * @return this model instance
>> 193:      */
>> 194:     public SimpleViewOnlyStyledModel squiggly(int start, int length, 
>> Color c) {
> 
> We need a netter name than "squiggly". CSS uses "wavy", so maybe 
> "wavyUnderline"?

mein squiggly!

-------------

PR Review Comment: https://git.openjdk.org/jfx/pull/1524#discussion_r1882952087
PR Review Comment: https://git.openjdk.org/jfx/pull/1524#discussion_r1882949116
PR Review Comment: https://git.openjdk.org/jfx/pull/1524#discussion_r1882951652

Reply via email to