On Fri, 9 Aug 2024 11:20:55 GMT, John Hendrikx <jhendr...@openjdk.org> wrote:
>> +1 for `StyleConverter.WithReconstructionSupport` >> >> maybe use a shorter name, like >> >> `StyleConverter.WithReconstruction` > > Clear, thanks MIchael. I would suggest `Reconstructable` as the name, which > seems more inline with interface naming (especially `Interpolatable`). Reads > nice also: > > if (converter instanceof Reconstructable r) { ... } But the converter is not reconstructable (in comparison to Interpolatable, which is something the marked types actually are). ------------- PR Review Comment: https://git.openjdk.org/jfx/pull/1522#discussion_r1711480351