Pushed, thanks. Marek
On Mon, Jan 13, 2014 at 10:00 PM, Andreas Hartmetz <ahartm...@gmail.com> wrote: > I don't have an fdo account or push rights. Can somebody else push it > for me please? I've added the Reviewed-by: lines so the patches only > need to be pushed now. > > On Monday 13 January 2014 11:22:07 Marek Olšák wrote: >> For the series: >> >> Reviewed-by: Marek Olšák <marek.ol...@amd.com> >> >> Feel free to push this. >> >> Marek >> >> On Sat, Jan 11, 2014 at 4:20 PM, Andreas Hartmetz <ahartm...@gmail.com> > wrote: >> > Continuing here because the threads had diverged... >> > >> > I've updated the patch series under the same URL and applied all the >> > suggested improvements. The variable renames are still in, but at the >> > very end so they are trivial to omit. >> > >> > On Tuesday 07 January 2014 17:27:56 Andreas Hartmetz wrote: >> >> We have talked on IRC meanwhile: >> >> "Everywhere" was supposed to mean file names and data structures. >> >> >> >> I have made a patch series (git link because file renames produce huge >> >> diffs) that renames *everything* away from r600 (and also radeonsi) >> >> to si, where it is actually about SI. In the such modified code it is >> >> then clear at first glance that only resources, textures and some >> >> other low-level interface code from R600 / generic Radeon are actually >> >> used in SI code. >> >> >> >> The patch series is ordered by increasing controversy potential due >> >> to destruction of git blame history, so the last parts can be omitted >> >> if they are deemed too destructive to history. In my opinion, it is >> >> better to have code that is readable now than code that is less >> >> readable but with the possibility to look up how it became like that. >> >> >> >> Michel said on IRC that he'd prefer to keep the name radeonsi_pipe.h/c, >> >> I disagree: If the library name is to be kept, there must be a break >> >> between radeonsi and si *somewhere*, and it is normal for library names >> >> to not correspond to any file name in the library. The same scheme is >> >> used in llvmpipe, llvmpipe lib / directory versus lp_* file names. >> >> >> >> Here's the repository (branch is master): >> >> git git://anongit.kde.org/scratch/ahartmetz/mesa.git >> >> web http://quickgit.kde.org/?p=scratch%2Fahartmetz%2Fmesa.git >> >> >> >> On Monday 06 January 2014 15:50:05 Marek Olšák wrote: >> >> > It sounds good, but I'd like the prefix to be si_ everywhere. >> >> > >> >> > Marek >> >> > >> >> > On Mon, Jan 6, 2014 at 2:47 PM, Andreas Hartmetz <ahartm...@gmail.com> >> >> >> >> wrote: >> >> > > Hello, >> >> > > >> >> > > many of the files in radeonsi originally came from other places where >> >> > > they had different names and were never renamed. >> >> > > Most of them now have names that don't tell what the files are for >> >> > > (r600 is not actually the first hardware supported by them, they >> >> > > start >> >> > > at radeonsi), and even those with radeonsi are split between >> >> > > radeonsi_ and si_. >> >> > > si_ is shorter than radeonsi_, but inconsistent with the directory >> >> > > and >> >> > > library name. I still think it's the best option, but no strong >> >> > > opinion >> >> > > from me. If and when the files are renamed, the next step would be >> >> > > doing the same with the r600_ struct and function names. >> >> > > Does that sound good? I'll send the patches shortly if so. >> >> > > >> >> > > Cheers, >> >> > > Andreas >> >> > > _______________________________________________ >> >> > > mesa-dev mailing list >> >> > > mesa-dev@lists.freedesktop.org >> >> > > http://lists.freedesktop.org/mailman/listinfo/mesa-dev > _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev