On 8 April 2013 09:15, Eric Anholt <e...@anholt.net> wrote: > Paul Berry <stereotype...@gmail.com> writes: > > > The vec4_visitor functions don't use any VS specific data from > > vec4_visitor::vp. So rename it to just "p" and change its type from > > struct gl_vertex_program * to struct gl_program *. This will allow > > the code to be re-used for geometry shaders. > > In many other places in the driver, "p" is a brw_compile. I'd rather > not overload that name. In a couple other cases where we've had both > the gl_shader_program and the gl_program, the shader_program becomes > "shader_prog" (only about 8 instances in brw_vec4) and gl_program gets > to be just "prog" >
That seems reasonable to me. I'll break this out into two patches, one to rename struct gl_shader_program *prog to shader_prog, and another to change the type of vp and rename it to prog. Note that gl_shader_program *prog appears in the backend_visitor base class, so renaming it will affect fs code too.
_______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev