> > Would you be satified if I simply duplicated the code?
>
> Well I had a look at your patch and I really think you should just let it
> there!
This sounds suspiciously like admitting that you criticized the patch
before reading it.
Maybe I am overreacting a bit currently...
> This is only the creation of the outermost Inset and all this stuff
> is there, or should we create "global" functions inside all inset definitions
> and then call this function instead of just handling it there.
I don't understand this.
> You anyway need it there you cannot remove the case xxx: stuff so my
> option is to leave it as is, as this is consistent with the other stuff.
Putting everything in the big switch _and doing part of the work there_
is stupid. I don't want mathed to participate in such stupidities...
> If we decide to do it the way you showed us, we should do this for ALL
> insets.
... and I don't really care for the other insets.
[IMNSHO the big switch could be a ten liner like
... Dispatch(BufferView * bv, action, string argument)
{
big_lynxfunc_map_type::iterator it = big_lynxfunc_map.find(action);
if (it == big_lynxfunc_map.find(action))
// not found
else
(*(it->second))(bv, argument)
}
or something like that. Mathed could now participate in such a scheme
easily, the other insets probably not. So what.]
All I want is all math stuff confined to src/mathed. Nothing less, nothing
more. And I want non-math stuff outside of src/mathed as far as this is
painlessly possible.
Andre'
--
André Pönitz ............................................. [EMAIL PROTECTED]