compnerd added inline comments.

================
Comment at: source/Commands/CommandObjectMemory.cpp:479
+            if (persistent_vars->SetCompilerTypeFromPersistentDecl(
+                    lookup_type_name, clang_ast_type))
+              break;
----------------
Why is the parameter `clang_ast_type` and not based on 
`persistent_vars->getKind()`?


================
Comment at: 
source/Plugins/ExpressionParser/Clang/ClangPersistentVariables.cpp:58
+    ConstString type_name, CompilerType &compiler_type) {
+  if (clang::TypeDecl *tdecl = llvm::dyn_cast_or_null<clang::TypeDecl>(
+          GetPersistentDecl(type_name))) {
----------------
NIT: `decl` would be a nicer name


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D62797/new/

https://reviews.llvm.org/D62797



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to