On Mon, Nov 23, 2009 at 12:44 PM, Albert Herranz <albert_herr...@yahoo.es> wrote: > Grant Likely wrote: >> On Sun, Nov 22, 2009 at 3:01 PM, Albert Herranz <albert_herr...@yahoo.es> >> wrote: >>> + /* devices contained int the flipper chipset */ >>> + soc { >> >> It would be better to rename this as IMMR or the bus type. This node >> doesn't actually describe the entire chip, but describes the internal >> memory mapped registers. >> > > Can you please elaborate more on this or point me to documentation? > The soc node here tries to represent the big multi-function chip that > integrates most of the devices of the video game consoles ("Flipper" on the > Nintendo GameCube and "Hollywood" on the Wii).
Right. Much like many other SoCs. However, the SoC has all these devices + the cpu core + the memory controller, and probably some other stuff. Whereas this particular node only encapsulates the integrated peripherals on an internal bus, so the node really is describing the internal bus, not the entire SoC. On some chips it is documented as the "internally memory mapped registers", or IMMR. So, it is better to name this node in a way that reflects what it is (an internal bus) instead of as the whole chip. Similarly, it is better to use a compatible value of something like: compatible = "nintendo,flipper-immr"; (instead of "nintendo,flipper") because your describing just the internal bus, not the entire chip. g. -- Grant Likely, B.Sc., P.Eng. Secret Lab Technologies Ltd. _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev