On Mon, 2023-03-06 at 15:33 -0600, Nathan Lynch via B4 Relay wrote: > From: Nathan Lynch <nath...@linux.ibm.com> > > The function name va_rtas_call_unlocked() is confusing: it may be > called with or without rtas_lock held. Rename it to va_rtas_call(). > > Signed-off-by: Nathan Lynch <nath...@linux.ibm.com>
Not a huge fan of the name, the va_ suggests that the only difference between this function and rtas_call() is the varargs handling. Perhaps something like __rtas_call()? > --- > arch/powerpc/kernel/rtas.c | 9 ++++----- > 1 file changed, 4 insertions(+), 5 deletions(-) > > diff --git a/arch/powerpc/kernel/rtas.c b/arch/powerpc/kernel/rtas.c > index c29c38b1a55a..96a10a0abe3a 100644 > --- a/arch/powerpc/kernel/rtas.c > +++ b/arch/powerpc/kernel/rtas.c > @@ -996,9 +996,8 @@ static void __init init_error_log_max(void) {} > #endif > > > -static void > -va_rtas_call_unlocked(struct rtas_args *args, int token, int nargs, > int nret, > - va_list list) > +static void va_rtas_call(struct rtas_args *args, int token, int > nargs, int nret, > + va_list list) > { > int i; > > @@ -1038,7 +1037,7 @@ void rtas_call_unlocked(struct rtas_args *args, > int token, int nargs, int nret, > va_list list; > > va_start(list, nret); > - va_rtas_call_unlocked(args, token, nargs, nret, list); > + va_rtas_call(args, token, nargs, nret, list); > va_end(list); > } > > @@ -1138,7 +1137,7 @@ int rtas_call(int token, int nargs, int nret, > int *outputs, ...) > args = &rtas_args; > > va_start(list, outputs); > - va_rtas_call_unlocked(args, token, nargs, nret, list); > + va_rtas_call(args, token, nargs, nret, list); > va_end(list); > > /* A -1 return code indicates that the last command couldn't > -- Andrew Donnellan OzLabs, ADL Canberra a...@linux.ibm.com IBM Australia Limited