linux-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH 2/2] hv: vmbus: add virtual memory fallback for ring buffer allocations under memory pressure
Emerson Busson
RE: [PATCH 2/2] hv: vmbus: add virtual memory fallback for ring buffer allocations under memory pressure
Michael Kelley
Re: [PATCH v14 03/22] KVM: selftests: Initialize the TDX VM
Lisa Wang
[PATCH v5 00/19] crypto: cmh - add Rambus CryptoManager Hub driver
Alex Ousherovitch
[PATCH v5 01/19] dt-bindings: crypto: add Rambus CryptoManager Hub
Alex Ousherovitch
[PATCH v5 06/19] crypto: cmh - add CSHAKE/KMAC ahash
Alex Ousherovitch
[PATCH v5 13/19] crypto: cmh - add ECDSA/SM2 sig
Alex Ousherovitch
[PATCH v5 18/19] selftests: crypto: cmh - add kselftest for management ioctl
Alex Ousherovitch
[PATCH v5 14/19] crypto: cmh - add ECDH/X25519 kpp
Alex Ousherovitch
[PATCH v5 16/19] crypto: cmh - add SLH-DSA/LMS/XMSS (HCQ)
Alex Ousherovitch
[PATCH v5 08/19] crypto: cmh - add AES skcipher/aead/cmac
Alex Ousherovitch
[PATCH v5 11/19] crypto: cmh - add DRBG hwrng
Alex Ousherovitch
[PATCH v5 19/19] MAINTAINERS: add Rambus CryptoManager Hub (CMH)
Alex Ousherovitch
[PATCH v5 09/19] crypto: cmh - add SM4 skcipher/aead/cmac/xcbc
Alex Ousherovitch
[PATCH v5 12/19] crypto: cmh - add RSA akcipher
Alex Ousherovitch
[PATCH v5 17/19] Documentation: ioctl: add CMH ioctl documentation and register 'J'
Alex Ousherovitch
[PATCH v5 10/19] crypto: cmh - add ChaCha20-Poly1305
Alex Ousherovitch
[PATCH v5 04/19] crypto: cmh - add SHA-2/SHA-3/SHAKE ahash
Alex Ousherovitch
Re: [PATCH v5 04/19] crypto: cmh - add SHA-2/SHA-3/SHAKE ahash
Herbert Xu
RE: [PATCH v5 04/19] crypto: cmh - add SHA-2/SHA-3/SHAKE ahash
Ousherovitch, Alex
[PATCH v5 07/19] crypto: cmh - add SM3 ahash
Alex Ousherovitch
[PATCH v5 05/19] crypto: cmh - add HMAC ahash
Alex Ousherovitch
[PATCH v5 15/19] crypto: cmh - add ML-KEM/ML-DSA (QSE)
Alex Ousherovitch
Re: [PATCH v5 00/19] crypto: cmh - add Rambus CryptoManager Hub driver
Herbert Xu
RE: [PATCH v5 00/19] crypto: cmh - add Rambus CryptoManager Hub driver
Ousherovitch, Alex
Re: [PATCH v10 6/6] alloc_tag: Defer /proc/allocinfo removal to a workqueue
Suren Baghdasaryan
Re: [PATCH v10 6/6] alloc_tag: Defer /proc/allocinfo removal to a workqueue
Hao Ge
Re: [PATCH v10 6/6] alloc_tag: Defer /proc/allocinfo removal to a workqueue
Suren Baghdasaryan
Re: [PATCH v10 6/6] alloc_tag: Defer /proc/allocinfo removal to a workqueue
Hao Ge
Re: [PATCH v10 4/6] module: allocate codetag sections before the regular module layout
Suren Baghdasaryan
Re: [PATCH] tpm: fix build regression for tpm_tis_resume
Jarkko Sakkinen
[PATCH] leds: aat1290: Allocate mm_current_scale with ARRAY_SIZE()
Kees Cook
Re: (subset) [PATCH] leds: aat1290: Allocate mm_current_scale with ARRAY_SIZE()
Lee Jones
Re: [PATCH v10 5/6] alloc_tag: skip percpu counter allocation when profiling is disabled
Suren Baghdasaryan
Re: [PATCH v10 5/6] alloc_tag: skip percpu counter allocation when profiling is disabled
Hao Ge
Re: [PATCH v10 5/6] alloc_tag: skip percpu counter allocation when profiling is disabled
Suren Baghdasaryan
Re: [PATCH v2] tpm: Remove ineffective wmb() from tpm_pm_resume()
Jarkko Sakkinen
[PATCH] pinctrl: mediatek: Fix eint->base allocation type
Kees Cook
Re: [PATCH v1 0/4] x86/vmware: Preserve panic diagnostics in vmware.log
Maaz Mombasawala
[PATCH] phy: realtek: usb: Remove const from phy_cfg allocation type
Kees Cook
[PATCH] extcon: realtek: Remove const from type_c_cfg allocation type
Kees Cook
[PATCH v6 0/5] mm: Fix MF_DELAYED handling on memory failure
Lisa Wang
[PATCH v6 3/5] mm: shmem: Update shmem handler to the MF_DELAYED definition
Lisa Wang
[PATCH v6 1/5] mm: memory_failure: Clarify the MF_DELAYED definition
Lisa Wang
[PATCH v6 5/5] mm: selftests: Add shmem into memory failure test
Lisa Wang
[PATCH v6 4/5] mm: memory_failure: Generalize extra_pins handling to all MF_DELAYED cases
Lisa Wang
Re: [PATCH v6 0/5] mm: Fix MF_DELAYED handling on memory failure
Andrew Morton
[PATCH v6 2/5] mm: memory_failure: Allow truncate_error_folio to return MF_DELAYED
Lisa Wang
[PATCH] ASoC: rockchip: rk3399_gru_sound: Allocate dai_link with ARRAY_SIZE()
Kees Cook
Re: [PATCH] ASoC: rockchip: rk3399_gru_sound: Allocate dai_link with ARRAY_SIZE()
Mark Brown
[PATCH] tpm: Disable TPM on null key name mismatch
Surendran Kanagaraj
Re: [PATCH] tpm: Disable TPM on null key name mismatch
Jarkko Sakkinen
Re: [PATCH] tpm: Disable TPM on null key name mismatch
Gunnar Kudrjavets
[PATCH] vt: keyboard: Allocate new_map with ARRAY_SIZE()
Kees Cook
[PATCH RFC] wifi: ath10k: skip completion wait for pairwise key removal
David Heidelberg via B4 Relay
[PATCH] pinctrl: qcom: tlmm-test: Add const to reg_names allocation type
Kees Cook
Re: [PATCH] pinctrl: qcom: tlmm-test: Add const to reg_names allocation type
Konrad Dybcio
Re: [PATCH] pinctrl: qcom: tlmm-test: Add const to reg_names allocation type
Bartosz Golaszewski
[PATCH] nvmem: core: Add const to pattrs allocation type
Kees Cook
Re: [PATCH] nvmem: core: Add const to pattrs allocation type
Srinivas Kandagatla
Re: [PATCH] nvmem: core: Add const to pattrs allocation type
Kees Cook
Re: [PATCH] nvmem: core: Add const to pattrs allocation type
Srinivas Kandagatla
Re: [PATCH] serial: qcom-geni: Fix unbalanced runtime PM resume for no_console_suspend
David Heidelberg
[PATCH v2] drivers/hv: remove deposited pages from direct map
Magnus Kulke
[PATCH] ASoC: codecs: wm8904: Add const to drc_texts allocation type
Kees Cook
Re: [PATCH] ASoC: codecs: wm8904: Add const to drc_texts allocation type
Charles Keepax
Re: [PATCH] ASoC: codecs: wm8904: Add const to drc_texts allocation type
Mark Brown
[PATCH] s390/keyboard: Allocate key_maps and func_table with ARRAY_SIZE()
Kees Cook
Re: [PATCH] s390/keyboard: Allocate key_maps and func_table with ARRAY_SIZE()
Heiko Carstens
[PATCH] hwmon: asus_wmi_sensors: Fix info[] allocation type
Kees Cook
Re: [PATCH] hwmon: asus_wmi_sensors: Fix info[] allocation type
Guenter Roeck
[PATCH] pinctrl: imx: Remove const from group_names allocation type
Kees Cook
[PATCH v2 0/2] module: close two ELF section-validation gaps
Fang Xieyan
[PATCH v2 1/2] module: Sanitize the undefined sh_name of SHT_NULL sections
Fang Xieyan
[PATCH v2 2/2] module: Validate the __version_ext_names section type
Fang Xieyan
[PATCH 0/2] x86/fred: Reconstruct fault state for rejected INT instructions
Matthew Schwartz
[PATCH 1/2] x86/fred: Reconstruct the #GP context for rejected INT instructions
Matthew Schwartz
Re: [PATCH 1/2] x86/fred: Reconstruct the #GP context for rejected INT instructions
H. Peter Anvin
Re: [PATCH 1/2] x86/fred: Reconstruct the #GP context for rejected INT instructions
Peter Zijlstra
[PATCH 2/2] selftests/x86: Check signal state for rejected software interrupts
Matthew Schwartz
[PATCH] hwmon: pwm-fan: Add const to channels allocation type
Kees Cook
Re: [PATCH] hwmon: pwm-fan: Add const to channels allocation type
Guenter Roeck
[PATCH net-next v3 0/3] net: hash uncached route lists by device
Chris J Arges
[PATCH net-next v3 1/3] ipv4: hash uncached routes by device
Chris J Arges
[PATCH net-next v3 3/3] selftests: net: cover IPv6 uncached route device mismatch
Chris J Arges
Re: [PATCH net-next v3 3/3] selftests: net: cover IPv6 uncached route device mismatch
netdev-bot+sashiko
[PATCH net-next v3 2/3] ipv6: hash uncached routes by device
Chris J Arges
Re: [PATCH net-next v3 2/3] ipv6: hash uncached routes by device
netdev-bot+sashiko
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Kuniyuki Iwashima
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Chris Arges
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Kuniyuki Iwashima
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Chris Arges
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Kuniyuki Iwashima
[PATCH] iio: imu: st_lsm6dsx: Allocate ext_channels with ARRAY_SIZE()
Kees Cook
Re: [PATCH] iio: imu: st_lsm6dsx: Allocate ext_channels with ARRAY_SIZE()
Lorenzo Bianconi
Re: [PATCH] iio: imu: st_lsm6dsx: Allocate ext_channels with ARRAY_SIZE()
Jonathan Cameron
[PATCH net-next] octeontx2-af: Allocate ikpu2 with ARRAY_SIZE()
Kees Cook
Re: [PATCH net-next] octeontx2-af: Allocate ikpu2 with ARRAY_SIZE()
Ratheesh Kannoth
Re: [PATCH net-next] octeontx2-af: Allocate ikpu2 with ARRAY_SIZE()
patchwork-bot+netdevbpf
Re: [PATCH v10 3/6] module: introduce SH_ENTSIZE_STANDALONE for separately allocated sections
Suren Baghdasaryan
Re: [PATCH v10 3/6] module: introduce SH_ENTSIZE_STANDALONE for separately allocated sections
Hao Ge
Re: [PATCH] slimbus: qcom-ngd-ctrl: match downstream DEF_ACT_CHAN encoding
Srinivas Kandagatla
[PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Hemendra M. Naik
[PATCH net-next v6 2/3] selftests: tc-testing: add fq_pie per-flow class stats test
Hemendra M. Naik
Re: [PATCH net-next v6 2/3] selftests: tc-testing: add fq_pie per-flow class stats test
netdev-bot+sashiko
Re: [PATCH net-next v6 2/3] selftests: tc-testing: add fq_pie per-flow class stats test
Hemendra M. Naik
[PATCH net-next v6 1/3] net/sched: sch_fq_pie: add per-flow statistics via class ops
Hemendra M. Naik
Re: [PATCH net-next v6 1/3] net/sched: sch_fq_pie: add per-flow statistics via class ops
netdev-bot+sashiko
Re: [PATCH net-next v6 1/3] net/sched: sch_fq_pie: add per-flow statistics via class ops
Hemendra M. Naik
[PATCH net-next v6 3/3] net/sched: pie: correct tc_pie_xstats field documentation
Hemendra M. Naik
Re: [PATCH net-next v6 3/3] net/sched: pie: correct tc_pie_xstats field documentation
netdev-bot+sashiko
Re: [PATCH net-next v6 3/3] net/sched: pie: correct tc_pie_xstats field documentation
Hemendra M. Naik
Re: [PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Jakub Kicinski
Re: [PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Hemendra M. Naik
Re: [PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Jakub Kicinski
Re: [PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Hemendra M. Naik
Re: [PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Jakub Kicinski
[PATCH] scsi: hpsa: Make buff allocation type unsigned
Kees Cook
[PATCH] regulator: axp20x: Remove const from new_desc allocation types
Kees Cook
Re: [PATCH] regulator: axp20x: Remove const from new_desc allocation types
Mark Brown
[PATCH] power: supply: qcom_smbx: Remove const from desc allocation type
Kees Cook
Re: [PATCH] power: supply: qcom_smbx: Remove const from desc allocation type
Konrad Dybcio
[PATCH] pinctrl: s32cc: Remove const from groups allocation type
Kees Cook
[PATCH] gpio: it87: Remove const from labels_table allocation type
Kees Cook
Re: [PATCH] gpio: it87: Remove const from labels_table allocation type
Bartosz Golaszewski
[PATCH] hwmon: scmi: Fix info[] allocation type
Kees Cook
Re: [PATCH] hwmon: scmi: Fix info[] allocation type
Guenter Roeck
Re: [PATCH] hwmon: scmi: Fix info[] allocation type
Guenter Roeck
[PATCH] 9p: Add const and unsigned to wnames allocation type
Kees Cook
Re: [PATCH] 9p: Add const and unsigned to wnames allocation type
Dominique Martinet
[PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Kees Cook
Re: [PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Andy Shevchenko
Re: [PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Jonathan Cameron
Re: [PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Kees Cook
Re: [PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Joshua Crofts
[PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Kees Cook
Re: [PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Charles Keepax
Re: [PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Cezary Rojewski
Re: [PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Mark Brown
[PATCH] ASoC: SOF: topology: Add const to tplg_files allocation type
Kees Cook
Re: [PATCH] ASoC: SOF: topology: Add const to tplg_files allocation type
Mark Brown
[PATCH v3] drivers/hv: remove deposited pages from direct map
Magnus Kulke
Re: [PATCH v3] drivers/hv: remove deposited pages from direct map
Mukesh R
Re: [PATCH v3] drivers/hv: remove deposited pages from direct map
Magnus Kulke
Re: [PATCH v3] drivers/hv: remove deposited pages from direct map
Wei Liu
Re: [PATCH v3] drivers/hv: remove deposited pages from direct map
Wei Liu
[PATCH] coresight: cti: Add const to con_groups allocation type
Kees Cook
Re: [PATCH] coresight: cti: Add const to con_groups allocation type
Mike Leach
[PATCH] hwmon: hp-wmi-sensors: Fix info_map[] allocation type
Kees Cook
Re: [PATCH] hwmon: hp-wmi-sensors: Fix info_map[] allocation type
James Seo
Re: [PATCH] hwmon: hp-wmi-sensors: Fix info_map[] allocation type
Guenter Roeck
[PATCH] memory: emif: Remove const from min_tck allocation type
Kees Cook
Re: [PATCH] memory: emif: Remove const from min_tck allocation type
Krzysztof Kozlowski
[PATCH] modules/kmod: Allocate argv with kmalloc_array()
Kees Cook
Re: [PATCH] modules/kmod: Allocate argv with kmalloc_array()
Petr Pavlu
[PATCH] KVM: selftests: Drop the unsigned >= 0 assertions in test_write/test_read
Gokul K
Re: [PATCH] KVM: selftests: Drop the unsigned >= 0 assertions in test_write/test_read
Sean Christopherson
Re: [PATCH v2 0/6] cpuidle: speed up do_idle() by caching the governor latency QoS constraint
Rafael J. Wysocki (Intel)
Re: [PATCH v2 0/6] cpuidle: speed up do_idle() by caching the governor latency QoS constraint
Yaxiong Tian
Re: [PATCH v2 0/6] cpuidle: speed up do_idle() by caching the governor latency QoS constraint
Rafael J. Wysocki (Intel)
Re: [PATCH v2 0/6] cpuidle: speed up do_idle() by caching the governor latency QoS constraint
Yaxiong Tian
[PATCH v9 0/4] media: add virtio-media driver
Brian Daniels
[PATCH v9 3/4] media: virtio: Add scatterlist builder
Brian Daniels
Re: [PATCH v9 3/4] media: virtio: Add scatterlist builder
Michael S. Tsirkin
[PATCH v9 2/4] media: virtio: Add session management
Brian Daniels
Re: [PATCH v9 2/4] media: virtio: Add session management
Albert Esteve
Re: [PATCH v9 2/4] media: virtio: Add session management
Michael S. Tsirkin
[PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Brian Daniels
Re: [PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Albert Esteve
Re: [PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Brian Daniels
Re: [PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Michael S. Tsirkin
Re: [PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Brian Daniels
Re: [PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Michael S. Tsirkin
Re: [PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Brian Daniels
[PATCH v9 4/4] media: virtio: Add ioctl operations and driver logic
Brian Daniels
Re: [PATCH v9 4/4] media: virtio: Add ioctl operations and driver logic
Albert Esteve
Re: [PATCH v9 4/4] media: virtio: Add ioctl operations and driver logic
Nick Rogers
Re: [syzbot] [wpan?] WARNING in hwsim_hw_xmit
syzbot
[PATCH v4 0/4] remoteproc: imx_rpoc: use memory-region-names to avoid hidden ABI.
Frank . Li
[PATCH v4 4/4] arm64: dts: freescale: add DT overlay for MX95-15x15-FRDM RPMSG usage
Frank . Li
[PATCH v4 1/4] dt-bindings: remoteproc: imx_rproc: document memory-region-names to avoid hidden ABI
Frank . Li
[PATCH v4 2/4] remoteproc: imx_rpoc: use memory-region-names to avoid hidden ABI
Frank . Li
[PATCH v4 3/4] arm64: dts: freescale: imx95-15x15-frdm: remove some rmem regions
Frank . Li
[PATCH 00/10] mm/damon: improve readability, clarity and test coverage
SJ Park
[PATCH 09/10] selftests/damon/sysfs_memcg_path_leak: fail only for real DAMON leak
SJ Park
Re: [PATCH 00/10] mm/damon: improve readability, clarity and test coverage
SJ Park
[PATCH 07/10] mm/damon/tests/core-kunit: test eligible_mem_bp commitment
SJ Park
[PATCH 08/10] mm/damon/tests/core-kunit: add probe_hits_wsum damos filter commit test
SJ Park
Re: [PATCH 00/10] mm/damon: improve readability, clarity and test coverage
Andrew Morton
Re: [PATCH net-next v2 2/2] selftests: net: test untracked NA recovery of FAILED neighbors
netdev-bot+sashiko
Re: [PATCH net-next v2 2/2] selftests: net: test untracked NA recovery of FAILED neighbors
Lawrence Lee
[PATCH v3 00/20] kbuild: significantly speed up kernel builds
Lorenzo Stoakes (ARM)
[PATCH v3 07/20] kallsyms: reimplement mksysmap in C
Lorenzo Stoakes (ARM)
Re: [PATCH v3 07/20] kallsyms: reimplement mksysmap in C
Kees Cook
Re: [PATCH v3 07/20] kallsyms: reimplement mksysmap in C
Lorenzo Stoakes (ARM)
Re: [PATCH v3 07/20] kallsyms: reimplement mksysmap in C
Lorenzo Stoakes (ARM)
[PATCH v3 17/20] objtool: decode instructions and resolve branch targets in parallel
Lorenzo Stoakes (ARM)
Re: [PATCH v3 17/20] objtool: decode instructions and resolve branch targets in parallel
Josh Poimboeuf
Re: [PATCH v3 17/20] objtool: decode instructions and resolve branch targets in parallel
Lorenzo Stoakes (ARM)
[PATCH v3 14/20] kbuild: batch module finalisation
Lorenzo Stoakes (ARM)
Earlier messages
Later messages