On Tue, Jun 10, 2014 at 07:45:47PM +0800, Ming Lei wrote: > OK, but the API name is a bit confusing, and that is easy to cause > misuse, like in nvme. > > Also requeue one request in completion handler may be a > common case, so maybe it is better to let blk_mq_requeue_request() > handle both adding to request list and kicking off, and introduce > blk_mq_prep_requeue_req()(or better name) to batch operations.
For now please just add some documentation. I'm happy to revisit these once we have a few user in tree, but for now I'd like to keep blk-mq a little more stable to not impact the merges of the major users. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/