linux-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[RFC PATCH v2 03/11] KVM: SEV: Remove struct page dependency from SNP gmem paths
David Woodhouse
[RFC PATCH v2 05/11] iommufd: Look up private-interconnect phys via exporter symbols
David Woodhouse
[RFC PATCH v2 04/11] KVM: guest_memfd: Introduce guest memory ops and route native gmem through them
David Woodhouse
[RFC PATCH v2 08/11] samples/kvm: Add guest_memfd backing sample
David Woodhouse
Re: [RFC PATCH v2 00/11] KVM: Allow alternative providers of guest_memfd backed by PFNMAP memory
Paolo Bonzini
Re: [RFC PATCH v2 00/11] KVM: Allow alternative providers of guest_memfd backed by PFNMAP memory
David Woodhouse
[PATCH v6 0/2] Add initial dual front camera and rear flash support for Pixel 3 / 3 XL
David Heidelberg via B4 Relay
[PATCH v6 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
David Heidelberg via B4 Relay
Re: [PATCH v6 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
Konrad Dybcio
Re: [PATCH v6 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
David Heidelberg
[PATCH v6 2/2] arm64: dts: qcom: sdm845-google: Enable PMI8998 camera flash LEDs
David Heidelberg via B4 Relay
[PATCH] selftests/mm: transhuge-stress: check duration inside page loop
Sarthak Sharma
[PATCH v5 0/5] vhost/vsock: add support for VHOST_RESET_OWNER and CPR migration
Andrey Drobyshev
[PATCH v5 1/5] vhost/vsock: split out vhost_vsock_drop_backends helper
Andrey Drobyshev
[PATCH v5 4/5] vhost: synchronize with RCU readers when freeing workers
Andrey Drobyshev
[PATCH v5 5/5] vhost/vsock: add VHOST_RESET_OWNER ioctl
Andrey Drobyshev
[PATCH v5 3/5] vhost/vsock: re-scan TX virtqueue on device start
Andrey Drobyshev
[PATCH v5 2/5] vhost/vsock: suppress EHOSTUNREACH fast-fail during CPR pause
Andrey Drobyshev
[PATCH RFC] MAINTAINERS: Add Matrix channel to the NFC subsystem
David Heidelberg via B4 Relay
[PATCH] rcu-tasks: Rename tasks_rcu_exit_srcu_stall_timer to tasks_rcu_exit_stall_timer
Zqiang
[PATCH] dm-pcache: fix implicit u8 truncation of gc_percent in message handler
jianyungao89
[PATCH 2/3] sched: Convert paravirt_steal to new static key APIs
Hongyan Xia
Re: [PATCH 2/3] sched: Convert paravirt_steal to new static key APIs
Jürgen Groß
[PATCH 0/1] scripts: kstack_erase: avoid absolute stackleak plugin path
Jaihind Yadav
[PATCH 1/1] scripts: kstack_erase: use relative stackleak plugin path
Jaihind Yadav
[PATCH v2 0/2] kselftest/arm64: Add two arm64 kselftests for orig_x0 issue
Jinjie Ruan
[PATCH v2 2/2] kselftest/arm64: Add testcase for SECCOMP_RET_TRACE orig_x0 bypass
Jinjie Ruan
[PATCH v2 1/2] kselftest/arm64: Add seccomp ptrace x0 bypass test
Jinjie Ruan
Re: [PATCH v2 0/4] ACPI: APEI: GHES: Add NVIDIA Vera CPER decoder and tests
Kai-Heng Feng
Re: [PATCH v3 3/3] Documentation: deprecated.rst: kmalloc-family: mark argument as optional
Manuel Ebner
[PATCH bpf-next v4 0/2] bpf: add bpf_strcat,bpf_strncat kfunc
Rong Tao
[PATCH bpf-next v4 2/2] selftests/bpf: Test bpf_strcat,bpf_strncat kfuncs
Rong Tao
Re: [PATCH bpf-next v4 2/2] selftests/bpf: Test bpf_strcat,bpf_strncat kfuncs
bot+bpf-ci
[PATCH bpf-next v4 1/2] bpf: add bpf_strcat,bpf_strncat kfunc
Rong Tao
[PATCH v5] gpio: kunit: add test cases verifying swnode devlink support
Bartosz Golaszewski
Re: [PATCH v5] gpio: kunit: add test cases verifying swnode devlink support
Bartosz Golaszewski
[PATCH] selftests/mm: use MAP_FAILED for mmap error check
longlong yan
Re: [PATCH] selftests/mm: use MAP_FAILED for mmap error check
Lorenzo Stoakes (ARM)
Re: [PATCH] selftests/mm: use MAP_FAILED for mmap error check
David Hildenbrand (Arm)
[PATCH] selftests/proc: make proc-maps-race work with READ_IMPLIES_EXEC
Karl Mehltretter
[PATCH v9 00/16] KVM: arm64: PMU: Use multiple host PMUs
Akihiko Odaki
[PATCH v9 06/16] KVM: arm64: PMU: Recreate events after MDCR_EL2 changes
Akihiko Odaki
[PATCH v9 15/16] KVM: arm64: PMU: Introduce FIXED_COUNTERS_ONLY
Akihiko Odaki
[PATCH v9 03/16] KVM: arm64: PMU: Freeze counter count after first run
Akihiko Odaki
[PATCH v9 13/16] KVM: arm64: PMU: Pass the target CPU to kvm_pmu_probe_armpmu()
Akihiko Odaki
[PATCH v9 16/16] KVM: arm64: selftests: Test PMU_V3_FIXED_COUNTERS_ONLY
Akihiko Odaki
[PATCH v9 12/16] KVM: arm64: PMU: Pass the pPMU to kvm_map_pmu_event()
Akihiko Odaki
[PATCH v9 08/16] KVM: arm64: selftests: Cover PMU state in MDCR_EL2
Akihiko Odaki
[PATCH v9 11/16] KVM: arm64: PMU: Protect the list of PMUs with RCU
Akihiko Odaki
[PATCH v9 14/16] KVM: arm64: PMU: Implement fixed-counters-only emulation
Akihiko Odaki
[PATCH v9 05/16] KVM: arm64: PMU: Keep implemented counter mask EL-independent
Akihiko Odaki
[PATCH v9 04/16] KVM: arm64: selftests: Test SET_NR_COUNTERS after first run
Akihiko Odaki
[PATCH v9 01/16] KVM: arm64: Serialize repeated vCPU initialization
Akihiko Odaki
[PATCH v9 07/16] tools headers: Use u* types for bitfield helpers
Akihiko Odaki
[PATCH v9 02/16] KVM: arm64: PMU: Stop updating MDCR_EL2.HPMN
Akihiko Odaki
[PATCH v9 09/16] arm64: errata: Require Apple IMPDEF PMUv3 traps on all CPUs
Akihiko Odaki
[PATCH v9 10/16] KVM: arm64: Don't clear vcpu->cpu in kvm_arch_vcpu_put()
Akihiko Odaki
[PATCH V11 0/9] famfs: port into fuse
John Groves
[PATCH V11 1/9] famfs_fuse: Update macro s/FUSE_IS_DAX/FUSE_IS_VIRTIO_DAX/
John Groves
[PATCH V11 7/9] famfs_fuse: fail I/O on invalid or errored daxdevs
John Groves
[PATCH V11 2/9] famfs_fuse: Basic fuse kernel ABI enablement for famfs
John Groves
[PATCH V11 3/9] famfs_fuse: Plumb the GET_FMAP message/response
John Groves
[PATCH V11 4/9] famfs_fuse: Create files with famfs fmaps
John Groves
[PATCH V11 5/9] famfs_fuse: register fs-dax daxdevs via FUSE_DEV_IOC_DAXDEV_OPEN
John Groves
[PATCH V11 6/9] famfs_fuse: Plumb dax iomap and fuse read/write/mmap
John Groves
[PATCH V11 8/9] famfs_fuse: Add DAX address_space_operations with noop_dirty_folio
John Groves
[PATCH V11 9/9] famfs_fuse: Add documentation
John Groves
Re: [PATCH V11 0/9] famfs: port into fuse
Amir Goldstein
[RFC PATCH] dm-pcache: fix use-after-free and invalid seg operations in kset_replay()
jianyungao89
[RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
Lian Wang
[RFC PATCH v3 1/3] mm/damon: introduce DAMOS_SPLIT action
Lian Wang
Re: [RFC PATCH v3 1/3] mm/damon: introduce DAMOS_SPLIT action
Gutierrez Asier
Re: [RFC PATCH v3 1/3] mm/damon: introduce DAMOS_SPLIT action
Lian Wang
[RFC PATCH v3 3/3] selftests/damon: add functional test for DAMOS_SPLIT
Lian Wang
[RFC PATCH v3 2/3] mm/damon/vaddr: implement DAMOS_SPLIT handler
Lian Wang
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
Gutierrez Asier
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
Lian Wang
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
David Hildenbrand (Arm)
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
Lian Wang
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
Zi Yan
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
SJ Park
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
Lian Wang
Re: [RFC PATCH v3 0/3] mm/damon: introduce DAMOS_SPLIT action
SJ Park
[PATCH] selftests/sgx: use MAP_FAILED for mmap error check
longlong yan
[PATCH] tools/virtio: Fix control typo in trace agent comment
GuoHan Zhao
[PATCH] tools/virtio: Fix userspace typo in vringh test comment
GuoHan Zhao
[PATCH v13 00/32] KVM: arm64: Implement support for SME
Mark Brown
[PATCH v13 06/32] arm64/fpsimd: Determine maximum virtualisable SME vector length
Mark Brown
[PATCH v13 01/32] arm64/sysreg: Define full value read/modify/write helpers
Mark Brown
[PATCH v13 04/32] arm64/fpsimd: Decide to save ZT0 and streaming mode FFR at bind time
Mark Brown
[PATCH v13 02/32] arm64/fpsimd: Ensure all of ZCR_EL1 is initialised from idle
Mark Brown
[PATCH v13 09/32] KVM: arm64: Pull ctxt_has_ helpers to start of sysreg-sr.h
Mark Brown
[PATCH v13 12/32] KVM: arm64: Define internal features for SME
Mark Brown
[PATCH v13 03/32] arm64/fpsimd: Configure all ZCR/SMCR bits when loading task state
Mark Brown
[PATCH v13 13/32] KVM: arm64: Rename sve_state_reg_region
Mark Brown
[PATCH v13 10/32] KVM: arm64: Rename SVE finalization constants to be more general
Mark Brown
[PATCH v13 14/32] KVM: arm64: Store vector lengths in an array
Mark Brown
[PATCH v13 05/32] arm64/sve: Factor virtualizable VL discovery out of SVE specific code
Mark Brown
[PATCH v13 19/32] KVM: arm64: Support TPIDR2_EL0
Mark Brown
[PATCH v13 21/32] KVM: arm64: Support SME priority registers
Mark Brown
[PATCH v13 20/32] KVM: arm64: Support SME identification registers for guests
Mark Brown
[PATCH v13 07/32] KVM: arm64: Remove bitrotted comment on handle_sve()
Mark Brown
[PATCH v13 24/32] KVM: arm64: Expose SME specific state to userspace
Mark Brown
[PATCH v13 08/32] KVM: arm64: Handle FEAT_IDST for guest accesses to hidden registers
Mark Brown
[PATCH v13 27/32] KVM: arm64: Expose SME to nested guests
Mark Brown
[PATCH v13 18/32] KVM: arm64: Support SME control registers
Mark Brown
[PATCH v13 15/32] KVM: arm64: Factor SVE code out of fpsimd_lazy_switch_to_host()
Mark Brown
[PATCH v13 30/32] KVM: arm64: selftests: Skip impossible invalid value tests
Mark Brown
[PATCH v13 11/32] KVM: arm64: Remove special case for FP state loading from ZCR_EL2 traps
Mark Brown
[PATCH v13 32/32] KVM: arm64: selftests: Add SME to set_id_regs test
Mark Brown
[PATCH v13 16/32] KVM: arm64: Document the KVM ABI for SME
Mark Brown
[PATCH v13 17/32] KVM: arm64: Implement SME vector length configuration
Mark Brown
[PATCH v13 25/32] KVM: arm64: Context switch SME state for guests
Mark Brown
[PATCH v13 29/32] KVM: arm64: selftests: Remove spurious check for single bit safe values
Mark Brown
[PATCH v13 26/32] KVM: arm64: Handle SME exceptions
Mark Brown
[PATCH v13 22/32] KVM: arm64: Support userspace access to streaming mode Z and P registers
Mark Brown
[PATCH v13 23/32] KVM: arm64: Flush register state on writes to SVCR.SM and SVCR.ZA
Mark Brown
[PATCH v13 28/32] KVM: arm64: Provide interface for configuring and enabling SME for guests
Mark Brown
[PATCH v13 31/32] KVM: arm64: selftests: Add SME system registers to get-reg-list
Mark Brown
[PATCH] vsock: use sock_error() to consume sk_err after connect timeout
Nguyen Dinh Phi
Re: [PATCH] vsock: use sock_error() to consume sk_err after connect timeout
Stefano Garzarella
Re: [PATCH] vsock: use sock_error() to consume sk_err after connect timeout
Phi Nguyen
[PATCH RFC v2] wifi: ath10k: make in-order rx amsdu buffers persistent
David Heidelberg via B4 Relay
[PATCH v6 0/3] KVM: selftests: arm64: Improve diagnostics from set_id_regs
Mark Brown
[PATCH v6 3/3] KVM: selftests: arm64: Make set_id_regs bitfield validatity checks non-fatal
Mark Brown
[PATCH v6 1/3] KVM: selftests: arm64: Report set_id_reg reads of test registers as tests
Mark Brown
[PATCH v6 2/3] KVM: selftests: arm64: Report register reset tests individually
Mark Brown
[PATCH v5 0/2] Add initial dual front camera and rear flash support for Pixel 3 / 3 XL
David Heidelberg via B4 Relay
[PATCH v5 2/2] arm64: dts: qcom: sdm845-google: Enable PMI8998 camera flash LEDs
David Heidelberg via B4 Relay
Re: [PATCH v5 2/2] arm64: dts: qcom: sdm845-google: Enable PMI8998 camera flash LEDs
Konrad Dybcio
[PATCH v5 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
David Heidelberg via B4 Relay
Re: [PATCH v5 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
Konrad Dybcio
Re: [PATCH v5 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
David Heidelberg
[PATCH] dt-bindings: remoteproc: ti,wkup-m3: Convert to DT schema
Bhargav Joshi
[PATCH 0/2] Add Apple T2 NHI device links
Atharva Tiwari
[PATCH 1/2] treewide: Add a flag to detect the Apple T2 chip
Atharva Tiwari
[PATCH 2/2] thunderbolt: Add device links for Apple T2 NHI
Atharva Tiwari
[RFC PATCH net-next 00/13] net: knod: in-kernel network offload device
Taehee Yoo
[RFC PATCH net-next 01/13] net: knod: add uapi and core headers
Taehee Yoo
[RFC PATCH net-next 02/13] net: devmem: extend memory provider for knod
Taehee Yoo
Re: [RFC PATCH net-next 02/13] net: devmem: extend memory provider for knod
Mina Almasry
[RFC PATCH net-next 03/13] net: core: add XDP_MODE_HW offload hook for knod
Taehee Yoo
[RFC PATCH net-next 05/13] bpf: offload: allow PERCPU_ARRAY maps for offloaded programs
Taehee Yoo
[RFC PATCH net-next 06/13] drm/amdkfd: prepare kfd core for the knod provider
Taehee Yoo
[RFC PATCH net-next 07/13] drm/amdkfd: add knod provider core
Taehee Yoo
[RFC PATCH net-next 04/13] net: knod: add offload device core and control plane
Taehee Yoo
[RFC PATCH net-next 11/13] bnxt_en: add knod XDP offload support
Taehee Yoo
[RFC PATCH net-next 10/13] net/mlx5e: add knod XDP offload support
Taehee Yoo
[RFC PATCH net-next 12/13] selftests: drivers/net: add knod tests
Taehee Yoo
Re: [RFC PATCH net-next 00/13] net: knod: in-kernel network offload device
Mina Almasry
Re: [RFC PATCH net-next 08/13] drm/amdkfd: add GPU instruction emitter and disassembler
Andrew Lunn
[PATCH v4 0/2] Add initial dual front camera and rear flash support for Pixel 3 / 3 XL
David Heidelberg via B4 Relay
[PATCH v4 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
David Heidelberg via B4 Relay
[PATCH v4 2/2] arm64: dts: qcom: sdm845-google: Enable PMI8998 camera flash LEDs
David Heidelberg via B4 Relay
[PATCH net-next 0/5] bridge: Validate and clean up IPv6 neighbour suppression
Danielle Ratson
[PATCH net-next 1/5] bridge: Use direct pointer in br_is_nd_neigh_msg()
Danielle Ratson
Re: [PATCH net-next 1/5] bridge: Use direct pointer in br_is_nd_neigh_msg()
Nikolay Aleksandrov
[PATCH net-next 4/5] bridge: Linearize skb once the ND message type is validated
Danielle Ratson
Re: [PATCH net-next 4/5] bridge: Linearize skb once the ND message type is validated
Nikolay Aleksandrov
[PATCH net-next 5/5] bridge: Use ndisc_parse_options() to parse ND options in br_nd_send()
Danielle Ratson
Re: [PATCH net-next 5/5] bridge: Use ndisc_parse_options() to parse ND options in br_nd_send()
Nikolay Aleksandrov
[PATCH net-next 2/5] ipv6: ndisc: Add ndisc_check_ns_na() validation helper
Danielle Ratson
Re: [PATCH net-next 2/5] ipv6: ndisc: Add ndisc_check_ns_na() validation helper
Nikolay Aleksandrov
[PATCH net-next 3/5] bridge: Validate NS/NA messages using ndisc_check_ns_na()
Danielle Ratson
Re: [PATCH net-next 3/5] bridge: Validate NS/NA messages using ndisc_check_ns_na()
Nikolay Aleksandrov
Re: [PATCH net-next 0/5] bridge: Validate and clean up IPv6 neighbour suppression
Nikolay Aleksandrov
[PATCH] dm: ioctl: reserve space for NUL-terminator in build_constructor_string()
Ilya Krutskih
Re: fbdev: arkfb: Move a variable assignment behind a condition check in ics5342_init()
Markus Elfring
Re: fbdev: arkfb: Move a variable assignment behind a condition check in ics5342_init()
Markus Elfring
[PATCH] fscrypt: Avoid dynamic allocation in fscrypt_get_devices()
Eric Biggers
Re: [PATCH] fscrypt: Avoid dynamic allocation in fscrypt_get_devices()
Christoph Hellwig
Re: [PATCH] fscrypt: Avoid dynamic allocation in fscrypt_get_devices()
Eric Biggers
[PATCH] fscrypt: Add missing superblock check in find_or_insert_direct_key()
Eric Biggers
Re: [PATCH] fscrypt: Add missing superblock check in find_or_insert_direct_key()
Christoph Hellwig
Re: [PATCH] fscrypt: Add missing superblock check in find_or_insert_direct_key()
Eric Biggers
[PATCH 00/15] drm/drm_simple: remove drm_simple_encoder_init
Diogo Silva
[PATCH 01/15] drm/exynos: remove dependency on DRM simple helpers
Diogo Silva
Re: [PATCH 01/15] drm/exynos: remove dependency on DRM simple helpers
Thomas Zimmermann
Re: [PATCH 01/15] drm/exynos: remove dependency on DRM simple helpers
Diogo Silva
Re: [PATCH 01/15] drm/exynos: remove dependency on DRM simple helpers
Thomas Zimmermann
[PATCH 08/15] drm/imx: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 02/15] drm/xlnx/zynqmp_dpsub: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 10/15] drm/renesas/shmobile: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 03/15] drm/tegra: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 04/15] drm/fsl-dcu: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 12/15] drm/arm/komeda: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 05/15] drm/kmb: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 06/15] drm/virtio: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 14/15] drm/drm_simple: remove deprecated drm_simple_encoder_init function
Diogo Silva
[PATCH 07/15] drm/tidss: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 09/15] drm/mediatek: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 11/15] drm/hisilicon/kirin: remove dependency on DRM simple helpers
Diogo Silva
[PATCH 15/15] Documentation/gpu: remove completed drm_simple_encoder_init() todo
Diogo Silva
[PATCH 13/15] drm/meson: remove dependency on DRM simple helpers
Diogo Silva
[PATCH] fscrypt: Update encryption policy version docs
Eric Biggers
Re: [PATCH] fscrypt: Update encryption policy version docs
Eric Biggers
[PATCH] fscrypt: Replace some variable-size memsets with fixed-size
Eric Biggers
Re: [PATCH] fscrypt: Replace some variable-size memsets with fixed-size
Eric Biggers
[PATCH v6 0/2] module: Extend blacklist parameter to support built-in modules
Aaron Tomlin
[PATCH v6 1/2] module: Extend module_blacklist parameter to built-in modules
Aaron Tomlin
Earlier messages
Later messages