On 10/08/2016 10:11 AM, Nilay Vaish wrote: >> > #define X86_FEATURE_RTM ( 9*32+11) /* Restricted >> > Transactional Memory */ >> > #define X86_FEATURE_CQM ( 9*32+12) /* Cache QoS Monitoring >> > */ >> > #define X86_FEATURE_MPX ( 9*32+14) /* Memory Protection >> > Extension */ >> > +#define X86_FEATURE_RDT_A ( 9*32+15) /* Resource Director Technology >> > Allocation */ >> > #define X86_FEATURE_AVX512F ( 9*32+16) /* AVX-512 Foundation */ >> > #define X86_FEATURE_AVX512DQ ( 9*32+17) /* AVX-512 DQ (Double/Quad >> > granular) Instructions */ >> > #define X86_FEATURE_RDSEED ( 9*32+18) /* The RDSEED instruction */ > I think these #defines are specific to Intel. I would prefer if we > have _INTEL_ somewhere in them.
While that isn't a horrible idea, it's also not something that we've enforced at *all* in the past. Would you suggest that we do this only for features in the generic CPUID leaves, or all features?