[
https://issues.apache.org/jira/browse/CRYPTO-33?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15261964#comment-15261964
]
Emmanuel Bourg commented on CRYPTO-33:
--------------------------------------
Having the same names in Crypto and in the JDK is a nice feature IMO. It means
people can just switch the import statements and benefit from the speed
improvements (assuming the API is similar).
> SecureRandom shadows JVM class
> ------------------------------
>
> Key: CRYPTO-33
> URL: https://issues.apache.org/jira/browse/CRYPTO-33
> Project: Commons Crypto
> Issue Type: Bug
> Reporter: Sebb
> Assignee: Xianda Ke
>
> The SecureRandom interface also exists as a class in java.security.
> This makes it awkward to use, for example in JavaSecureRandom the fully
> qualified name has to be used for the java class.
> Ideally it should be renamed.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)