[
https://issues.apache.org/jira/browse/CRYPTO-33?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15261557#comment-15261557
]
Jerry Chen commented on CRYPTO-33:
----------------------------------
We will use the following naming convention to avoid shadowing java classes.
Cipher -> CryptoCipher
SecureRandom -> CryptoRandom
CipherInputStream -> CryptoInputStream
CipherOutputStream -> CryptoOutputStream
CTRCipherInputStream -> CTRCryptoInputStream
CTRCipherOutputStream -> CTRCryptoOutputStream
...
> SecureRandom shadows JVM class
> ------------------------------
>
> Key: CRYPTO-33
> URL: https://issues.apache.org/jira/browse/CRYPTO-33
> Project: Commons Crypto
> Issue Type: Bug
> Reporter: Sebb
>
> The SecureRandom interface also exists as a class in java.security.
> This makes it awkward to use, for example in JavaSecureRandom the fully
> qualified name has to be used for the java class.
> Ideally it should be renamed.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)