[
https://issues.apache.org/jira/browse/CRYPTO-33?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15259809#comment-15259809
]
Sebb commented on CRYPTO-33:
----------------------------
Name clashes *do* affect developers if they use an IDE.
e.g. Several times I have had java.sql.Date come up instead of java.util.Date.
We should not be making the situation worse.
Here are some suggestions:
CipherInputStream => CryptoInputStream
SecureRandom => ISecureRandom (interface) or CryptoRandom
Cipher => ICipher (interface)
It's better to use redundancy in the name than to have ambiguous names.
> SecureRandom shadows JVM class
> ------------------------------
>
> Key: CRYPTO-33
> URL: https://issues.apache.org/jira/browse/CRYPTO-33
> Project: Commons Crypto
> Issue Type: Bug
> Reporter: Sebb
>
> The SecureRandom interface also exists as a class in java.security.
> This makes it awkward to use, for example in JavaSecureRandom the fully
> qualified name has to be used for the java class.
> Ideally it should be renamed.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)