Hmm, I have to disagree…

1. Just as intuitive as the whole list() construct. I don’t see where this 
particular addition adds any strangeness.

For your readability/hard to read code problem I think the RFC is just doing a 
bad formatting job:

list("name"     => $this->name,
      "colour"   => $this->colour,
      "age"      => $this->age,
      "cuteness" => $this->cuteness) = $attributes;

Would be how I’d format that. Makes it pretty obvious which keys are used (nice 
list from top to bottom) and makes it nicely visible what the origin array is, 
it being very prominently on the right.
And at that point (also that I only have to parse the origin array only once) 
it presents a nice readability improvement.

And the 3. point regarding future scope is irrelevant. It’s something this RFC 
would make possible, but it by far doesn’t mean that it will ever come - it’s 
just future scope. Ignore it.

Hence I ultimately think this RFC is a good idea.

Thanks,
Bob

> Am 9.2.2016 um 16:36 schrieb guilhermebla...@gmail.com:
> 
> Here is my reasons for no:
> 
> 1- Non-intuitive behavior
> 2- Hard to read code, takes more time to understand underlying logic/flow
> 3- YAANPI => Yet Another Alternate Named Parameters Implementation (when I
> look at future scope)
> 4- Most common usage form (first example) still forces you to type almost
> same amount of logic with less readability and little value
> 
> Regards,
> 
> On Tue, Feb 9, 2016 at 1:50 AM, Joe Watkins <pthre...@pthreads.org> wrote:
> 
>> Morning internalz,
>> 
>>    As mentioned the future scope stuff is scary, but not enough on it's
>> own to vote no.
>> 
>>    So I want to vote yes, but I'm just waiting to hear objections from no
>> voters, in case they thought of something I didn't ...
>> 
>> Cheers
>> Joe
>> 
>> On Mon, Feb 8, 2016 at 8:18 PM, Andrea Faulds <a...@ajf.me> wrote:
>> 
>>> Hi again,
>>> 
>>> There's been a lot of No votes on this RFC, but I haven't received much
>>> feedback as to why. Would any of you mind sharing your reasons, if
>>> possible? It would be helpful if I knew why people have voted against it,
>>> as then I might be able to modify the RFC to be more palatable, or
>>> understand where I went wrong.
>>> 
>>> Thanks!
>>> 
>>> 
>>> Andrea Faulds wrote:
>>> 
>>>> Hi everyone,
>>>> 
>>>> It's been more than two weeks since I first proposed this RFC, and
>>>> there's no outstanding issues preventing moving towards a vote. There's
>>>> not yet a language specification patch, but that can be done later.
>>>> 
>>>> So, I'm opening the vote on this RFC today, 2016-02-05, and it'll close
>>>> the Sunday after next, 2016-02-14. The vote requires a 2/3 majority as
>>>> it's a language change.
>>>> 
>>>> The RFC page is here: https://wiki.php.net/rfc/list_keys
>>>> 
>>>> Happy voting!
>>>> 
>>> 
>>> 
>>> --
>>> Andrea Faulds
>>> https://ajf.me/
>>> 
>>> --
>>> PHP Internals - PHP Runtime Development Mailing List
>>> To unsubscribe, visit: http://www.php.net/unsub.php
>>> 
>>> 
>> 
> 
> 
> 
> -- 
> Guilherme Blanco
> MSN: guilhermebla...@hotmail.com
> GTalk: guilhermeblanco
> Toronto - ON/Canada



Bob




Reply via email to