11.02.2020 14:00, Richard Earnshaw (lists) wrote: > +(define_insn "*doloop_end" > + [(parallel [(set (pc) > + (if_then_else > + (ne (reg:SI LR_REGNUM) (const_int 1)) > + (label_ref (match_operand 0 "" "")) > + (pc))) > + (set (reg:SI LR_REGNUM) > + (plus:SI (reg:SI LR_REGNUM) (const_int -1)))])] > + "TARGET_32BIT && TARGET_HAVE_LOB && !flag_modulo_sched" > + "le\tlr, %l0") > > Is it deliberate that this pattern name has a '*' prefix? doloop_end > is a named expansion pattern according to md.texi. > > R.
21.02.2020 18:30, Kyrill Tkachov wrote: > +;; Originally expanded by 'doloop_end'. > +(define_insn "doloop_end_internal" > > We usually prefer to name these patterns with a '*' in front to > prevent the gen* machinery from generating gen_* unneeded expanders > for them if they're not used. > It seems you and Richard asking Andrea to do the opposite things. :) LOL.patch Roman PS. I don't have an idea what approach is correct.