On Mon, Dec 11, 2017 at 01:26:42PM +0100, Eric Botcazou wrote: > > Ah, that makes a lot of sense. So like this? > > > > 2017-12-11 Jakub Jelinek <ja...@redhat.com> > > > > * recog.c (store_data_bypass_p_1): New function. > > (store_data_bypass_p): Handle USE in a PARALLEL like CLOBBER. Use > > store_data_bypass_p_1 to avoid code duplication. Formatting fixes. > > Yes, but I think that you can further simplify the first function: > > rtx out_set = single_set (out_insn); > if (out_set) > return !reg_mentioned_p (SET_DEST (out_set), SET_DEST (in_set)));
Ok. > I also wonder why we have a test on PARALLEL in the first one and an > assertion > on the same PARALLEL in the second one. The old code was inconsistent, had return false; in one case and assert in the remaining two spots. If you are not against it, I'd use return false; in both cases if we want consistency. > No big deal in either case so your call for the definitive version. Jakub