> Ah, that makes a lot of sense. So like this? > > 2017-12-11 Jakub Jelinek <ja...@redhat.com> > > * recog.c (store_data_bypass_p_1): New function. > (store_data_bypass_p): Handle USE in a PARALLEL like CLOBBER. Use > store_data_bypass_p_1 to avoid code duplication. Formatting fixes.
Yes, but I think that you can further simplify the first function: rtx out_set = single_set (out_insn); if (out_set) return !reg_mentioned_p (SET_DEST (out_set), SET_DEST (in_set))); I also wonder why we have a test on PARALLEL in the first one and an assertion on the same PARALLEL in the second one. No big deal in either case so your call for the definitive version. -- Eric Botcazou