On Wed, 2009-04-08 at 07:51 +1000, Noel Butler wrote:
> On Wed, 2009-04-08 at 04:01, Timo Sirainen wrote:
> 
> > deliver is the binary name. but it's configured inside protocol lda {}
> > section. This is getting annoying, any thoughts on what would be a good
> > unifying name?
> > 
> 
> annoying? who complains? I suspect a negligible number of people. 

Me. It makes my code ugly. It makes writing to wiki difficult when you
never know if you should call it deliver or lda. Basically there's no
consistency, which is annoying.

> > a) deliver binary, protocol deliver {}
> > 
> 
> changing protocol would be a huge mistake due to its current widespread
> use and I can envisage many many many complaints of "it stopped working"
> etc,  lets face it, most people don't read changelogs in detail, if at
> all, and almost all are used in automated startups so start-up warnings
> are not really much use.

My plan was to keep it working as protocol lda {} in any case for v1.x
and drop it in v2.0 when there are probably going to be other
configuration changes.

> > c) dovecot-lda binary, protocol lda {}
> 
> if you absolutely must change the binary name, then C would be my
> option, but be warned of the above caution for this as well. 

C is beginning to sound pretty good.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to