[ 
https://issues.apache.org/jira/browse/KAFKA-648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13549075#comment-13549075
 ] 

Jun Rao commented on KAFKA-648:
-------------------------------

Thanks for patch v4. Made another pass. Should we make the following changes?

40. KafkaConfig:
max.message.size => max.message.bytes
socket.send.buffer => socket.send.buffer.bytes
socket.receive.buffer => socket.receive.buffer.bytes
log.segment.size => log.segment.bytes
log.retention.size => log.retention.bytes
log.flush.interval => log.flush.interval.messages
log.default.flush.interval.ms => log.flush.interval.ms
log.flush.intervals.ms.per.topic => log.flush.interval.ms.per.topic
replica.socket.buffersize => replica.socket.receive.buffer.bytes
replica.fetch.size => replica.max.fetch.bytes
fetch.request.purgatory.purge.interval => 
fetch.purgatory.purge.interval.requests
producer.request.purgatory.purge.interval => 
producer.purgatory.purge.interval.requests
replica.max.lag.time.ms => max.replica.lag.time.ms
replica.max.lag.bytes => max.replica.lag.bytes
replica.fetch.max.wait.ms => max.replica.fetch.wait.ms
replica.fetch.min.bytes => min.replica.fetch.bytes

41. ProducerConfig: producer.retry.count. In other configs we have 
num.network.threads. To be consistent, shouldn't we use num.producer.retries?

42. AsyncProducerConfig:
queue.time => queue.time.ms
buffer.size => socket.send.buffer.bytes

43. ConsumerConfig:
socket.buffer.size => socket.receive.buffer.bytes
fetch.size => max.fetch.bytes

                
> Use uniform convention for naming properties keys 
> --------------------------------------------------
>
>                 Key: KAFKA-648
>                 URL: https://issues.apache.org/jira/browse/KAFKA-648
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.8
>            Reporter: Swapnil Ghike
>            Assignee: Sriram Subramanian
>            Priority: Blocker
>             Fix For: 0.8, 0.8.1
>
>         Attachments: configchanges-1.patch, configchanges-v2.patch, 
> configchanges-v3.patch, configchanges-v4.patch
>
>
> Currently, the convention that we seem to use to get a property value in 
> *Config is as follows:
> val configVal = property.getType("config.val", ...) // dot is used to 
> separate two words in the key and the first letter of second word is 
> capitalized in configVal.
> We should use similar convention for groupId, consumerId, clientId, 
> correlationId.
> This change will probably be backward non-compatible.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to