----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/41431/#review110852 -----------------------------------------------------------
ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java (line 71) <https://reviews.apache.org/r/41431/#comment170868> Nit: Whitespace at the end of the declaration needs to be removed. ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java (line 127) <https://reviews.apache.org/r/41431/#comment170870> expiration queue length is fixed at 11? Shouldn't it be a configurable value? ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java (line 235) <https://reviews.apache.org/r/41431/#comment170878> Given the assertion below, you should rename this method to returnSessionToPool or something like that if it is guaranteed to be a pool session or change the assertion below. ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java (line 247) <https://reviews.apache.org/r/41431/#comment170879> Change this assertion or change the method name. ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java (line 247) <https://reviews.apache.org/r/41431/#comment170881> Change this assertion or the method name because it does not look like this was the intention from the previous code. ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java (line 449) <https://reviews.apache.org/r/41431/#comment170912> Can you raise a jira for follow up on this? ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java (line 459) <https://reviews.apache.org/r/41431/#comment170940> Can you add more comments here explaining the states and how the interaction with the session pool occurs. - Vikram Dixit Kumaraswamy On Dec. 16, 2015, 1:57 a.m., Sergey Shelukhin wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/41431/ > ----------------------------------------------------------- > > (Updated Dec. 16, 2015, 1:57 a.m.) > > > Review request for hive, Siddharth Seth and Vikram Dixit Kumaraswamy. > > > Repository: hive-git > > > Description > ------- > > see JIRA > > > Diffs > ----- > > common/src/java/org/apache/hadoop/hive/conf/HiveConf.java 243f281 > ql/src/java/org/apache/hadoop/hive/ql/exec/mr/ExecDriver.java 971dac9 > ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezJobMonitor.java f6bc19c > ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionPoolManager.java > 0d84340 > ql/src/java/org/apache/hadoop/hive/ql/exec/tez/TezSessionState.java e1a8041 > ql/src/java/org/apache/hadoop/hive/ql/session/SessionState.java c066c7a > ql/src/test/org/apache/hadoop/hive/ql/exec/tez/SampleTezSessionState.java > d55c9fe > ql/src/test/org/apache/hadoop/hive/ql/exec/tez/TestTezSessionPool.java > 11c0325 > > Diff: https://reviews.apache.org/r/41431/diff/ > > > Testing > ------- > > > Thanks, > > Sergey Shelukhin > >