-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/831/#review753
-----------------------------------------------------------



trunk/metastore/if/hive_metastore.thrift
<https://reviews.apache.org/r/831/#comment1571>

    How about calling it get_multi_table instead? multi_get_table sounds little 
confusing to me.



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
<https://reviews.apache.org/r/831/#comment1572>

    You can write this more concisely using commons-lang utility method as: 
StringUtils.join(tbls,',');



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
<https://reviews.apache.org/r/831/#comment1576>

    You can get rid of tables.get(i) == null check that will never be true.



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
<https://reviews.apache.org/r/831/#comment1573>

    Instead of throwing RuntimeException, create MetaException and throw that.



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/RawStore.java
<https://reviews.apache.org/r/831/#comment1574>

    Please add javadocs for new methods introduced in interface. Also see my 
first comment for name.



trunk/service/src/test/org/apache/hadoop/hive/service/TestHiveServer.java
<https://reviews.apache.org/r/831/#comment1575>

    This test really belongs in the TestMetastore or some such in metastore dir 
not in HiveServer.


- Ashutosh


On 2011-06-02 23:01:00, Sohan Jain wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/831/
> -----------------------------------------------------------
> 
> (Updated 2011-06-02 23:01:00)
> 
> 
> Review request for hive, Paul Yang and Ashutosh Chauhan.
> 
> 
> Summary
> -------
> 
> Created a function "multi_get_table" that retrieves multiple tables on one 
> trip to the hive metastore, saving round trip time.
> 
> 
> This addresses bug HIVE-2188.
>     https://issues.apache.org/jira/browse/HIVE-2188
> 
> 
> Diffs
> -----
> 
>   trunk/metastore/if/hive_metastore.thrift 1130342 
>   
> trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java 
> 1130342 
>   trunk/metastore/src/java/org/apache/hadoop/hive/metastore/ObjectStore.java 
> 1130342 
>   trunk/metastore/src/java/org/apache/hadoop/hive/metastore/RawStore.java 
> 1130342 
>   trunk/service/src/test/org/apache/hadoop/hive/service/TestHiveServer.java 
> 1130342 
> 
> Diff: https://reviews.apache.org/r/831/diff
> 
> 
> Testing
> -------
> 
> Added a test case to testMetasore() in TestHiveServer.  Also tested for speed 
> improvements in a client session.
> 
> 
> Thanks,
> 
> Sohan
> 
>

Reply via email to