Hi Ferruh, > -----Original Message----- > From: Yigit, Ferruh > Sent: Wednesday, December 7, 2016 2:26 PM > To: Lu, Wenzhuo <wenzhuo...@intel.com>; dev@dpdk.org > Cc: Iremonger, Bernard <bernard.iremon...@intel.com> > Subject: Re: [dpdk-dev] [PATCH v2 16/32] net/i40e: add set VF VLAN insert > function > > On 12/7/2016 3:31 AM, Wenzhuo Lu wrote: > > Support inserting VF VLAN id from PF. > > User can call the API on PF to insert a VLAN id to a specific VF. > > Same comment with prev patch, does it make sense to insert " from PF" to > patch title?
Consistency in the patch titles makes sense. "set VF VLAN filter from PF" might be better. > > > > Signed-off-by: Bernard Iremonger <bernard.iremon...@intel.com> > > --- > > drivers/net/i40e/i40e_ethdev.c | 53 > +++++++++++++++++++++++++++++++ > > drivers/net/i40e/rte_pmd_i40e.h | 19 +++++++++++ > > drivers/net/i40e/rte_pmd_i40e_version.map | 1 + > > 3 files changed, 73 insertions(+) > > > > diff --git a/drivers/net/i40e/i40e_ethdev.c > > b/drivers/net/i40e/i40e_ethdev.c index 253209b..c571d8b 100644 > > --- a/drivers/net/i40e/i40e_ethdev.c > > +++ b/drivers/net/i40e/i40e_ethdev.c > > @@ -10361,3 +10361,56 @@ static void i40e_set_default_mac_addr(struct > rte_eth_dev *dev, > > else > > return -EINVAL; > > } > > + > > +int rte_pmd_i40e_set_vf_vlan_insert(uint8_t port, uint16_t vf_id, > > + uint16_t vlan_id) > > +{ > > + struct rte_eth_dev *dev; > > + struct rte_eth_dev_info dev_info; > > + struct i40e_pf *pf; > > + struct i40e_pf_vf *vf; > > + struct i40e_hw *hw; > > + struct i40e_vsi *vsi; > > + struct i40e_vsi_context ctxt; > > + int ret; > > + > > + RTE_ETH_VALID_PORTID_OR_ERR_RET(port, -ENODEV); > > + > > + dev = &rte_eth_devices[port]; > > + rte_eth_dev_info_get(port, &dev_info); > > + > > + pf = I40E_DEV_PRIVATE_TO_PF(dev->data->dev_private); > > + hw = I40E_PF_TO_HW(pf); > > + > > + /** > > + * return -ENODEV if SRIOV not enabled, VF number not configured > > + * or no queue assigned. > > + */ > > + if (!hw->func_caps.sr_iov_1_1 || pf->vf_num == 0 || > > + pf->vf_nb_qps == 0) > > + return -ENODEV; > > + > > + if (vf_id > pf->vf_num) if (vf_id >= pf->vf_num) would be better. > This check was [1] in prev patches: > [1] > if (vf_id > pf->vf_num - 1 || !pf->vfs) if (vf_id >= pf->vf_num || !pf->vfs) would be better. > > > + return -EINVAL; > > + > > + if (vlan_id > 4095) > > Can there be any define in base driver for this? Or ETH_VLAN_ID_MAX > perhaps? ETHER_MAX_VLAN_ID in rte_ether.h should be used . > > + return -EINVAL; > > + > > + vf = &pf->vfs[vf_id]; > > + vsi = vf->vsi; > > + > > + vsi->info.valid_sections = > cpu_to_le16(I40E_AQ_VSI_PROP_VLAN_VALID); > > + vsi->info.port_vlan_flags |= I40E_AQ_VSI_PVLAN_INSERT_PVID; > > + vsi->info.pvid = vlan_id; > > + > > ---> > > + memset(&ctxt, 0, sizeof(ctxt)); > > + (void)rte_memcpy(&ctxt.info, &vsi->info, sizeof(vsi->info)); > > + ctxt.seid = vsi->seid; > > + > > + hw = I40E_VSI_TO_HW(vsi); > > + ret = i40e_aq_update_vsi_params(hw, &ctxt, NULL); > > + if (ret != I40E_SUCCESS) > > + PMD_DRV_LOG(ERR, "Failed to update VSI params"); > <----- > > If Wenzhuo prefers to extract this part into a function, it can be re-used > here > too. > > <...>