On 2023/3/7 0:13, Thomas Monjalon wrote: > The impact of the option "enable_iova_as_pa" is explained for users. > > Also the code flag "RTE_IOVA_AS_PA" is renamed as "RTE_IOVA_IN_MBUF" > in order to be more accurate (IOVA mode is decided at runtime), > and more readable in the code. > > Similarly the drivers are using the variable "require_iova_in_mbuf" > instead of "pmd_supports_disable_iova_as_pa" with an opposite meaning. > By default, it is assumed that drivers require the IOVA field in mbuf. > The drivers which support removing this field have to declare themselves. > > If the option "enable_iova_as_pa" is disabled, the unsupported drivers > will be listed with the new reason text "requires IOVA in mbuf". > > Suggested-by: Bruce Richardson <bruce.richard...@intel.com> > Signed-off-by: Thomas Monjalon <tho...@monjalon.net> > ---
... > compile_time_cpuflags = [] > subdir(arch_subdir) > diff --git a/doc/guides/rel_notes/release_22_11.rst > b/doc/guides/rel_notes/release_22_11.rst > index 91414573bd..c67c2823a2 100644 > --- a/doc/guides/rel_notes/release_22_11.rst > +++ b/doc/guides/rel_notes/release_22_11.rst > @@ -504,7 +504,7 @@ ABI Changes > ``rte-worker-<lcore_id>`` so that DPDK can accommodate lcores higher than > 99. > > * mbuf: Replaced ``buf_iova`` field with ``next`` field and added a new field > - ``dynfield2`` at its place in second cacheline if ``RTE_IOVA_AS_PA`` is 0. > + ``dynfield2`` at its place in second cacheline if ``RTE_IOVA_IN_MBUF`` is > 0. Should add to release 23.03 rst. The original 22.11 still have RTE_IOVA_AS_PA definition. ... > diff --git a/drivers/net/hns3/meson.build b/drivers/net/hns3/meson.build > index e1a5afa2ec..743fae9db7 100644 > --- a/drivers/net/hns3/meson.build > +++ b/drivers/net/hns3/meson.build > @@ -13,9 +13,7 @@ if arch_subdir != 'x86' and arch_subdir != 'arm' or not > dpdk_conf.get('RTE_ARCH_ > subdir_done() > endif > > -if dpdk_conf.get('RTE_IOVA_AS_PA') == 0 > - build = false > - reason = 'driver does not support disabling IOVA as PA mode' > +if not get_option('enable_iova_as_pa') > subdir_done() > endif Suggest keep original, and replace RTE_IOVA_AS_PA with RTE_IOVA_IN_MBUF: if dpdk_conf.get('RTE_IOVA_IN_MBUF') == 0 subdir_done() endif Meson build 0.63.0 already support deprecated a option by a new option. When update to the new meson verion, the drivers' meson.build will not be modified. > > diff --git a/drivers/net/ice/ice_rxtx_common_avx.h > b/drivers/net/ice/ice_rxtx_common_avx.h > index e69e23997f..dacb87dcb0 100644 ...